76Views4Replies

Author Options:

Linkit One not working Answered

I have a Linkit One that keeps disappearing from my ports when I try to upload a sketch. I was doing some testing of a sketch I had made and I keep getting the message that there was not board on the port I had selected. I have successfully uploaded sketches with this setup before. This was on a Macbook Pro running Yosemite 10.10.5.

After several attempts to fix the problem I moved my setup to my Windows 7 machine. The issue is similar. I cannot get the board to remain visible on the port for any amount of time. I plug it in and it shows up for a few second before disappearing again. I fear my board's usb port has gone bad. I can upload to my arduino uno with no problems.  

If it is a bad usb port is there anything I can do? Can I upload sketches another way? I would hate to lose the use of this board. Thanks for your time.

Discussions

0
None
Downunder35m

3 years ago

If it is recognised under Windows but disapears right after then it is usually a power problem.
Windows checks the USB port for the presence of something, when you connect your Linkit the device is powered up and exchanges the ID and other things with the host.
Unless you use the wrong driver the disappearing can mean that there is not enough power getting to the device to keep it powered.
I assume you already tried different cables but have you tried with power on the battery connector?
That should make sure the device has enough juice and should use the USB connection only for data.
Be sure to have the switches in the right position!
If all fails you should still be able to flash your sketches using the SPI connection but that would require an Arduino or dedicated flasher.
I guess you also checked here already?

0
None
ehudwillDownunder35m

Reply 3 years ago

Thanks for the suggestions. A powered USB hub got it working again.

0
None
ehudwillPenolopy Bulnick

Reply 3 years ago

I did go to the MediaTek forums. I did not get any replies to my problem. I got a powered USB hub and it works now. It was odd that it worked well for several months before needing a powered hub to work. Thanks for the suggestions.