84Views2Replies

Author Options:

My Arduino UNO is no longer communicating with computer Answered

Hi, I own the Freenove UNO (identical to the Arduino UNO) and it has been working fine with my laptop (Win10 and using the Arduino IDE program) but recently it stopped communicating with the laptop. I have reinstalled the Arduino IDE program (tried uninstalling and reinstalling a few times, including installing an older version of the IDE) and have tried it on 3 different computers (2 running Windows 10 and one on Win7) with 2 different USB A-Bvcables, but still, when you plug it into a computer the on and L lights turn on so it is receiving power but code won't upload and it doesn't communicate the device I am not sure what to do. In the past, I successfully uploaded sketches to the UNO and they worked as expected, so I'm not sure why the UNO would suddenly stop communicating with the computer unless it is fried which would make sense because a week before this I was trying to control my WS2812B LEDs with the UNO but the LEDs need 12 volts so I powered both my LEDs and my UNO with a 12-volt wall adapter I had a 220 resistor but I don’t think it worked because after it smelled funny

In the case, it is fried, I am not sure what to do is there a way to fix a fried Arduino UNO also why would the on led be light up if the Arduino UNO if it fried

Comments

The forums are retiring in 2021 and are now closed for new topics and comments.
1
Orngrimm
Orngrimm

Best Answer 11 months ago

I assume you checked the device manager and no COM-port shows up if you plug the UNO in? Please check and confirm.
If this is the case (No COM-Port) then yes: Something is bad...
Can be either:
- Killed the Power-regulator onboard the UNO (Most likely as you say "Smelled funny")
- Flashed with bad code for another frequency (Killed more than one Arduino pro Micro with uploading code für 8MHz, 3.3V instead 5V and 16MHz)
- Killed CPU somehow

For the most likely cause: You feeding "12V" to the Arduino:
Many cheapo PSU have MUCH more than 12V if they are unloaded... I saw chinese 12V-PSU with over 30V if unloaded... Would kill any Arduino in an instant...
Also, (and i dont know UNO's this well to say for certain) https://www.instructables.com/id/How-to-Fix-Fried-... may be a hint... MAybe it is just the diode needs replacing?
Otherwhise, you need to replace the defective parts on the board. Often after "Smelling funny" they also show discoloration or condensed barker stuff on the board or maybe even cracks in the case of parts... Replace those.

For bad code: You can try to reflash the CPU:
Use a second UNO to flash the defective UNO: https://www.arduino.cc/en/tutorial/arduinoISP

But honestly, if you have time, i dont see it worth my time to try to repair a 3$ UNO and just buy a new one from china. If you want to tackle it as a project for the learning and the project's sake, then, well then it is a different story! :)

To your Q why it lights up if plugged in: The LED you see is on a different powerrail (USB 5V) than the regulated internal voltage.

1
KushagraK7
KushagraK7

Best Answer 11 months ago

Please check the attached circuit schematic. You are powering the 5-volt LEDs and the 5-volt pin of the Arduino with a 12-volt DC power supply. You'll kill the microcontroller and the LEDs if you do so. If a voltage higher than 5-volts gets to any digital I/O or analog pins or any pin which is not supposed to get more then 5-volts will kill the microcontroller as well the programmer chip located close to the USB connector.
I would recommend you to get a new Arduino board and try a Leonardo this time, it has lots of more features than UNO and costs roughly the same.