Author Options:

My Jailbroken iPod Touch 2nd Gen wont install apps from the App Store... HELP PLEASE!!! Answered

My 2nd gen ipod touch jailbroken CORRECTLY by quick freedom, and has worked properly for a month will not properly install apps from the app store. Here is what happens: 1. go into app store and click install app, 2. I enter my password and the buy now button now says installed, but IT IS NOT ON THE HOME SCREEN. On the first occurence of this, it made a lot of bookmarks.PLEASE HELP!?



10 years ago

I would de-jailbreak your iPod. This also happened to me after I did it. If you want I can teach you how to do 3.0 software jailbreak.


Answer 10 years ago

It works now, It was just a firmware error that apple had when sending out the 3.0 firmware via a wireless n+ network Which I happened to have. Now it is fixed. thanks for the re-jailbreak offer, but I own a software company so I am capable of doing it myself.


Answer 6 years ago

how you fix the firmware error? i am having the same problem.

Download SBSettings from Cydia and use it to respring your device. It probably just needs to be resprung (refreshed).