230Views7Replies

Author Options:

My LED circuit suddenly stopped working. Can anyone help? Answered

I set up this really awesome simple circuit for the Chitauri scepter I'm making (so the stone will glow without a visible on/off switch, which will be hidden inside a piece of the scepter), and of course, the instant I tried to install it, it stopped working.  I thought perhaps it shorted out because the resin for the stone didn't set properly, but now I'm not sure.  

It's set up like this (going from the power source to the LED, and back).

Power source: 9V
ON/OFF toggle I pillaged from the battery pack
330 Ohm resistor
Blue LED from Radio Shack (max voltage 3.8V)
Back to Power source.

I've checked everything, and used multiple batteries to double-check.  I even entirely re-did the circuit to make sure that cleaning off the uncured resin didn't mess with anything, and it's still dead in the water.  What did I do wrong?

Discussions

0
None
Downunder35m

3 years ago

I have no clue about the current requirements of your LED but did you check if your battery is still providing 9V?
Otherwise please provide full details for a more detailed answer.

0
None
KateM28Downunder35m

Answer 3 years ago

I'm not incredibly used to working with circuits, but I definitely checked my 9V, and it's working. Even bought a bunch of extra to check.

As far as I am knowledgeable about the circuit, however, I am being as detailed as I can.

0
None
hulkbuild

3 years ago

Make sure you get the polarity of the LED correct. I have gotten this mixed up before. They usually have a flat side which connects to negative.

0
None
KateM28hulkbuild

Answer 3 years ago

Definitely got the polarity right. Thanks for the double-check, though!

0
None
Josehf Murchison

3 years ago

Your resistor is a little small at 330 ohm the diode is getting 0.027 amp most LEDs are 0.02 amp or less. Try a 470 or 680 ohm resistor to get your current under 0.02 amp.

It may take the current for a time but it wont last.

Then check your battery and switch to make sure they are working.

Last make sure your resin is not conductive when fully set and you got all the old resin off, even a small amount can mess you up.

0
None
Josehf Murchisonsteveastrouk

Answer 3 years ago

First in the real world electronics is
ball parks.

10% resistor 330 Ω is 297 Ω to 363 Ω.

With LEDs at Radio Shack they tend to
post the max 3.8 v, can be as little as 2.6 v.

20 mA typical max can be as little as 15
mA max, most work well with as little as 5 mA.

9 v battery can be as high as 10.5 v.

10.5 volts – 2.6 = 7.9 volts/297 Ω = 27
mA

If you do not consider the
semiconductors voltage drop you will be in the safe ball park every time.

0
None
steveastroukJosehf Murchison

Answer 3 years ago

In the real world, the last time I used a 10% resistor was over 30 years ago. I stand by my number, on low voltages, you should consider the forward drop of the LED.

0
None
Josehf Murchisonsteveastrouk

Answer 3 years ago

In the real world I work with resistors up to 20% I used 10% for the middle.

and Radio Shack sells 10% resistors they are the ones with the Silver Tolerance band.