2306Views13Replies

Author Options:

My solid-state relay keeps blinking a lightbulb while in the inactive state, how can I eliminate that? Answered

I have a DC controlling AC solid state relay connected to an arduino diode for control and a light  bulb to the 220 side.
While there is no signal coming from the arduino the bulb is blinking insanely fast, when there is arduino signal, the light remains constantly on as intended.
How can i make sure there is no load at all on the 220 end while the relay is inactive, so there is no light flickering?
Relay specifications:
Control: 3/32VDC
Output: 48-480VAC 50/60Hz

Thanks in advance!

Comments

The forums are retiring in 2021 and are now closed for new topics and comments.
0
pro2xy
pro2xy

9 years ago

Did the problem get solved?

0
TenshiKiri
TenshiKiri

Answer 9 years ago

I haven't managed to test with higher load yet, so... :P

0
pro2xy
pro2xy

Answer 9 years ago

Uhh.. Ok. I was wondering if it could be the noise on your signal lines. I would suggest you to put a pulldown resistor. But the experts here didn't mention it here so I'm like............ :P

0
TenshiKiri
TenshiKiri

Answer 9 years ago

It's 220v AC, straight off the wall's plug.

0
steveastrouk
steveastrouk

Answer 9 years ago

LOAD. Not voltage.

0
TenshiKiri
TenshiKiri

Answer 9 years ago

Sorry, morning posting at it's finest :P
I had only one economy bulb on the circuit of probably 15-20 Watts. the relay indicates 25A as it's limit.

0
steveastrouk
steveastrouk

Answer 9 years ago

Try a much bigger bulb, in the first instance. I suspect you are getting false triggering on the low current device. I'm not saying its the answer, I just want to use it as diagnosis. Its a known problem in SSRs that are very lightly loaded.

Disconnect the arduino and short the input to the SSR. Do you still see false triggering ?

Steve

0
TenshiKiri
TenshiKiri

Answer 9 years ago

I have tried shorting the input, no different effects at all.
I am about to try with higher load and post the results, just as long as i find some free time ><

0
lemonie
lemonie

9 years ago

While there is no signal coming from the arduino the bulb is blinking insanely fast

-Does the relay behave the same if you completely disconnect the signal?
I should think not, and that there is a signal when there shouldn't be.

L

0
TenshiKiri
TenshiKiri

Answer 9 years ago

I completelly disconnected the signal ends and it kept blinking.

0
lemonie
lemonie

Answer 9 years ago

It only stops when you apply signal?
The relay sounds defective now.

L

0
TenshiKiri
TenshiKiri

Answer 9 years ago

Without signal, it blinks, with signal, it is constantly active as intended!