66Views2Replies

Author Options:

One bug, one inconvenience Answered

Hey all, Instructables is an amazing website, spend a lot of time in the electronics section! Haven't had time to make my first instructable yet, but getting ready too shortly! I found two bugs, one that doesn't hinder usability but it has a huge annoyance factor, and the other is an inconvenience more or less.

The first one:
Ironically I found this while looking at pictures of bugs people had previously submitted in the comments of the featured bugs article. When you click on the image to view it in the light-box some of the objects on the page ALWAYS show up in front of the light-box. This makes me believe that the Z-Index is possibly set too high on those objects, haven't had a chance to play around in FireBug and propose a solution as of yet though. I have attached the screenies of this problem below. I only took screen-shots of the problem on this specific page, but rest assured it does it on every single page I have checked. I figured this pair of images is enough.

Second "bug" (not so much a bug as a recommendation here):
When posting in the forums I ALWAYS have to do the "Select a category group and category" step in my post. I understand that if I wasn't already inside a specific forum (category) when I clicked the new topic button it wouldn't already know where I wanted to post to, but seeing as you don't have this button until you are inside a category it should be able to fill this in for you. For example I was inside the "bugs" category in the "help" category group when I clicked the "New Topic" button, it wouldn't be too difficult to have that button pass a parameter to allow those boxes to automatically have the right selection, but keep them selectable just in case someone would want to change where it was posted.

Computer 1 specs:
OS: Both Ubuntu 11.10 (x86 and x64) and Windows 7 (x64)
Browsers: Firefox 8.0, Chromium 15.0.874.106 (Developer Build 107270 Linux)
CPU: Core 2 Duo e5700
RAM: 8 Gb
GPU: NVIDIA GeForce 7300 (Driver Version 2.1.2)

Computer 2 Specs (My web development machine):
OS: Windows 7 SP1 (x64) and XP Pro SP3 (x86)
Browsers: Firefox 9.0.1, IE 9.0.8812.16421, Chrome 16.0.912.63, Safari 5.1.2, Opera 11.60
CPU: Core i5 m520
RAM: 8Gb
GPU: ATI Radeon HD 5470

I was able to replicate this issue across 3 operating systems with various levels of installed updates, and across every single common browser, updated to their latest versions for the specific operating systems. In supporting browsers using compatibility mode this problem wasn't present, but as previous posts stated paddings, menus and some other items move around the site or collapse on themselves, specifically on the front page using internet explorer. These bugs were replicated using both 32 bit and 64 bit versions of operating systems, and on 64 bit operating systems it was tested on both the 32 and 64 bit browsers.

Comments

The forums are retiring in 2021 and are now closed for new topics and comments.
0
Jayefuu
Jayefuu

9 years ago

The first one's definitely already been reported. It's been known about for some time :( If you're not logged in as pro the adverts also have the wrong Z-index, sometimes making them appear in front of the image.