Author Options:

Potentiometer not working after connected to wires Answered

I'm fairly new to electronics and I'm trying to learn it with my Arduino. Recently I have been working on a project that involves 4 potentiometer(pot). I'm using one 1k pot and 3 10k pot. The pot is used to send signals to the analog inputs of the arduino. To test the pots I used a simple serial.println program that sends the value of the pot from 0 - 1023. When I connect the pot through its 3 pins directly to the breadboard, all of them work perfectly fine and gives me a stable value as I turn the pot.

However, when I soldered three wires to them each, 2 of them work and 2 of them didnt. The 1k and one of the 10k pot didnt work. When I connected it through its wires, the values it gave kept jumping even when I'm not turning the knob and sometimes it will just stay one value when I'm turning it or not. Why is this happening? Did I overheat the pot when soldering?

I took some new pots and tested them again through the pins directly and it worked perfectly fine. But when I soldered the wires to it, this time the 10k worked fine and the 1k didnt work. It gave the same problem as the ones before.

Please help me with this problem. I have attached the pictures of the pots that didn't work. Please help me check if my soldering is anything wrong. I have checked online couldn't fine anyone experiencing the same problem.



The forums are retiring in 2021 and are now closed for new topics and comments.

5 years ago

It looks like the pictures didn't attach. Try again.

Solder joints should look nice and shiny. Check to see that the spots where you soldered too are isolated and not shorting out. Are the pieces of wire good with no internal breaks. A cheap multimeter helps out. Tin the wire ends first and then solder it to the tabs on the pot. Twist stranded wire ends together and tin so you have one solid lead to solder on the tab. Have solder wick or a pump desolderer to remove the solder and re solder on the joint, don't flood with more solder. Are you using rosin flux core solder and a 30 watt soldering iron? Clean the tip when hot with a wet sponge or those stranded metal pads.


Reply 5 years ago

Oh im sorry, I just attached it again. Anyway I just checked the latest 1k pot and it works after 2 days but the other 2 still doesnt work. Even with multimeter it shows resistance infinity for the first 2 pots. I probably burn the wire inside or something. The rating on my iron says 30W-120W. But thanks for the help.