Author Options:

Problems with Mousey the Junkbot... Answered

I am a young boy with an interest in robots (and electronics). I recently attempted to build my first robot (Mousey the Junkbot.) Unfortunately it did not go well. I was hoping someone would be able to help me. I have tried to wire it up and when I try to run it, I run into a few problems. the motor wires from the relay are like positive and negative leads. when i hook them up to the positive leads on the motor, the ground connection coming from the LM386 basically does nothing and hookup the leads making the motors run like a series circuit. Also, the reverse switch just makes the motors stop for a few seconds then the motors start up again. When i press the reverse switch, sometimes (not always) the relay clicks, then rattles, and the wires become significantly warmer. There are a few variances in my robot than specified. They are: I am using a 12v computer relay instead of a 5v relay, and i am using an LM386N-1 chip instead of the LM386. I believe the problem is the relay, but i have the understanding that the relay is only used for the reverse circuit. if so, is it possible to omit the relay and try to only make it "Light Seeking" without the runaway circuit? Also, I am deeply confused with the wiring for the light sensors. i have found that Make Magazine says to put it in series with the Led, the "corrected" circuit diagram shows it connected to the positive lead of the Led, and the Instructable shows it should be connected to common ground. I hope you can help me! Thanks!


The forums are retiring in 2021 and are now closed for new topics and comments.

Best Answer 10 years ago

You mention Make Magazine, so I suspect you're following these instructions.

You might find these or these instructions help clarify things.

If you're using a 12v relay it might not be getting quite enough power to switch properly.

The best way to trouble shoot is to start again at the very beginning and double check every single connection, but if stuff is getting warm you may have burned out a component.  After you've verified your connections and polarity of everything, and it's still not working, try removing and testing each component to make sure it actually works.


Answer 10 years ago

I think i may have burnt out my LM386. anyways, i have tried a different approach with a 555 timer and I'm still getting some problems.. any help?
here's a link to my question