94Views2Replies

Author Options:

Programming XMC1100 from Windows10 on a MacBook Pro doesn't work ? Answered

Hello,

I'm trying to get a connection between my Microcomputer XMC1100 and my Windows10 Partition on a MacBook Pro. I've installed the recommended development environment Dave from Infineon and everything works fine except the connection to the microcomputer.

Is this connection maybe due to hardware not possible?  What else could be the reason ?

Please help,
regards 

Discussions

The forums are retiring in 2021 and are now closed for new topics and comments.
0
Downunder35m
Downunder35m

3 years ago

Bit more details please...
Are you trying to establish the connection between the mac and xmc first?
If so: does it work, meaning can you send commands that are being recognised and followed?
I don't do any rotten fruit products, but I know from past experience that communication starts with the basics.
For the XMC to be able to read from a hdd in your mac it must first be able to communicate with the mac.
From there is is back the basics and if still required figuring out where exactly the problem happens.

0
-mister-
-mister-

Reply 3 years ago

The connection between the mac and the xmc was the problem. Fortunately I managed to fix that. The so called J-Link driver wasn't installed correctly.

But now I am stuck with flashing my program on the xmc board. However, next week I'm gonna see somebody who might be able to help. If not, I will post my problem here more detailed and with screenshots maybe.

Anyway, thanks.