Author Options:

Stepper motor vibration/lockup with driver? Answered

I am trying to get a stepper motor to turn using a StepStick driver from Botronicz. I have gotten the driver to work once before, but now it has decided not to work. I have wired my stepper motor (Model STP-42D3018) according to any specs I can find online in a bipolar connection, but when I fire it up the stepper only sits there and vibrates. Or misses steps (depending on voltage). A few other times I had it also where it would step one direction for I think a single step and then step back the other direction. It is really bothering me because I have tried multiple other wiring combinations and have not gotten any of those to work. My current setup is exactly like this (I have checked numerous times). I have also tried changing the vmot supply voltage and current limit, as well as the current limiter pot on the board itself.

If anyone can help it would be greatly appreciated!


The forums are retiring in 2021 and are now closed for new topics and comments.

Best Answer 7 years ago

1: dont leave enable floating, that may be part of your problem, as the driver may be turning itself on and off while stepping. Tie it to + or -, whichever it needs. Then, try reversing one or both coils, as it will do exactly what you said if one is backward.
Also, check that your power supply can handle the motor. If you're powering a 2A motor with a 9v battery, you're not going anywhere.


Answer 7 years ago

Question took 3 days to post... Checked and it was a coil wire with a short. Fixed now (but I did have to pull the enable pin so that helped!)