75Views2Replies

Author Options:

Submit interface very user hostile at least for FireFox Answered

I am trying to create a new Instructable and I find the user interface absolutely user hostile. At least with FireFox. And I hate to use IE. First off I uploaded all the images for the entire article at the same time. They all ended up in the introduction. Then I tried removing all but one but when I saved my changes they were all back. So I had to use IE to remove the images and save the changes. It was not at all clear that removing the images from a step wouldn't remove them permanently. It just so happens that they remain in your "library" but there is nothing telling you that. The documentation for the submittal process is inadequate. Then I did a considerable edit of the text of the intro and saved it. When I preview the change I get the old version and have to manually refresh the page to see changes. I then edited again adding an image from the library and saved the change. It turns out that all the text I edited before did not show up in the edit session because I didn't MANUALLY refresh it before making changes. So I ended up saving the old text minus a lot of changes. So now I have to re-edit everything a second time. This is ridiculous. A real waste of time. Another thing is I can't arrange images with text around them. All images end up at the bottom of the step with only one large size image and a bunch of thumbnails that must be clicked one at a time. This is not how anyone likes to view a step-by-step description. I also can't create a bulleted list for materials. I really think the interface needs a lot of work. These are just basic requirements of any word processing interface. The format needs to be changed to allow a better flow of the instructions with text interspersed with images like a MAKE magazine article. Even this forum interface is defective. Because I didn't enter at least two keywords when I finally did enter them and tried to preview my post this entire post was gone! Fortunately I was using the Save Text Area extension so I had the entire body of the post in my text editor and was able to paste it back. This is ridiculous.

Comments

The forums are retiring in 2021 and are now closed for new topics and comments.
0
gmjhowe
gmjhowe

11 years ago

Im sorry you seem to have had some problems, I have read through your passage, and I think I understand your problems.

Most of the time, people right up the instructable, sometimes in several sessions without any problems, I have had none writing up all mine.

My main advice, is not to browse away from the working page. Open anything new in another tab. Check that the message under 'save now' indicates that it was saved. Then open another tab to 'preview' it. That way, if you have a network hiccup (your end, or at I'bles end) you have not lost anything.

When adding pictures in the first place, there is a tick box that chooses to add all images to first step or not.

If you find that your limited by the way the pictures are laid out in 'step' form. Try making use of image notes to highlight and explain.

Finally, one thing that is not always easily explained is how to do bullet points, these can be added by putting a space, followed by an asterix(*) followed by another space, then your point
 *
  • Like this.

For further text formatting, I would check out this instructable by NachoMahma.

Finally, any further questions, or if you need any help at all, feel free to send me a PM, or reply to this comment.
Picture 1.png
0
Laral
Laral

Reply 11 years ago

Thanks for your reply. That post is interesting but I found nothing that will allow inline images. The image macro has been disabled here. Bulleted lists are created by using * . Other basic things that most blogs and forums do allow are disabled or non-existent. I think this is just basic functionality that is severely lacking.

As for the refresh issue, I found the problem. I had set the about:blank browser.cache.check_doc_frequency entry to 2, 'Never check', in a hope that it would speed up revisiting a page. It did not and I neglected to set it back to the default, 3, 'Check when the page is out of date (automatically determined)'. I reset it and now everything works correctly. Changes are saved and images can be removed too. That's a relief. But the other issues still stand.