76Views0Replies

Author Options:

This site's editor is the worst I have ever used… Answered

This site's editor is the worst I have ever used…

Once again, I have wasted my time in a frustrating effort to simply answer a question in my own Instructable, thanks to the still horrendous forum editor. Even after years of being online, and my and other people's utter frustration with this editor, it is still the worst forum editor on the web.

Let me describe for you my current experience. First of all, I make it a point to compose my message in a text editor because I know from bad experience, that it is a certainty that the editor will lose all text that I enter at some point. OK, so I compose my message which contains some html anchor tags with links and text. I paste it into the text box. I hit the Preview button and nothing happens… Great. I see that NoScript (Firefox 30.0) is showing that there is some javascript that is not enabled. I temporarily enable JS. Poof! My text is gone!!! What did I tell you? I have to keep enabling JS several times to finally get rid of the red barred circle on the NoScript icon. I now re-paste my text that I thankfully still have safely saved in my text editor. Preview still doesn't work so I decide to switch to the Rich Editor. BTW I tried switching to Safari to see if it worked there and it didn't so it is not a browser issue. Now Preview works but all my html code is being shown as code and not nicely formatted text with embedded links. Wonderful. I have no intentions of wasting more time with the Rich Editor, trying to add links in the painfully slow process of point, click, copy, paste. No thanks… So I refresh the page. Poof! Text gone. I re-paste and simply click 'make comment' so I can PREVIEW my post. I need to make a few changes so I have to DELETE the post--there is no way to EDIT it like there is in any other forum I have ever used--and I have to repeat this ridiculous ritual several times to finally get it to the point where I can finally post the comment for real. Keep in mind, I could not use any formatting like bold or italics on any of the text like I wanted to do because there is no longer any markdown language. Formatting is only available in the Rich Editor which I refuse to use for reasons already mentioned. Oh, and one more thing… I tried to upload an image and the server was 'down for maintenance' so I gave up at that point.

I was told that as a PRO member, the editor was an improved version of the normal one. I don't see any improvements.

This and many other similar experiences I have had ONLY on this site, is IMO unacceptable. We all have a life and have much better things to do than waste hours of our own time struggling with an inferior editor in order to freely share our ideas with other people. This in itself is a creativity stifler. I have complained about this before and I probably will again until (IF) this problem is addressed properly. Obviously we the users are the life blood of this site and we deserve much better treatment. Once again, I make no apology for ranting and complaining--Kiteman. This crucial issue needs to be addressed. Get a new webmaster if that's what it takes. The current one is not doing his/her job.

PS

Wow, I had to preview this post before I could publish it and I see that all the breaks between paragraphs have been removed. Unbelievable. Even in an all-text post there are problems, which just serve to emphasize my point.

PS 2

Wait a minute… When I went to edit the post and previewed it, the breaks suddenly miraculously appeared. So not only is the editor flakey, it is unpredictable as well.

Tags:editor

Comments

The forums are retiring in 2021 and are now closed for new topics and comments.