84Views4Replies

Author Options:

UTF-8 Bugs Answered

Adding extended UTF-8 characters to Instructables works the first time, but if I edit the page, the editor replaces them all with broken characters instead. I have to manually edit all the characters back before hitting save, or the broken characters are propagated to the web. The characters that I have tried are capital omega (Ω) and the degree sign (°), and I plan to use lower-case mu (μ) in the future. Also, the bug posting form seems to be much more broken in this regard.

Comments

The forums are retiring in 2021 and are now closed for new topics and comments.
0
_soapy_
_soapy_

12 years ago

Regarding this, I flagged it up ages ago for the (UK pound sign) and (double quote) I just noticed that including the (UK pound sign) prevents the comment preview working in here!

0
CaladanJen
CaladanJen

Reply 12 years ago

It's not just entities that are having problems, but any non-ASCII UTF-8-encoded characters. They seem to work the first time, and then they turn garbled. Unless posting here, of course - the bug reporting forum seems to be totally broken this way. Are all Instructables written in English? My keyboard layout can type all sorts of non-ASCII characters, and I imagine the problem is much worse for other languages that rely on accented characters or other alphabets. It's all γρεεκ to me. Unless it's all garble to me, of course.

0
Lithium Rain
Lithium Rain

Reply 12 years ago

Some instructables are written in other languages, such as Spanish, but they all have to cope with the same problem. It's a real pain. :-(