Author Options:

Unable to program an Arduino micro. Any ideas on how to fix this? Answered

I've been working on a project for some time now, and I plan to embed an arduino micro into it. As such, I just went to do a dry run of the setup with the micro before I started putting it all together. And failed miserably. 

Few things to get out of the way:
-It is an off-brand, but it does have the ATMega 328 at it's core. 
-My computer (win7) does recognize it, although it's as a USB Serial Port (com6) and not an arduino micro 
-I am using the 1.0.5 IDE
-My PC will only see the micro as a USB Serial port on one of my USB ports. On the others, it sees it as a USB hub (and a failed one at that)
-I have tried to manually update the drivers (by pointing windows to the driver folder): it will only say that the correct driver is installed (either the Serial Port or USB Hub) and refuse to go past that
-I also tried to manually assigning the driver via "I have the disc" only to have my PC blue-screen
-I have powercycled. Too many times to count. 
-I have tried with another micro: same issue
-I have tried without anything connected shy of the USB cord and free hanging, to ensure nothing metal was touching it
-The IDE does have the correct setting (correct board selected and COM port)
-I've tried several sketch (mostly those from the "Example" section of the IDE) and each time I get the same error
-I have tried holding the on-board reset button while uploading, letting go just at the moment the IDE says "Uploading"

With what I hope is the obvious stuff covered (though chances are I did miss something stupid, and thats whats causing this) the error I get is as follows:
Binary sketch size: 5,190 bytes (of 28,672 byte maximum)
Found programmer: Id = "B<<g"; type =
         Software Version = . ; Hardware version = .
avrdude: error: buffered memory access not support. Maybe it isn't
a butterfly/AVR109 but a AVR910 device?

I als thought that maybe the bootloader was bad (I'm a tad of a noob to this, so I'm not 100% sure of the above error can be caused due to a poor bootlader) and tried to upload it. This pops up:
avrdude: Error: Could not find USBtiny device (0x1781/0xc9f)

Any help would be greatly appreciated! 


The forums are retiring in 2021 and are now closed for new topics and comments.

Best Answer 6 years ago

With the ATMega 328 you may need to select the Duemilanove board in the IDE. Are you sure the chip is not a fake? Are you sure it has the arduino boot loader on it already?

These kinds of problems are why it's best to buy the real thing instead of a cheap knockoff.


Answer 6 years ago

Your something awesome! That did that trick, and it's taking sketchs, no problems. Thank you so much!!


Answer 6 years ago

I'll try the Diemilonove board here in a moment. As for the chip: I don't know if it's a fake. It looks like the real thing, but thats as promising as a sticker. I'm also not sure the bootloader is on it. The LED does flash, so I would assume so. But I am unable to upload it even if it isn't on there.

And this I do know now. I had a friend who had a handful in a box of junk that I threw a few bucks his was for. So if they fail, now skin off my nose.