Author Options:

Uploading to ATmega328 with preloaded blink sketch through ArduinoISP doesnt work? Answered

I'm using my Arduino Mega as an ISP and have successfully uploaded a blink sketch to an atmega on a breadboard, with the led @ D13. Thats the SCK pin, and now i cant upload another program to the atmega on the breadboard. I tried resetting both the boards JUST before uploading, but it didnt work. my connections are secure, reset pin is tested, auto-reset is off. im at a loss. Please HELP!!!



4 years ago

It could be many things: Fuse bits settings, like clock source, clock speed etc. I would look at the bootloader, too.

Does the older program still work? Can you get status msgs from the Atmega328 via ISP (w/ AVRdude)? Or read the fusebits? If so, that would tell you something.

If not, that will also tell you something. In some circumstances, HV programming might be the only way to reset the chip...


Reply 4 years ago

Thanks sooo much for your early reply! I solved the problem... Here is what I did:

First, I uploaded the ArduinoISP sketch to my mega. Then I connected it correctly to the atmega328. Here's where I corrected myself; I had to then press " upload using programmer!" I did that, and it finally worked... I will have a detailed description of this in my next Instructable(coming soon!) Where I'll be making an electronic mosquito repeller..... So check it out!!!