Author Options:

add a mini pcie slot in place of expresscard? Answered

ok, so if we've looked at the pinouts of the expresscard 34/54 slot and the mini pcie slot, we know that:
-they both use USB 2.0
-they both use PCIe
-they both run on similar voltages

so i tried my luck and wired up a mini pcie slot in place of the expresscard slot in my laptop.
ive got all the pins wired correctly and all the grounds are grounded, but my wireless adapter card is not recognized.
first off, skip all of the "why bother adding a wireless card when you've already got one?" and "this is just a stupid idea" remarks, thats not what im asking.
the miniPCI wireless card ive currently got works, but the bandwidth is really limited because its an older technology than mini PCIe.

but back to the question at hand.
why isnt my mini PCIe card recognized? i have a feeling that it might be the "CP USB" pin on the expresscard slot, which, on the pinout sheet is labeled as "card inserted", but i have no clue what i do with that pin to tell the computer to check for a card.

does anyone have any ideas?

expresscard pinout:

mini PCIe pinout:

any help would be greatly appreciated.


The forums are retiring in 2021 and are now closed for new topics and comments.

8 years ago

I never did anything as wierd as this but my two cents:
The PCI Express protocol might have a different method to send data around than the original you took out. I think simply connecting the 'data' pins correctly might not do it for your motherboard. Are you certain this kind of upgrade can be done without any major changes to your motherboards bios and/or circuit lay-out ?
I'm nowhere qualified enough to say for sure but my best bet, the protocol differs too much to switch out the different hardware types without some further changes.


Answer 8 years ago

i should have probably taken down the question when i solved the problem :s
the issue was indeed the CP USB pin, and an associated pin called CPPE.
when an expresscard was inserted, it would pull either of these pins low to state that it uses either protocol for transferring data. i pulled both pins low and now it works.