89Views3Replies

Author Options:

arduino uno detection Answered

hello evry one
i've got a weird issue :(

i have an arduino uno R3 and it was working fine.


now my computer doesn't detect it (i can't find even the com port or non identified devices in the device manager)

that was when i was trying a GSM shieled with 9V 2Amp power like the datasheet says

the weird thing that when i plug my arduino to the USB 3.0, the light "ON" on the board turn on, but when i plug it to USB 2.0, nothing happen.

what i did:
i remove evry other connection from the arduino
i tried with another cable
i tried other devises on my USB 2 and 3, they works fine
i tried to use my arduino on another computer, same problem
(i dont have another arduino to know what's making this problem)
i tried to reset (with button and with jumper) -> the led L does not blink

what i think the problem is:
probably the problem is in the arduino not the computer
maybe when i plugged the power 9V 2Amp and plug to the computer in the same time (and i dnt think it can be a problem)
maybe there is a problem with the bootloader


please help me, at least how can i know what it the problem, did i harm something or evrything

Discussions

0
None
Detectingdragon777

3 years ago

There is a problem with the bootloader. the china made arduino's do not really work until you upload a bootloader. Click this link: http://www.wch.cn/download/CH341SER_EXE.html

Download the file. It is a serial port driver. Then order this product:

NEW hot sale 1Piece Atmel ATMEGA328P-PU Microcontroller DIP-28 IC Chip

It is a chip that has the bootloader. Connect wires on a breadboard like as in the image:

Get onto Arduino IDE. Select Arduino Uno as the board. Click the tools tab. Click burn bootloader. Hopes this helps! Happy Arduinoing

SimpleBreadboardAVR.png
0
None
Quadrifoglio

3 years ago

Power to the UNO is an either / or situation. It uses USB only but shuts off the USB if an external supply is added. Even though USB 3.0 is capable of providing 900 mA and the spec for the GSM is 700 to 1000 mA, they don't recommend running it off of the USB, especially if you are using the modem.

From the number of returns for a Google search of reset an UNO arduino, it seems that it is common to confuse an UNO to the point the reset button doesn't work. http://stackoverflow.com/questions/5290428/how-to... has a number of approaches to achieve a reset.

Good hunting.

0
None
iceng

3 years ago

You probably damaged the arduino IC and now it is pulling a lot of power the USB3 can deliver more current then the USB2.

The regulator may have survived and the extra current USB3 can light the LED.

Does the IC get hotter on USB3 ?