97Views4Replies

Author Options:

help with fixing stereo amp Answered

iv had a few problems trying to fix an amp iv got ...there is no obvious problems/problem with it iv tested the thing the best i can ....transistors on out put capacitors diodes and all are ok... the heat sink gets hot to the touch when there is a signal passed through but not any sound comes out .
its a sansui amp ax510 iv got a few pics attached ...there is two or three relays in side one on power in and as a speaker protection and iv got a felling that this may be engaged due to a fault .. im not to sure on testing relays iv never had to do it b4 .... iv used a multimeter across it and is showing that a signal not to sure if its a good or bad thing though

Tags:fixamp

Discussions

0
None
Cooljoe27

4 years ago

hi there I have a reciver amp. When I sweetch the unit on all the lights come on ok. There is no sound coming from the reciver amp.

0
None
lemonie

9 years ago

You've asked 4(?) questions about this already.
You would do better to comment back to the people who have replied to those, some of them do know what they're talking about.
Asking a new question is a bit like unplugging and plugging it - do you think you'll get the result you want if you do it enough times?

L

0
None
andybudalemonie

Reply 9 years ago

cheeky i was having problems sending the pics to someone and posted it in the answers bit by mistake... i got the guys email and sent them direct
 there not very good pics any way 
shame i cant send them in privet msg 
any way hows you know much about amps

0
None
lemonieandybuda

Reply 9 years ago

You can't PM them? That sounds like a problem that shouldn't be.

It can be taken as a bit rude to have someone try to help you, but then post the question again like what they said was no good at all. That's all I meant. You best answered someone but asked the question again instead of sticking with 'em.

L