98Views7Replies

Author Options:

infinite loop on instructables.com Answered


whenever i try to open www.instructables.com i get an infite loop in my browser and i cannot access the page.
linux tool "wget" gives this output:

$> wget https://www.instructables.com/
--2011-06-01 10:37:35-- https://www.instructables.com/
Resolving www.instructables.com... 74.50.63.27
Connecting to www.instructables.com|74.50.63.27|:80... connected.
HTTP request sent, awaiting response... 302 Moved Temporarily
Location: https://www.instructables.com/index [following]
--2011-06-01 10:37:36-- https://www.instructables.com/index
Reusing existing connection to www.instructables.com:80.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: https://www.instructables.com/ [following]
--2011-06-01 10:37:36-- https://www.instructables.com/
Reusing existing connection to www.instructables.com:80.
HTTP request sent, awaiting response... 302 Moved Temporarily

and so on...

that does not seem to be right :)

when i open a saved link everything is fine, i just can not access the root page.

no idea, if that has anything to do with my ips ( germany ) or has a different cause, but at the moment.
tested from various providers, browsers and operating systems.

Discussions

0
None
StumpChunkman

8 years ago

Have you tried clearing out your cache? I've tried the homepage on three different OS's, and they're all working fine. Maybe you tried to get on in the middle of some kind of update?

0
None
JohnCopperStumpChunkman

Reply 8 years ago

yes, i have cleared all the caches...

tested systems:

office
- windows xp: ie8
- fedora 14: firefox 3.6, firefox 4, chromium 12

at home
fedora 14: firefox 4

my root server
centos 5.4: w3m and links ( so no caching at all )

funny thing is:
works from my mobile phone and from the pc of a friend of mine
both of course have different providers...

it currently points to a provider dependent topic, but i have no idea, what on that network level should cause this issue... maybe some kind of dns thing.. i have no idea...

it stopped working some weeks, few months ago...

0
None
Lithium RainJohnCopper

Reply 8 years ago

I've noticed this effect - one time chrome warned me about it. And forget running any kind of downloader or speed analysis on the site for this very reason.

0
None
StumpChunkmanLithium Rain

Reply 8 years ago

I'll pass it on. But I'm not sure how we're going to know what's causing it, if we can't get it to happen here (under any circumstances). We have a lot of computers here...and we're on Instructables quite a bit (as one might imagine).

But as I said, I'm passing it on to smarter people. So perhaps they'll be able to figure it out.

0
None
Lithium RainStumpChunkman

Reply 8 years ago

Rest assured that while perhaps rare, this bug indeed exists. While I don't recall precisely which tools I used in the past which would show a failure due to this, you might try a few of the general "see how fast your website loads" variety - some will have no problems, but sometimes they'll choke on the infinite loop.

0
None
JohnCopperlebowski

Reply 8 years ago

@leboswi: it actually really is.. cool...
what was changed?

thanks :)