87Views11Replies

Author Options:

new browser editor not saving Answered

After working in the new editor in Browser i spend about and hour working and found that nothing actually saved.
i was pressing the save button very often while working. Than i mentioned it was not showing the "saving..." and "saved" logo next to it. Really frustrating.
i am using chrome on osx 10.7.5 
when i reloaded the page it began to save again

Discussions

0
None
pseaton

6 years ago

As one of the main developers behind the new editor, I wanted to thank the community members who contributed to this forum topic directly. I have heard of this "saving..." bug twice prior to this community topic, but have never had enough information about it to successfully reproduce it until now.

AntzyP, your comment cracked the nut on this one. This error occurs when step text overflows the database column. Neither the old nor the new editor handle this situation very nicely, but the old editor at least was able to throw a proper error about it. The new editor actually experiences a second error *while reporting* the first one because of the unexpected nature of the problem.

By early next week we should be able to show a proper error when saves fail for this reason. I'll also look into solving it for good going forward.

I wanted to thank you all for your perseverance and tolerance on this one. It's been very difficult to track down, and I know that the result (lost work) is more than extremely frustrating. We're working hard to get it fixed ASAP.

Meanwhile, if you see that the "saving..." badge doesn't go away. refresh the page right away and don't type anything more in your longest step.

Thanks again, and my sincerest apologies for the frustration as we transition towards what we hope will be a much smoother and more fun experience for everyone.

0
None
Antzy Carmasaicpseaton

Reply 6 years ago

Loved the new editor, especially the pixlr integration. Keep up the great work. Glad to be of help... :)

0
None
pseatonAntzy Carmasaic

Reply 6 years ago

So glad you enjoyed working with it overall, despite a few bumps in the road. Thanks again for your patience with us! I hope this will be awesome and smooth for everyone by the time we're done!

0
None
h0n3y5un5h1n3

6 years ago

I'm using FireFox on Windows 7. Not using the picture editor; while working, the editor constantly says "saving..." The button never goes away, and is not actually saving the project. I don't think I'm running any of the kind of plug-in mikeasaurus mentioned. Frustrating >.<

0
None
h0n3y5un5h1n3h0n3y5un5h1n3

Reply 6 years ago

Update: tried again in Chrome. Again, same error. The old editor is working and saving fine, but crashes as soon as I try to add in a step. Any fixes out there yet?

0
None
mikeasaurush0n3y5un5h1n3

Reply 6 years ago

Try clearing your browser cache completely, then log in and refresh the page.

0
None
Antzy Carmasaic

6 years ago

I am seeing something similar. The 'saving...' logo keeps looping for a looong time but doesn't change to "saved". This happens when I'm saving long text in the step. I instead tried saving short step description and both manual-save and auto-save work perfectly.

0
None
cornelius3

6 years ago

I can't get either browser to properly save or Publish

0
None
mikeasauruscornelius3

Reply 6 years ago

See my comment left Nov 5 @ 10:14am, regarding browser add-ons.

0
None
mikeasaurus

6 years ago

Both the old and the new editor save automatically whenever you switch steps, or hit the save button. If you were not getting a response from hitting save maybe you have a script-blocking browser add-on (like Ad-Block or GreaseMonkey). Make sure those are turned off completely before you start.

Did that help?

0
None
bastl-instruments

6 years ago

actually thinking of it again. it might have been cause by using the picture editor which i was using. maybe these two interfere. neither the pictures and the text was saved