Repair Power Supply Miele W1514, W1714, W1614, W1730 . (EDPL200-A, EDPL200-M, EDPL200-W, EDPL200)

425

2

Special thanks to Kevin Steward for providing me valuable information.

There was no power at all on my Miele W1714. After disassembling the control board EDPL200 I noticed that IC TEA1522 was damaged and there was short on the transformer. TEA1522T is widely available but I couldn’t manage to find the transformer. Kevin Steward had the skill to rewind the transformer. If you visit his channel youtube https://www.youtube.com/watch?v=85jzYGdRY7c he provides a lot of valuable information about this board, plus how to rewind the transformer.

Here below I will provide a workaround how to restore power if there is no power on the board

1) Disassemble the washing machine

2) Remove the board

3) Check the fuse, varistor, switch.

4) Connect power supply CAUTION HIGH VOLTAGE.

5) Measure the voltage on capacitors before primary and after primary (50V, 8V and 15V).

6) If there is no 8V and 15V as on the 2 capacitors capacitors, Kevin Stewart suggests to connect 50V external power supply and try to repair the board. Continue troubleshooting as Kevin explains. If you believe you will not be able to repair the board continue to step 7. (Continue step 7 if 8V and 15V is not present)

7) Remove the SMPS transformer

8) Connect external power supply on the board. I had salvaged a power supply from an old Humax 5400 receiver which had 8V and 15V, exactly what I needed.

9) Solder the 3 cables as indicated

10) After connecting the power supply you must notice “Waterproof” “fault” on the display.

11) You must now fix the external power supply somewhere in your washing machine.

Share

    Recommendations

    • Tape Contest

      Tape Contest
    • Trash to Treasure

      Trash to Treasure
    • Gardening Contest

      Gardening Contest

    2 Discussions

    0
    None
    kstewart2017

    7 weeks ago

    Service Mode
    1. Set to Cottons with door closed.
    2. Hold Start whilst powering up.
    3. After the rapid flashes there should be a solid light.
    4. Press the Start button 3 times (for service) or 5 times (for factory) holding it down on the last push.
    0
    None
    kstewart2017

    7 weeks ago on Introduction

    What I would say, is that there is a strong possibility that the one or more of the processor I/O pins has been damaged. The processor is not cheap and it is not easy to program. I tried to see if they had used a boot loader so that a standard in circuit programmer could be used. I am not even sure if the processor has been code protected so I stopped at that point.

    The power supply fault resulted in damage to many components on the board. I think that it is probably cheaper any more likely to result in success buying a replacement board off eBay.

    Note that any of the W15 or W17 boards seem to work in any of these machines. You will need to go into the factory service menu and change the settings accordingly. This is what I have for 2 of the models. It was mainly the 5kg/6kg drum capacity that was different. I don't know what difference the flow meter setting makes either.


    Setting


    W1514

    W1714

    Water intake

    Cold

    Cold

    Max water level

    No

    No

    Flow meter

    No

    Yes

    Low water pressure

    Yes

    Yes

    Sensor rinse

    Yes

    Yes

    Allergy

    No

    No

    Country version

    EU

    EU

    Auto load control

    Yes

    Yes

    Heater rating

    2100W

    2100W

    Suds container

    5kg

    6kg

    Imbalance charts

    5kg

    6kg

    Max spin speed

    1400

    1400

    Imbalance sensor

    Tacho

    Tacho

    Time left disp

    Yes

    Yes