Swagway, Hover Board, IScooter, Swegway, Red Ring of Death Advanced Fix.

About: iOS Developer, Love to create and hack. Internet of things enthusiast. Cocoa Head, Tech geek, @StartUpGrindUtah #IoT #3Dprinting #runner

This is the third of a series of fixes for these boards. If this is the first one you have come across I would first suggest that you try just recalibrating the board the steps to do that can be found here. https://www.instructables.com/id/Fix-Hover-Board-Sw...

If that doesn't work then your probably in the right place if you still have the Red Ring of Death.

If the issue that you are having is the board has a seizure when you step off of it then you probably need this fix found here https://www.instructables.com/id/Swagway-Hover-Boar...

So in this intractable we will cover the how to fix the the board erring out.

What you will need for this fix

Hot Glue Gun along with hot Glue.

Philips head Screw Driver +

I also used a Flat Head Screwdriver - for removing old hot glue. You could also use a knife.

Teacher Notes

Teachers! Did you use this instructable in your classroom?
Add a Teacher Note to share how you incorporated it into your lesson.

Step 1: The Problem.

The issue that we face here is that when these things became popular china went in to turbo mode in creating these. The companies want to make as much money as possible so they demand more inventory. This means the pressure is put on the factory to produce more faster. Witch means corners will be cut and things will not be put together as they should. So lets open this guy up and see what we need to do to get everything back together.

Step 2: Getting the Bottom Off.

Their are 10 screws for each side of the board. Some of the screws are different. The 4 closest to the center of the board and the outer most 4. They just screw into the other half of the bodies shell. They are shorter and pointy. You will need to remove all 20 screws. Once you have removed the screws the bottom portion of the board should come off. They will still be attached by some wires, on one side this is just for the LEDs. You can take your screw driver or a knife and pry at the Hot Glue off of the connectors or you can just leave them. On the other side you also have the power connectors for recharging the battery and the power button wires.

Step 3:

So now that you have the bottom off you can see how many wires are shoved into here. So my Swag way worked fine for about a month but after multiple people have tried it out and seen how fast they could go and how fast they can not go it began to give me the Red Ring of Death. This is due to one of the connections for the wires becoming disconnected making it impossible of the logic board to either know what to do based on sensor data or cannot complete commands to the motors. Therefore the board senses the error and and "for your safty" lol does not work.

So all we have to do is find out where the connection that is not connected is and reconnect it. Sounds easy right, well no. So as you can probably see now that you have the bottom of your board off that they have tried to prevent this by putting hot glue on every connection and on the back of connectors to keep the wires in there snug. But also as you can see it looks like whom ever put yours together was in a little bit of a rush maybe because it was like the 300th one they put together that day.

So I would suggest removing any hot glue that you can. Anything that is simple to remove is not doing its job.

Step 4: We Need More Power.

Make sure and check your power lines. You may need to remove the plastic guard that keeps the battery in place. It is simple just 4 philips screws holding that on. This gives you success to the connections underneath it. These are the three thicker wires that go to both motors. The reason that there are three and not just two is because the motors are controlled by speed controllers. So two of the lines are power and one is the signal on how fast it needs to go. Most of these are just bullet connectors which mean they just slide into one another and lock together. It is possible that there may be corrosion between these connections making it difficult for the power to pass through. Sounds like a big problem but the solution is to just disconnect them and then reconnect them. This will knock any obstructions out of the way giving good connection.

Now the colors should match up

Green -> Green

Blue -> Blue

Yellow-> Yellow

But as you can see in my pictures mine are not lined up. But mine worked previously and if its not broken don't fix it. Also when I tried to swap all of them to the correct ones the board had no Idea what it was doing so I swapped them back. So take note or pictures of how yours are set up and make sure they are the same after you disconnect them and reconnect them.

Step 5: Other Connections.

Now for the other connections. These are the connections that are responsible for the transferring of information from sensors and giving commands to the motors. So once you have removed the hot glue from a connection you can squeeze the sides and press on the little arm that bridges from the one side to the other. It acts like a lock holding them together. Now check the male end there should be a prong coming out for as many wires that are going in the back. (This side is not normally the one that is at fault)

Now check the female side. You may or may not be able to see inside if the contact is all the way to the connector. You can use a light or just do your best to make sure that it is as far in as it should be. You can pull on the wires individually on the back and if any slid out that is your culprit usually just pushing it back in you will feel a little click and that is the connector snapping into place. You can also take a small screw driver or nail like object and try and press them in.

Once that is done Just take some hot glue and line the back of the connector to keep the wires for pulling out again.

Step 6: Testing to See If It All Works.

Check to make sure you have reattached all your connections. Take the side that has your power button and battery port and reconnect those.

place 3 screws to hold it on just so we can see if it works. Set the board flat on the ground and hold the power button for 5 to 10 seconds. once the lights flash a few times power it off and back on. You should be able to stand on the board and ride it around. I would suggest about a min to make sure the Red Ring of Death does not come back if it does one of your connections needs to be redone.

Once that is confirmed just put the rest of if back together.

Remember the small screws go on the center of the board and the out side edge.

Your Welcome.

Share this if it helped

Check out these if you still have problems



or if you need a new project check out



Be the First to Share


    • Made with Math Contest

      Made with Math Contest
    • Multi-Discipline Contest

      Multi-Discipline Contest
    • Robotics Contest

      Robotics Contest

    7 Discussions


    3 years ago

    Hi merry Christmas I'm so sorry to bother you I just opened muy I wat board today and it worked for two mins before the red light of death came on I tried to recalibrate it but then the red light turned green and the battery light is green. Both are stuck on and the front blue lights are also stuck on. I don't know what to do!!!!! Or what is wrong. I'm trying to let the battery die to see if that helps but I dought it will. What should I do. I have contacted the company I bought it from. Any help on this matter would be great thankyou.

    5 replies

    Reply 3 years ago

    Another thing that you could try is taking the bottom off of the board and completely disconnect the batterie. If you then take a small piece of wire and bridge the connector leading to the control board (Not the batterie that will be bad). This will discharge any stored energy helping the board to reset. I would then wait 30 min before plugging the battery back in. Once you plug it in make sure to recalibrate the board (steps in the intractable https://www.instructables.com/id/Fix-Hover-Board-Swagway-Glyde-Stick-Red-Ring-of-De/) Good luck. Which brand of board did you get?


    Reply 3 years ago

    Hi thanks for your help, I bought the I wat board I6 the same one they are using in the music video. And the company I got it from is effectoled.com authorised dealer to the I wat board company. I live in Gran Canaria. And they sent it from valencia to me. At the moment I'm trying to get them to pick it up and change it. Because it has stickers on the bottom so if I open the board up it will make the warrenty useless. But they are refusing to pick it up saying I must mail it back to them. Which will cost a fortune as it weighs a lot. If all else fails I will try your suggestions, I'm such a girl so not really sure what wire is which lol. But your videos are great. And I just wanted to say thankyou. At least I know in the future if I have problems I can work it out with your help. The manual for the I wat is rubbish dosent even tell you how to recalibrate the thing. Just about safe riding etc and battery charging. I read the whole thing. Anyway I will be in touch thankyou so much again for your help. As I know loads of people are having problems with them just from looking on line. Xx


    Reply 3 years ago

    Same thing happening to me! Very sad son. And seller and swagway closed till Monday. Please help!


    Reply 3 years ago

    Which brad are you having trouble with? Also If you are looking at the components in the inside would you take some pictures and send them to me. That would be appreciated.


    Reply 3 years ago

    I have sent them an email. But it's not working still with green lights on and blue lights stuck on at the front. I want a refund as I have just heard if they don't have a Samsung battery in they could explode.


    3 years ago

    Hi it's Swagway X1. I mailed it back to them and am now waiting to hear if they will replace it. It would not work or move at all. I did open the back to check connectors and hope that doesn't void the warranty. Thanks anyway for your response. Fingers crossed. It only worked 10 min and flipped and kept going on its own before red ring of death and then dying.