Virtual Reality Minecraft 1.8 With Google Cardboard

184,587

106

61

Intro: Virtual Reality Minecraft 1.8 With Google Cardboard

Welcome to my first instructable. I have been a member of this site for a very long time now and have been wanting to start posting for a wile but never knew where i should start. After looking at my recurring email from here i saw the minecraft contests and thought what better way than to start here with the VR i have been planning to set up any way.

For the google cardboard set up read it all, for oculus rift skip to step 2.

Thanks for stopping by and reading.

Items needed Google Cardboard (Or Oculus Rift)

Computer and files (mentioned later)

Smart phone

Minecraft

Step 1: Step 1: the Easy Part Screen Sharing

This can be done with your favorite smart phone to windows remote screen.

I chose to use splashtop, Its the best i have tried so far.

fist download it for windows/mac/linux (I did Windows so can not help for other OS).

http://www.splashtop.com/downloads

the download for your phone can also be found here or in the app store. (I am using android in this instructable)

after downloaded create and account and test it.

Also this is a good time to put together your google cardboard. I had already put mine together so that is not part of this instructable.

Step 2: Step 2: Simple Minecraft Preparation (Oculus Rift Step)

For this step you need to download mincrift found at the link below

straight to forum
straight to download

For those with Oculus I urge you to go to the forums and follow the more detail and oculus catered instructions.

The forum has a link for older versions of mincraft.

After downloading make sure that you have run minecraft 1.8.1 at least once before running the downloaded .exe

Run the .exe just downloaded (on Windows 8.1)

Press ok on the screen, shown in the picture with same settings shown.

After installing the .exe open up the minecraft launcher.

Make sure that what is circled in red in the second picture reads minecrift-1.8.1-xxxxxxx or is similar to the pic.

If not press edit profile and select release minecrift-1.8.1-xxxxxxx as shown in pic 3. (this is where you will change it back when you decide to play normal just select the version you would like to play.)

If all good press play.

Step 3: Step 3: Editing Setting to Work With Google Cardboard

[Play Video]

The video shows how to set the settings and shows it working.

I suggest editing the setting with out your head set on.

Here are the steps using the pictures. You will most likely need to just try and follow were my cursor is and where the buttons in minecraft are highlighted because for the first few steps it will be impossible to read what the options say.

This is shown in game but can be done at title screen.

Pic 1 press exc on the keyboard and go to options.

Pic 2 press VR settings

Pic 3 go to HUD settings

Pic 4 slide the HUD size slider all the way up to 2.50 or to the position you prefer press done

At this point you should be able to make out what the options say.

Pic 5 go to move/aim control

Pic 6 turn on pitch control (this allows you to look up and down with the mouse)

Final step press done till your back in the game and than connect you phone to your pc using the remote connection app and program we installed in step 1

Step 4: Step 4: ENJOY

Enjoy playing minecraft using your google card board.

If you liked this vote for me in the minecraft competition.

Minecraft Challenge

First Prize in the
Minecraft Challenge

Share

Recommendations

  • Audio Contest 2018

    Audio Contest 2018
  • Plastics Contest

    Plastics Contest
  • Electronics Tips & Tricks Challenge

    Electronics Tips & Tricks Challenge

61 Discussions

0
None
joransom5

1 year ago

i could not find the link on page 2.if i could this seems like it would be fun.

0
None
ZombieSheepman

1 year ago

In order to use the .exe file I had to convert it to a .jar because I'm using a Mac. I changed all the settings as specified but when I pressed play, it would download everything but not open the game itself. Is this a problem with Mac or is it something wrong with the version of Minecrift.

0
None
RiccardoZ2

2 years ago

Link doesn't work

0
None
mikes12

2 years ago

to those who say trinus. dont its difficult to get going smoothly and its rather expensive. i've been using riftcat vr ridge. it's both compatable with steam vr and oculus games. just simply install on phone and computer. then plug your phone into the computer via usb and enjoy. https://riftcat.com/vridge

0
None
MakerMan234

2 years ago

you should use trinus vr

0
None
DomB

2 years ago

http://www.mtbs3d.com/phpbb/viewtopic.php?f=142&t=17489&p=124997#p124997

Found the forum post. scroll down and choose 1.8.1

0
None
Beachbear1

2 years ago

Where is the link?

0
None
august1742

2 years ago

when he said: found at the link below, why isnt there a link?

0
None
Cl41daGamer

2 years ago

I couldn't find the link for the installer package....and I have a HooToo headset and a generic controller. Will these work for what I want? Or do I have to get other equipment? Please help!!!!

0
None
Cl41daGamer

2 years ago

I couldn't find the link for the installer package....and I have a HooToo headset and a generic controller. Will these work for what I want? Or do I have to get other equipment? Please help!!

0
None
DipperP

2 years ago

when i try to open the profile/version, it opens a window, then shortly after crashes with this crash report.

---- Minecraft Crash Report ----

// Why did you do that?

Time: 5/22/16 1:11 PM

Description: Unexpected error

java.lang.NullPointerException: Unexpected error

at bao.setupRenderConfiguration(Minecraft.java:3795)

at bao.ak(Minecraft.java:1328)

at bao.f(Minecraft.java:1271)

at net.minecraft.client.main.Main.main(SourceFile:148)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

at java.lang.reflect.Method.invoke(Method.java:597)

at net.minecraft.launchwrapper.Launch.launch(Launch.java:131)

at net.minecraft.launchwrapper.Launch.main(Launch.java:27)

A detailed walkthrough of the error, its code path and all known details is as follows:

---------------------------------------------------------------------------------------

-- System Details --

Details:

Minecraft Version: 1.7.10

Operating System: Mac OS X (x86_64) version 10.10.5

Java Version: 1.6.0_65, Apple Inc.

Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Apple Inc.

Memory: 132370944 bytes (126 MB) / 162529280 bytes (155 MB) up to 1060372480 bytes (1011 MB)

JVM Flags: 5 total; -Xmx1G -XX:+UseConcMarkSweepGC -XX:+CMSIncrementalMode -XX:-UseAdaptiveSizePolicy -Xmn128M

AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used

IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0

Launched Version: minecrift-1.7.10-R1c-nohydra

LWJGL: 2.9.1

OpenGL: Intel HD Graphics 5000 OpenGL Engine GL version 2.1 INTEL-10.6.33, Intel Inc.

GL Caps: Using GL 1.3 multitexturing.

Using framebuffer objects because ARB_framebuffer_object is supported and separate blending is supported.

Anisotropic filtering is supported and maximum anisotropy is 16.

Shaders are available because OpenGL 2.1 is supported.

Is Modded: Very likely; Jar signature invalidated

Type: Client (map_client.txt)

Resource Packs: [faithful32pack, Faithful 1]

Current Language: Canadian English (Canada)

Profiler Position: N/A (disabled)

Vec3 Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used

Anisotropic Filtering: Off (1)

2 replies
0
None
DipperPDipperP

Reply 2 years ago

Nevermind, i got it working

0
None
ColinT20DipperP

Reply 2 years ago

I'm getting the same error, how did you fix yours?

Thanks

0
None
ThomasStremmie

2 years ago

Minerift does not work for Mac/Linux

0
None
DrewD30

2 years ago

Never played Minecraft but got it on vr..can anyone please tell me how to remove blocks so i can make space to build..thank you

0
None
Hl.C

2 years ago

where are the links in page 2????