Tell us about yourself!

Complete Your Profile
  • TylerS32 commented on dcolemans's instructable DIY Submersible ROV4 months ago
    DIY Submersible ROV

    Hello again. Well my ROV is progressing well. I had a slight problem with the frame and had to raise it to get the tube to fit above the thrusters. But ill end up using those T's for lights or something. As for wiring, well all the sensors and such connected to the MEGA board are working properly. But I cant seem to get the data from the MEGA to the UNO. I tested the UNO with the OSD and the test sketches work, so I know its working. But I cant get it to display any data from the MEGA. Can you please share more info for the wiring to the rs485 and how they connect to the MEGA and UNO. I have mine as follows, but it does not work. I have tried several combos of this and still nothing.MEGA pin 19 RX1 to RO on rs485MEGA pin 18 TX1 to DI on rs485, i have swapped these but not workingDE and...

    see more »

    Hello again. Well my ROV is progressing well. I had a slight problem with the frame and had to raise it to get the tube to fit above the thrusters. But ill end up using those T's for lights or something. As for wiring, well all the sensors and such connected to the MEGA board are working properly. But I cant seem to get the data from the MEGA to the UNO. I tested the UNO with the OSD and the test sketches work, so I know its working. But I cant get it to display any data from the MEGA. Can you please share more info for the wiring to the rs485 and how they connect to the MEGA and UNO. I have mine as follows, but it does not work. I have tried several combos of this and still nothing.MEGA pin 19 RX1 to RO on rs485MEGA pin 18 TX1 to DI on rs485, i have swapped these but not workingDE and RE on rs485 to +5v, maybe this is the problem?RS485 VCC to +5 and GND to GND on bothrs485 A to A on second rs485 and B to B, swapped this but noon second rs485 DE and RE to +5v, again, dont know where to connect these, some web diagrams show connected to +5von second rs485 DI and RO I have tried on pins 0RX and 1TX on UNO, also pins 5 and 6 on uno, swapping them has no effect.I have even tried removing the rs485 and just connecting pins 18 and 19 on MEGA to both 0 and 1, and, 5 and 6 on UNO. Doing this, i dont remember witch one worked but, I can see data using the serial monitor via the Arduino IDE with a usb connection. But even though i see the data in serial monitor, nothing on OSD. Again, I have run test sketchs on OSD and they do work, such as Hello World and Display Font. Again, thanks for all you have done with sharing your design.

    Thanks for the reply. So while trying to figure out the rs485 i decided to bypass them, while on my desk, and just use direct serial. But I still could not get it working. Then a strange thing happened. I bumped something and lost video, but could see the OSD all of a sudden. I was blown away. So looking into it I found its actually my camera!! I posted a video below. So I will now try the rs485 chips and make sure they are working based on the diagram you shared. To answer your questions, I plan to use a 100 ft tether. The battery will go between some skids, like a helicopter, that are not pictured. While we talked about using a polycarbonate tube that I had. Turns out that that tube was not very round and smooth. Im using the Blue Robotics flanges, end caps, and dome. When I discov...

    see more »

    Thanks for the reply. So while trying to figure out the rs485 i decided to bypass them, while on my desk, and just use direct serial. But I still could not get it working. Then a strange thing happened. I bumped something and lost video, but could see the OSD all of a sudden. I was blown away. So looking into it I found its actually my camera!! I posted a video below. So I will now try the rs485 chips and make sure they are working based on the diagram you shared. To answer your questions, I plan to use a 100 ft tether. The battery will go between some skids, like a helicopter, that are not pictured. While we talked about using a polycarbonate tube that I had. Turns out that that tube was not very round and smooth. Im using the Blue Robotics flanges, end caps, and dome. When I discovered my tube would not work, I got a Blue Robotics tube also.I made a video here:

    View Instructable »
  • TylerS32 commented on dcolemans's instructable DIY Submersible ROV4 months ago
    DIY Submersible ROV

    Hello again. So my build is coming along nicely. But I have hit a road block and thought maybe you would know a solution. Its about using PPM from the RC receiver. As I understand it, PPM is limited to 8 channels. But I find myself wanting more. I have built a ROV using 8 thrusts. 4 vectored for F/B and turning. And 4 vertical that will provide U/D and also pan and tilt. Pan and tilt thrusters would accomplish the same as having servos on the camera to look around. Either way I need some form of pan and tilt taking two channels. I see in your code that you run both your vertical thrusters together. Where each of my 4 would need separate PWM. I am very new to the Arduino and only assume that it has enough PWM outs to run all 8 motors. I expect that I can copy parts of your code to read t...

    see more »

    Hello again. So my build is coming along nicely. But I have hit a road block and thought maybe you would know a solution. Its about using PPM from the RC receiver. As I understand it, PPM is limited to 8 channels. But I find myself wanting more. I have built a ROV using 8 thrusts. 4 vectored for F/B and turning. And 4 vertical that will provide U/D and also pan and tilt. Pan and tilt thrusters would accomplish the same as having servos on the camera to look around. Either way I need some form of pan and tilt taking two channels. I see in your code that you run both your vertical thrusters together. Where each of my 4 would need separate PWM. I am very new to the Arduino and only assume that it has enough PWM outs to run all 8 motors. I expect that I can copy parts of your code to read the pan and tilt channels from my RC. So my main problem is again 8ch of PPM. By my count its like this. 1 up/down, 2 forward/back, 3 turn left/right, 4 move left/right, 5 pan, 6 tilt. I also need one for lights, so 7, and I would like to add an arm that I expect would need at least one to close the clamps. So im at my 8. But that doesnt leave any room to expand. Suppose I want to have movement on my arm, or add a second set of lights on a separate channel so I can use them only when needed. The point is, is there a way to use SBUS instead of PPM from the RC receiver? Then I could get all 16 ch available.

    View Instructable »
  • TylerS32 commented on dcolemans's instructable DIY Submersible ROV5 months ago