Author Options:

3D Printer XYZ Axis Problem Answered

So, I finished building my 3D printer. I installed the firmware, etc. Whenever I try to print in repetier the X and Y axis move really fast while the Z axis doesn't go up nor down. I have tried so much to fix but I just can't find a solution. Also, I have the MK9 Extruder and for some reason the extruder doesn't feed the filament, it just stays there. In case you ask, I have not be able to print anything.

There is a video of the process, and sorry for the mess.


The video didn't embed.

I barely know anything about 3D Printers, but I'd guess that there's something wrong with the code, or the motor (You've probably checked this a million times, but just in case...)

I forgot to say that I am new to this, I followed instruction on how to set each things. I could post the Marlin info here so if anyone can figure out what's wrong.

It is next to impossible to diagnose the problem without access to the printer.
1. The firmware must be cofigured correctly to the hardware.
2. The stepping and endstops must be defined correctly.
3. The motor drivers need to be set to the correct amperage for the motor connected.
4. The entire system must be calibrated.
Usually after all this you try to print something and do the finetuning.

1. I posted some of the firmware configuration so any of you can take a look and see if something is wrong.

2. I have tried to switch the endstop to different location, etc. Nothing seems to happen so I guess the configuration might be wrong.

3. I saw something concerning this but I don't know if they are adjusted the right way.

4. I been trying to figure out how to calibrate the system, but I keep getting errors or sometimes some of the lines in Marlin don't even exist for me.

All this is fine but how would I know the actual hardware in your machine and how it is set up?
Check the Reprap forum for Tiffids calibriation guide and go from there.

You can see the video if it gives you any clue if something is wrong.

The only thing the video tells me is that at least one motor is running with far too much current - that beeping noise is from your motor...
For the rest it seems you don't understand the problem:
What is your endstop logic and location - how is it set in the firmware?
What temp sensor is used and how is it set in the firmware?
What is the axis configuration, hardware and firmware?
All this and more needs to match up before you address problems like the stepping, pid control or speeds....
And there is no way to firgure that out by pics or a video - you have to match this by checking your hardware and the corresponding firmware settings.

You can check the firmware in one of the comments below that I posted. For the temperature I ran the PID Autotune to get a code for the thermistors. Like I said, I have followed multiple instruction on how to set my 3D printer, but I can't get it to work.

Any specific help forums for your brand of printer?

Did you actually have any model to print and did it get sliced properly to generate gcode before printing?

You should go through the bed leveling procedures before attempting to print.

Your extruder nozzle may be jammed or the feeder is not adjusted properly to grip the filament. Do you see the extruder motor turn? The filament may not have been pushed all the way into the hot end. You can manually push through some filiament while the hot end is heated up to see some filament oozing out.

If you have the correct firmware loaded on your printer, the software must be configured with the right profile for the printer settings.

Also, the hot end heats up, then the heated bed has to come to temperature before the actual print. Maybe the erratic xy movement is the head trying to find home position before the print, your endstop switches may not be hooked up or working correctly.

Yup, a lot of things to figure out when owning a 3D printer. Good luck.

I have not be able to print anything as the filament does not go through the hotend. I have tested two different extruder nozzle and both are acting the same, so there might be something else wrong. I tried to push the filament but it doesn't go through. I posted some of the firmware configuration in case there is soemthing wrong.

It must be some kind of generic 3D import printer but the firmware, if you have the correct version, may need to be configured for the hot end/thermistor you are using. I don't know if those temperature readings are real or accurate. Is the hotend assembled correctly through the heater core with all the feed tubes clear? Is it getting warm when you get close to it? Check the wiring and for the heated bed/thermistor. Load in a model to actually slice and print.

The temperature are all right. Everything about that is assembled correctly. The only thing is that when I click print the temp are not shown rising once it completely stop at its max. I'm just more concern about the high movement of the motors.

Check the printer configuration in Repetier that it is set for your printer. Again, not knowing what kind of 3D printer you are using, maybe you need the latest or a custom configured version of Repetier. Does your clone use the same profiles as a name brand machine? You should manually be able to move the printhead and test extrude through controls in Repetier if all is configured correctly.

If the video won't work for you, here is the link to the YouTube video. https://youtu.be/X_tLiShymRE

#define SERIAL_PORT 0

#define BAUDRATE 250000



#define EXTRUDERS 1

#define TEMP_SENSOR_0 8

#define TEMP_SENSOR_1 0

#define TEMP_SENSOR_2 0

#define TEMP_SENSOR_3 0


#define HEATER_0_MINTEMP 5

#define HEATER_1_MINTEMP 5

#define HEATER_2_MINTEMP 5

#define HEATER_3_MINTEMP 5

#define BED_MINTEMP 5

#define HEATER_0_MAXTEMP 230

#define HEATER_1_MAXTEMP 230

#define HEATER_2_MAXTEMP 230

#define HEATER_3_MAXTEMP 230

#define BED_MAXTEMP 120


// fine endstop settings: Individual pullups. will be ignored if ENDSTOPPULLUPS is defined









// Mechanical endstop with COM to ground and NC to Signal uses "false" here (most common setup).

#define X_MIN_ENDSTOP_INVERTING true // set to true to invert the logic of the endstop.

#define Y_MIN_ENDSTOP_INVERTING true // set to true to invert the logic of the endstop.

#define Z_MIN_ENDSTOP_INVERTING true // set to true to invert the logic of the endstop.

#define X_MAX_ENDSTOP_INVERTING true // set to true to invert the logic of the endstop.

#define Y_MAX_ENDSTOP_INVERTING true // set to true to invert the logic of the endstop.

#define Z_MAX_ENDSTOP_INVERTING true // set to true to invert the logic of the endstop.

#define Z_MIN_PROBE_ENDSTOP_INVERTING true // set to true to invert the logic of the endstop.

// X and Y axis travel speed (mm/m) between probes

#define XY_PROBE_SPEED 8000

// Speed for the first approach when double-probing (with PROBE_DOUBLE_TOUCH)


// Speed for the "accurate" probe of each point


#define INVERT_X_DIR false

#define INVERT_Y_DIR false

#define INVERT_Z_DIR true

// @section extruder

// For direct drive extruder v9 set to true, for geared extruder set to false.

#define INVERT_E0_DIR false

#define INVERT_E1_DIR false

#define INVERT_E2_DIR false

#define INVERT_E3_DIR false

// Homing speeds (mm/m)

#define HOMING_FEEDRATE_XY (50*60)

#define HOMING_FEEDRATE_Z (2*60)

#define DEFAULT_AXIS_STEPS_PER_UNIT {80,80,4000,1000} // default steps per unit for Ultimaker

#define DEFAULT_MAX_FEEDRATE {300, 300, 3, 25} // (mm/sec)

#define DEFAULT_MAX_ACCELERATION {3000,3000,100,10000} // X, Y, Z, E maximum start speed for accelerated moves. E default values are good for Skeinforge 40+, for older versions raise them a lot.

#define DEFAULT_ACCELERATION 3000 // X, Y, Z and E acceleration in mm/s^2 for printing moves

#define DEFAULT_RETRACT_ACCELERATION 3000 // E acceleration in mm/s^2 for retracts

#define DEFAULT_XYJERK 20.0 // (mm/sec)

#define DEFAULT_ZJERK 0.4 // (mm/sec)

#define DEFAULT_EJERK 5.0 // (mm/sec)