cd rom cnc machine not working

So I tried to make a cnc machine with an arduino uno, an easydriver and stepper motors according to this i almost have no experience in electronics. and the machine isn't working. I have two ideas why it isn't working it according to what I have searched. It could be either my stepper motor drivers are burned out or I have wrong wirings on my easydrivers. On the wrong wirings part, I may have soldered the wrong wires on the wrong motor coil but im sure that the motor coil that i soldered onto the pins are a correct pair. So I'm not sure what's the problem of the machine

Asked by ZjY 10 months ago

Nema 17 max speed?

What is the max speed of a NEMA 17 motor like this one? I will use a easydriver+arduino. Would there be a different stepper driver i should use (that is still cheap)?

Asked by headslant 1 year ago

Can I use an arduino mega and a R.A.M.P.S. board to run a CNC machine? Answered

Right now, I`m planning to use an arduino duemilanove, and 3 EasyDriver Stepper Motor Drivers. RAMPS board: EasyDriver Board:

Asked by Stuffses 7 years ago

problem in my cnc machine?

At first sorry for the english language is not good  i have problem in my cnc machine when i send 10mm it is move 10mm but when i send 50mm it is move 57mm this is video for problem i'm using  easydriver stepper motor and arduino   and grbl this is my grbl settings  

Asked by aghaM2 1 year ago

What Arduino board to use? Answered

As a university project we are making a robot based around a arduino board. The arduino board need to be able to control four stepper motors, two solenoids and have inputs from six analog sensors. The stepper motors will be contolled via EasyDriver stepper motor driver and the solenoids via relays. Does anyone have any suggestions for a suitable board? Also in terms of analog sensors, we need to detect where a hole is under the robot. We were thinking of using a system a bit like a line following robot with use of IR detectors. any suggestions on that?? Thanks

Asked by benmurton 3 years ago

Driving a Hewlett- Packard Stepper Motor?

Greetings! I am just getting my feet wet and have been doing a little research on stepper motors.  I pulled two good- sized steppers from an HP printer a couple months ago, but I haven't been able to run them yet.  I want to use an EasyDriver[] to drive them, but due to the imposing ICs, I'm hesitant to just plug in the cables like a standard stepper. (I have identified one of the ICs(AN44050A) as a stepper controller) Any recommendations on how to drive this puppy from a BeagleBone Black or other 3.3v logic controller? ~Tyler

Asked by tyler.stevens.16718 3 years ago

CNC Homing

Hello, I work on CNC Alamode project, raspberry pi and Alamode is configured to control 3 stepper motors: My configuration: Raspberry Pi Alamode (Arduino compatible), 3 stepper motors and 3 EasyDriver. Everything works, grbl is ok. Here is my story: I wanted to install a homing system, I first started with the x axis, as in the drawing, it worked well, it has stopped the motor, but I realized that the current 5v  passed directly on Limit X (D9), without 330 Ohm resistance. Then I put this resistor like a drawing but now the homing no longer works. My question is: Have I damaged my card, knowing that everything works? Can I redo my original configuration without resistance? My last statement :  4.96 Volts between limit x (D9) and Ground. Thank you for your help.

Posted by end3x 3 years ago

Transition between two Steppers with independently assigned cues

Hello. I am going to use two step motors, two easy-drivers, one arduino uno. Each step motors have gear to rotate, front and back. First, I'd like to assign multiple rotation cues for each steppers. such as, int step1cue1 = 329 int step1cue2 = 582 int step1cue3 = 1038 int step1 cue4 = 1790 ... int step2cue1 = 568 int step2cue2 = 1004 int step2cue3 = 1928 int step2cue4 = 3592 ... and each stepper needs minimum 0 and maximum value, such as, int step1maxcue = 8372 int step2maxcue = 8421 each rotation speed and acceleration need to be set and controllable as well. I would like to use rotation speed = 0 to make the stepper stopped at the cue. ** Operation Both steppers start from 0, First, stepper1 rotates to randomly chosen cue from its step1cues, when it almost reaches to the chosen cue, stepper2 starts to rotate to randomly chosen cue from step2cues.(stepper1 stopped at the cue with speed=0), when step2 almost reaches to its cue, stepper1 starts to rotate to another randomly chosen step1cue (not the current cue).. (stepper2 stops with speed=0).. and repeat this transition between two steppers. I would like to use the code from this, 'Example 4: Running multiple stepper motors'

Asked by toshi182 2 years ago

UPDATE: CDROM stepper motor moves up and down now! wiggle problem resolved

To anyone who read my previous post about the CDROM stepper motor wiggling and not moving while being controlled by GRBL and the EasyDriver motor controller, I got that same motor to work. What I did was I completely took off the wiring system of jumpers I had made. I took off the male pins and kept only that. Then, I tinned four new 22 AWG stranded wire (which is a larger gauge than I was using previously), attached the male pins to one end, and soldered the other ends to the motor directly using copious amounts of flux and verifying resistance continuity between all wires and connections. My Take Away: A. The previous gauge wire was too small, B. My splicing of the wire failed miserably, C. The solder pins were in fact touching each other, shorting the system I am guessing that a combo of all three (honestly, mainly B) caused the frustration. Now it is one solid wire from motor to breadboard for each of the four connections. I believe by unsoldering everything and cleaning it up fixed the wiggle jiggle of the CDrom motor. So if you are having these problems with your CDrom motor/ motor controller, check the wiring and the solder joints. I hope this helps anyone having these problems.          

Posted by dankozi713 2 years ago

Kaysan Stepper Motor ( Motor Shield or Easy Driver ) ? How to stop motor after rotation?

Hello, I am Mechanical Engineering student working on my Intro to engineering class project. We are a group of two students ME and EE but unfortunately my EE partner dropped out of class and I have to finish the project myself. The project is about rotating some sort of pipes. I have not figured out where to place the electric motor but all I am working on now is setting up the circuit and the motor. I have a kaysan stepper motor nema 17 Datasheet link : I am planning to have the motor rotate one or two rotations in only one direction and then stop. When a push button is pressed the motor will start rotating the one or two rotations. I did some research and I found out that I need a motor shield or Easy drive to control the motor. So far I have the following items: 1. kaysan stepper motor nema 17. 2. Arduino Uno Board. 3. Adafruit Motor Shield v2.3 4. Easy Driver Shield Stepper Motor Driver V44 A3967. 5. Push buttons and the circuit board. I am really not sure what is the best to use between the Adafruit Motor Shield and the EasyDriver. What is best suitable for my application ? and in terms of the Arudino code how do I make the motor stop completely after specific number of rotations. I have the Stepper Motor connected to the Arduino and I tested it using the Example code in the Arduino software but I am not really sure how to make the motor stop completely? As of the power supply, I am planning to use an external battery buy not sure what voltage I need. Your help is really appreciated. Thanks

Asked by james112343 1 year ago

CDROM stepper motor problem with movement

I have been having intermittent problems with my cdrom stepper motor. I had a four pin motor soldered to a bare copper wire. I used the pins not the little ribbon cable and I left the ribbon cable attached because I figured, as soon as I snip it off I would regret it later. The other end connects to a breadboard that is in line with the stepper input to the EasyDriver motor controller. I have been using GRBL controller on my PC and when I tested it the first time in a vertical position it would just wobble around, not moving up nor down. I thought the stepper motor was bad so I got another one. The second was wired the same way, 4-pins, and it worked in the vertical no problem. Then later, while working on the rest of my project the second cdrom motor that was working did that same wiggle without moving up or down. I realized that the solder connections were very close together and that two pins were electrically connected. I modified the wire to basically a homemade male to male jumper wire. The extra pin made the room I needed to unsolder the two pins. Once again the motor worked up and down with no wobble. I have done nothing to modify the cdrom stepper any further and went to test my motor today after a couple weeks hiatus and once again, wobble with no up nor down motion. At this point I am stumped. I have reason to believe that my solder skills are lacking and that my homemade jumper has broken internally inside my shrink tubing where I cannot immediately see it but If anyone else has had this problem and knows how to rectify it please let me know. I hope there is enough info here laying out my problem and that someone can lead me in the right direction. If it also helps, I have checked my pin out and I do not feel it is backwards or crossed. I checked the resistance between the four pins and the end of my "jumper" and is approximately, 40, 20, 40, 100 ohms for A-, A+, B-, B+, respectively. I am really not sure what these number would mean but my buddy told me to check the continuity from end to end.

Posted by dankozi713 2 years ago