Japanese editor have a problem.

It seems like the editor have problem in Japanese site. I can create an instructables and steps(add step), but couldnot edit a step. When I select a step, it apear an intro page. English site is ok for editing a step. Please fix it.

Posted by yshiozawa 3 years ago


Editor shows plain HTML

Hi, while working at this one https://www.instructables.com/id/Waveshare-EPaper-and-a-RaspberryPi I experienced some clitches in the editor. 1. Code sections (formated with the paragraph "Code") are loaded in the editor including the HTML formating tags etc. When saving this they apear in the text as well, so the formating within the code section is destroyed every time. Browser = Chrome 60.3312... all my Safaris  On an up to date iPad the complete page is shown as HTML within the editor, I did not try to save it there Feature Requests 2. More Header styles 3. insert a table ? User experience suffers a bit :-( Cheers Mario

Posted by mariosis 10 months ago


Brazilian editor

Hi, My name is Andresa, I love this website and I wanted to know if you feel like translate it to other languages and I would love to help to translate it to Portugues (from Brazil) which is my mother tongue. Thanks a lot!

Posted by drexy 5 years ago


This site's editor is the worst I have ever used…

This site's editor is the worst I have ever used… Once again, I have wasted my time in a frustrating effort to simply answer a question in my own Instructable, thanks to the still horrendous forum editor. Even after years of being online, and my and other people's utter frustration with this editor, it is still the worst forum editor on the web. Let me describe for you my current experience. First of all, I make it a point to compose my message in a text editor because I know from bad experience, that it is a certainty that the editor will lose all text that I enter at some point. OK, so I compose my message which contains some html anchor tags with links and text. I paste it into the text box. I hit the Preview button and nothing happens… Great. I see that NoScript (Firefox 30.0) is showing that there is some javascript that is not enabled. I temporarily enable JS. Poof! My text is gone!!! What did I tell you? I have to keep enabling JS several times to finally get rid of the red barred circle on the NoScript icon. I now re-paste my text that I thankfully still have safely saved in my text editor. Preview still doesn't work so I decide to switch to the Rich Editor. BTW I tried switching to Safari to see if it worked there and it didn't so it is not a browser issue. Now Preview works but all my html code is being shown as code and not nicely formatted text with embedded links. Wonderful. I have no intentions of wasting more time with the Rich Editor, trying to add links in the painfully slow process of point, click, copy, paste. No thanks… So I refresh the page. Poof! Text gone. I re-paste and simply click 'make comment' so I can PREVIEW my post. I need to make a few changes so I have to DELETE the post--there is no way to EDIT it like there is in any other forum I have ever used--and I have to repeat this ridiculous ritual several times to finally get it to the point where I can finally post the comment for real. Keep in mind, I could not use any formatting like bold or italics on any of the text like I wanted to do because there is no longer any markdown language. Formatting is only available in the Rich Editor which I refuse to use for reasons already mentioned. Oh, and one more thing… I tried to upload an image and the server was 'down for maintenance' so I gave up at that point. I was told that as a PRO member, the editor was an improved version of the normal one. I don't see any improvements. This and many other similar experiences I have had ONLY on this site, is IMO unacceptable. We all have a life and have much better things to do than waste hours of our own time struggling with an inferior editor in order to freely share our ideas with other people. This in itself is a creativity stifler. I have complained about this before and I probably will again until (IF) this problem is addressed properly. Obviously we the users are the life blood of this site and we deserve much better treatment. Once again, I make no apology for ranting and complaining--Kiteman. This crucial issue needs to be addressed. Get a new webmaster if that's what it takes. The current one is not doing his/her job. PS Wow, I had to preview this post before I could publish it and I see that all the breaks between paragraphs have been removed. Unbelievable. Even in an all-text post there are problems, which just serve to emphasize my point. PS 2 Wait a minute… When I went to edit the post and previewed it, the breaks suddenly miraculously appeared. So not only is the editor flakey, it is unpredictable as well.

Posted by Laral 3 years ago


How Do You Like the New Editor?

How do you like the new editor?  It's called the CKEditor, and it shows you how the text of your Instructables and comments look while you are editing them.It was quite an undertaking to convert all the existing text on the site, so if you see anything awry, let us know.

Posted by ewilhelm 8 years ago


what happened to the old editor

In not a fan of the new editor, so Ive been using the old one till today.... wheres the old editor gone? please can i have it back?

Posted by liquidhandwash 4 years ago


Plain editor

PLEASE fix the basic editor in the answers section. It can't be that hard to force a into the html on a CR character.

Posted by steveastrouk 8 years ago


NEW EDITOR!!!!!

It looks different, and its easier to use, the new editor is awesome. I noticed this when i was working on a new ible....................

Posted by DJ Radio 9 years ago


what does "rich editor" mean? Answered

When you post a comment it says rich editor at the top. what does this mean?

Asked by Acepilot42 8 years ago


Rich editor in replies to Instructables broken.

It looks like the rich editor is broken when trying to comment on an Instructable. - Answers is OK.. Tested with FireFox and IE, 2 different machines. The standard editor appears below a 1/2 page of white space and the "rich editor" button has no effect.

Posted by AndyGadget 7 years ago


New Instructable Editor

I'm just about to list off all the sweet new features in a blog post, but right now, try out the new Instructable editor!https://www.instructables.com/id/editYou can also get to it from the "Try the new Editor!" link in the upper right of the standard editor

Posted by ewilhelm 10 years ago


Links in the instructable editor

Hi, I'm writing an insrtructables and I can not insert any hyperlink.

Posted by andre72 2 years ago


What is the best free video editor for vista? Answered

It will be used for my church and personal use.

Asked by geoffOfAllTrades 9 years ago


New editor does not do proper paragraph breaks without [Rich Editor] option

The new editor has a pretty substantial bug.  If the user leaves the editor in the new "default" (plain text) format, it does not respect carriage returns.  It should do so.  Most particularly, it really ought to follow the convention that two carriage returns correspond to a paragraph break.

Posted by kelseymh 8 years ago


EDITOR MALFUNCTION!

Whilst I was editing my new collaboration, an unfortunate thing happened, twice. The page i was working in duplicated itself on all the other steps!! I tried with both the new and old editor, the same thing happened.

Posted by KentsOkay 10 years ago


Rich editor bug

All to often when I paste something into the rich editor it loses the cursor and I have to guess where it may be -- Why?? Happens to a lot of people. I, for one, of many would like Rich ed to be the default for the pro users.

Posted by rickharris 7 years ago


New Editor by default?

I've been a using the new editor, and I think it's a big improvement over the old one. Is there a way I can use it by default? Yes I know it is but one click from the old editor, but by nature I'm a very energy consumption conscious person (aka lazy), and I'd prefer not to expend that 0.25 food calorie on clicking the "try New Editor" button. So how can I reduce global warming and use it by default?

Posted by KentsOkay 10 years ago


Japanese editor have a problem.

It seems like the editor have problem in Japanese site. I can create an instructables and steps(add step), but couldnot edit a step. When I select a step, it apear an intro page. English site is ok for editing a step. Please fix it.

Asked by yshiozawa 3 years ago


Problem with indent in new editor

There seems to be an issue with indent in the new editor. I am using Google Chrome Version 34.0.1847.116 m on win 8.1 See attached screenshots  from https://www.instructables.com/id/Vegetable-gardens-from-old-water-tank/ with an image from within the editor with indents and second image with saved version. I add an indent when editing but on save the indent vanishes in the editor and it is lost on the saved version. This is a consistent behavior, I have tried numerous times.

Posted by Microbe 4 years ago


Oy! Where's the "Collaborate" Thingy for the New Editor?

I've been working on a colaboration, and I've noticed that there's only a "Collaborate" option on the old editor. WTF is up with that?

Posted by KentsOkay 10 years ago


Best (for viewer) schematic editor?

Hi all, this question shouldn't be to hard to answer... What schematic editor do you guys use to make "instructables friendly" images? Meaning images that pretty much anybody can understand, with little to no circuit experience. Eagle is a bit hard for the beginner to comprehend...

Asked by astroboy907 6 years ago


New editor issues

First time with new editor, I typed up a new 'ible (saving often), clicked publish, and "poof" all of my text was gone.  Title, body, everything...gone.  It said "you must add a description first."   I'll type it up in Word first and try again.

Posted by The Papier Boy 6 years ago


What happened to the Instructable Photo Editor?

When adding photos to an Instructable the photo has a "view/edit" link on the imported photo.  Clicking it used to take you to a photo editor to crop, adjust, color correct annotate, etc.  Now the link only lets you view the photo. Has the photo editor gone away or is it located somewhere else.  It was so  nice to be able to edit photos via the Instructable website as needed.   Thanks,

Asked by wannabemadsci 8 months ago


instructable editor problem

I am trying to do my 3rd Instructable.  The last one I did in November was really straight forward. It seems like with the new editor (or maybe with my new computer?), the editor isn't working.  When I click "start instructable" from the "publish" tab, a box comes up saying "Please enter a title".  But the box is not active--the only thing that works is the x to close it. I've not experienced this problem and have no idea if it's the editor or what.  I tried with both Firefox and MS Edge. thanks for any information John

Posted by Dr_K 2 years ago


Line-break Text Editor Bug

I guess there's a bug in the new text editor. Whenever I save/ publish a guide. All the line breaks are not rendered exactly as I input it. It's missing the "" line break. This happens when I do a double line break for leaving a single line blank. For now, I use the source code window to manually add the extra "". Best, Angelo

Posted by ASCAS 4 years ago


How to Post Code in the Editor

Could someone please help me. Please show me the correct way to post code in an "ible". I have seen where some people post it in its own box. I would like to be able to do that, Im just not sure how.

Posted by MakrToolbox 1 year ago


New Editor Fixes Relased!

Hi! So we released some fixes to the new editor that should prevent the "forever updating" error. Also you should be able to click images attached to each step to add image notes to them, view them in a larger size, etc. without re-ordering them. This is specifically because Kiteman and rachel asked for it, so thank them. Please let me know if there's any more bugs. - Dave

Posted by dworley 6 years ago


Editor Bug - random steps disappearing

Another editor bug. I have been preparing a thirteen-step instructable. While I worked on the images on the introduction & step 2, all the text vanished from step 10, even though I hadn't touched it. When I re-typed step 10 and saved the project, step seven (a long step!) also vanished. @staff who read this, it's the project I mentioned on CT.

Posted by Kiteman 6 years ago


horrible bug in new editor

Ok so i wrote a quite long step, works fine. i went to add a picture so i dragged one to the drop area. chrome decided to open the picture instead of adding it, not that big of a problem. upon reloading the page i see that the auto save rubbish deleted all my text and auto saved the step that i had been working on for a hour. please just bring back the old editor.

Posted by knutknackebröd 4 years ago


Posting formatted code

How do I post properly formatted code with the new editor ? The old one accepted Arduino format cut/paste, the new one mangles it completely. Steve

Posted by steveastrouk 3 years ago


Auto Save in editor randomly breaks

This is been going on for a few weeks, Ill be typing away and the auto save will kick in and then just keep spinning. Once it starts I lose all  of my text or photos etc. The only work around it is, to copy all my text, shut down the editor reopen it and paste it back in..... if i notice it not saving. It does it randomly but once it spins longer than 5 seconds or so, it just keeps going. Im using a mac book with firefox 43.0.4 anyone else having this problem?

Posted by liquidhandwash 2 years ago


Problem with Editor--Unable to enter text

My earlier instructables were easy and the editor worked fine.  I'm running Windows 10 now (vs. 7 on my old machine) if that makes a difference.  now I click "start instructable" and a box comes up to "enter a title". But the box is not active.   Does anyone have an idea what is going on?  I have not used Instructables for several months, but something is different here. Thanks for any advice.  I'm on Windows 10, and tried it on MS  Edge and also Firefox. John

Asked by Dr_K 2 years ago


Create Instructables in the New Editor

Here at Instructables HQ, we're always looking for new ways to make it easier than ever to share the things that you've made.  Today we are very excited to announce the first public beta release of the new Instructables editor!  The new editor allows you to create, edit, and publish Instructables.  You can even use it to make changes to Instructables that you've already started or published. Some of the new features include: Drag and drop interface  - add, remove, and reorder photos and steps, all with drag and drop. (those of you who are already familiar with the Instructables iOS and Android mobile apps will love this feature) View All Steps - the landing page of the new editor gives you an overview of all the steps and images in your Instructable Continuous Editing Experience - edit, upload, save, preview, and publish... all without a single page reload New Uploader - rotate images and see the status of your upload Easy Embed - embed video and media from a variety of sites Pixlr Image Editing - crop and retouch uploaded images in just a few clicks with Pixlr photo editor integration Easy Preview - preview your Instructable without ever leaving the editor Cover Image Selector - select and crop your Instructable's cover image, so it looks great on the site and on your phone New Publish Page - add keywords, select a category and channel, and enter your Instructable in contests, now in a clean, new interface So poke around, edit, and publish, and let us know what you think.  Please leave any comments, questions, or feature requests in the comments below.  Definitely let us know if there are any bugs we still need to work out! How do I find the New Editor? To create a new Instructable from scratch, follow this link: https://www.instructables.com/editInstructable To edit a draft or published Instructable (note: you can only edit Step by Step Instructables in the new editor, you will be redirected if you try to edit photo or video instructables): 1.  Login and navigate to one of your drafts in the current editor (Go to https://www.instructables.com/you?show=UNPUBLISHED and click the edit link next to any of your drafts). 2.  Click the big orange button at the top of the page that says "Try the New Editor".  You will get redirected to the new editor, with all your Instructable's data loaded and ready to go.  The url looks like this: https://www.instructables.com/editInstructable/edit/XXXXXXXXXXXXXXX

Posted by instructables 4 years ago


Widescreen Formating

It just occurred to me that the format of the new editor causes there to be a disconnect between the images and the text. Often I'm having to scroll up and down repeatedly to see the image the text is referring to. The format of the editor is predominantly vertical while screens are predominantly horizontal/widescreen (or can be turned). What if the text in an ible was next to the images instead of below? See the image for precisely what I mean. 

Posted by Brooklyntonia 3 years ago


Editor disappears

Before the last update when I was in the middle of writing an answer I could leave the page to pick up a link or something like that then go back to the page pick "answer" and my answer would still be there.  Now the answer is gone.  What changed?  Is there any other way than creating a new tab or window to do my research and still keep my answer going? Using Firefox.

Posted by Re-design 8 years ago


New Editor Relased

We've released an updated version of the editor. Some new features include: It's powered by jquery, which will mean nothing to you if you're not a huge nerd. Automatically saves after doing anything but typing. Remember to save anything you type, just like a word processor. Incorporates a new uploader, which will hopefully suck less than the current one. Should be faster, I think? I'm not sure about this point yet, still have to see it in the wild. Will definitely fail tonight, there are caching issues. I hope I can delete this line in the morning! Various bugfixes, the previous editor was heavily in need of going away forever, heavily. Dances when no one is watching. PROVE IT DOESN'T. As always, please let us know if you have any problems. Or, also, let us know if you think it's awesome. Nobody ever does that. It's lonely here. Send cupcakes.

Posted by dworley 6 years ago


How to return to 'ible in progress?

I started creating an instructable in the new editor, saving as I went. I shut down my computer and went to take pictures to add to it. When I returned and opened up Instructables, I can't seem to find where my instructable in progress is. Any guidance is appreciated. And, yes, I feel a bit stupid.

Asked by skistler 1 year ago


New Editor Feedback

I just used the new editor for the first time, publishing a quick project, and starting a longer one. Short version: I like it. I particularly like being able to edit my images via Pixlr. Rotating and cropping on the fly were ideal. Longer, less-positive version: The "unordered list" and "order list" buttons added neither bullet-points nor numbers.  All they did was indent the text. There is an "intuition breakdown" adding images to steps - when I wanted to add images from my library, I thought I couldn't, until I discovered that the library can be accessed via the "Upload Images" button.  The "Upload Images" button ought to be renamed "Add Images". When using the "Upload Images" pop-up, the actual image upload function did not work.  I clicked the button, and nothing happened - no error message, no wait symbol, nothing. This is all experienced using my desk-top PC, running Windows XP and FireFox.

Posted by Kiteman 4 years ago


If label hangs off edge of image, save button doesn't work

In the new editor if you have a situation like the attached image where you create a label near the edge of the screen, when you click save it thinks you have clicked outside the image and moves to the next image instead of saving. The workaround is to save it further to the left and then drag it into position. Windows 8.1 update, Chrome Version 34.0.1847.131 m

Posted by Microbe 4 years ago


Why can't I drag my intro photo? Answered

I did publish my instructable BUT it will not let me drag my intro photo.  I dragged all the other photos.  What's the deal? 

Asked by onrust 1 year ago


Can Autosave be disabled while editing?

Can autosave be turned off in the editor?  I'd rather not have anything be "published" as I'm still typing and editing.  I think it's better to hit the "save" button when I'm done. Another reason I have this suggestion/complaint: I'd noticed that some of my recent edits have been mysteriously  reverting back to old versions and couldn't figure out why this was happening.  I've come to the conclusion that by accident (maybe due to inadvertent swipe of the touchpad or mouse, my browser went back a page in history, so it brought up my previous version of a page I was editing.  The frequent auto-save saved this previous edition of my page, wiping out all my edits! This is obviously really annoying, and could be resolved if the editor didn't autosave and just saved when we tell it to. Also, what's the difference between save and publish?  I understand the difference when you've never published a instructable yet, but once you've published it once, you never have to publish again do you?

Posted by thrashercharged 4 years ago


Ible text disappears (permanently) during editing

While editing the Intro of an unpublished instructable, I clicked on the "Library" tab to delete an unwanted image. Then I selected the "Upload" tab, and uploaded two replacements. When I scrolled up, all the Intro body text was gone. Kaput. It had been entered and edited several times the day before, so it wasn't a "you didn't save your changes" bug... ------------------------------------------------ Update --------------------------- Another minor bug,  on my You page: Instructables: You've published "X instructables." You're working on "X instructables." If you click the You're working on "X instructables." link, the counter at the top says Unpublished (0). But if I select the Instructables tab at the top, it correctly lists Unpublished (1).

Posted by gmoon 8 years ago


hammer editor?

Hey i was wondering if any would be interested in seeing some hammer editor tutorials on this site as i would be able to make them.if enough people are interested ill post a hammer editor tutorial.

Posted by smidge147 10 years ago


Subscript and Superscript in Instructables Editor?

I'm missing something glaringly obvious here, but how do you get subscript and superscript in Instructables text editor?

Posted by ohoilett 1 year ago


Editor not saving step when reordering

In the editor, for an instructable, a step that would otherwise be automatically saved is NOT when you click 'Reorder steps.' all progress on that step since the last save is lost. 

Posted by drinkmorecoffee 6 years ago


Instructable Editor repositions

I was editing an Instructable and accidentally hit a key near the home key on my keyboard. I had selected text, I think my shift key was still down and this happened to the editor: I had to save the Instructable, close the editor, and re-open the draft of the Instructable to fix the problem.

Posted by CommunityWorkshops 1 year ago


Who are the editors of each channel?

I've looked, but cannot seem to find a post listing all of the editors of each channel. Is this something that is available, and if so, could someone point me in that direction? Many thanks!

Posted by WUVIE 3 years ago


Editor is duplicating / eating my steps

When I went to update my published instructible, the editor ate over my steps! How can I fix it? (Every time i try to re-edit, but then it eats over other steps.)

Posted by britsteiner 10 years ago


Where is gone Pixlr editing in the EDITOR?

I remember that was possible directly edit the pictures in the library via PIXLR...is gone? It was only via Mobile App???

Posted by Skyfinder 1 year ago


Rich Editor working for comments

UPDATE: Whatever was wrong earlier seems to have been "fixed" (or gone away). It seems that the Rich Editor button below the comments editor box is no longer working.  When I press it, nothing happens.  No icons, no change to the box content.  It just stays in "plain text/raw HTML" mode. I'm using the latest Firefox 3.6.11 on MacOSX 10.5.8.

Posted by kelseymh 7 years ago