Author Options:

After Delecting files, they re-appear.... Answered

I have a 1.0 GB SD card and im trying to delete the files off of it. When i "delete" them, and plug it into the same thing or something else, their still there. The lock on the card isn't on The files are maked as read-only, so i turn it off, but they go back to read-only any ideas? also: Tried to format it (with windows right-click format), at the end of the formatting it says unable to format



10 years ago

Can't delete files off 1GB micro SD card

I have a micro sd card that I used in a HTC 8525 PDA for a while, I swapped over to a Blackberry Bold, I put the card in and it says "a media card has been inserted that contains errors. To correct the errors please use a disk error-checking utility on a computer" Well I tried to format it in the Bold but it wouldn't, I put it in the HTC and deleted all files, put back in the Bold and the same message. So I hooked the card straight up to the computer and the files were still on there. I deleted them and tried to check for errors, it said unable to. I tried to defrag and noticed that there was still some usage on the card. I pulled it back up and Be hold All the files where back on there. I tried to delete 5 times and they will not delete. If anyone has a way to clear off my card I would appreciate it.

Sounds like you are not the only one.

For the Android file system, you might try:
new File("/sdcard/my/file/is/here.txt").delete()
which should work.

Sometimes a file will become corrupted, and then nothing works.

I have seen the same Filez disagreement awhile back. I couldn't even delete it through the PC, so I had to copy all legitimate files onto the PC, reformat the
card, copy them back.

The file that wouldn't go away was a zero kb file with a strange name.
The application on the PC called "Killbox" was unable to delete that
file, too.

But you COULD try FileProg.prc (if the link breaks you can Google it)

It looks like you could use a file manager like: TealMover although there is money involved and no guarantee it will work.


10 years ago

. Right-click:Properties. Tools tab. Check Now...


10 years ago

there may be some issue with the recycle bin. try to delete them with shift + del try on another computer try as administrator try on a linux computer (or run a linux live cd on your computer) try with the write switch in the other position and again in the previous one