119Views2Replies

Author Options:

Animated GIFs only play if they're embedded in text Answered

macOS 10.12
Chrome 60.0.3112.113 (Official Build) (64-bit)

If the GIF is embedded in the text of the step, it works fine. Examples: IOT Made Simple: Playing With the ESP32 on Arduino IDE (step 4 onward), Split Flap Display (intro and step 5)

If the GIF is put in the image section of the step, though, it doesn't play and just looks like a still image. Examples: PIDDYBOT - DIY Arduino Balancing Robot (every step except 1), Making a Gif From Photos (intro and step 1)

(Also, GIFs in Design Challenge entries' image sections seem to work fine. Example: Lab Centrifuge Fidget Spinner (second image))

I first tried opening the images in the lightbox, and also opening them in new tabs via the context menu—neither helped; the images were still static.

I tried clearing the cache, because I found that suggested elsewhere for GIFs not playing in Chrome, and that did help, but only very slightly. Upon refreshing the page after clearing the cache (or upon shift-refreshing the page to bypass the cache), the GIF will play for less than a second and then reload and become a static image again.

I also tried Incognito mode, with all extensions disabled, with exactly the same behavior (playing briefly only when loaded without the cache).

I also downloaded one of the non-playing GIFs (from the image section of a step) and one of the working ones (embedded in the text) to my computer and opened them in Preview. The sidebar showed only one frame for the non-working one (and looked just as if I had opened a static JPEG image) and all of the frames for the working one. A screenshot of this is attached. This seems to me to indicate that the server is not sending the proper file (or is sending the proper file and then sending a bad file to replace it) when the image is in the image section.

Steps to reproduce: I have no idea. AFAIK all I did was load the page and it was broken.

Discussions

0
None
seamster

1 year ago

Hello!

This is known bug that sprang up on Friday, and the site's team of engineers will hopefully have it fixed soon. Thanks!!

Sam (seamster)

0
None
Matlek

1 year ago

Yes you are right the GIFs stay fix in the image section (at least on Safari 9.1.2)...

It is a shame considering that there is the GIF contest!