Author Options:

Arduino UNO R3 SMD Uploading Error on Widnows 7 64bit Answered

I just Installed Arduino UNO R3 SMD to my Windows 7 64bit. and getting

    avrdude: stk500_getsync(): not in sync: resp=0x00 error when uploading

I'm sorry if it is a old problem solved somewhere in this forum. But last couple of hour i couldn't find it. Please see attached image for better understanding.



Regarding my problem i got it to work. Don't know if it is too basic but i just copied rxtxSerial.dll file to windows systed32 folder.

Thanks for your response.
I'm *sure* Driver installed properly. Regarding wrong board & port it's ok as you can check it on the image (lower right corner of the IDE {Arduiono UNO on COM 28}).

I've changed the port to 2 and 30 still no luck. So far what i've tried :

In the mean time i want to add what i've tried so far :
1. Trying 3 more USB port.
2. Trying Another Cable.
3. Uninstalling/Installing driver.
4. Trying different port (28->30 and 2).
5. Restarting laptop.
6. Tried most of the board type in IDE. (most type except Arduino-Mega RX led flashes 3 times after i hit upload button then shows error)
7. Tried Serial Monitor and sending different data (Pressing send button Initiate RX led blink one time).
8. Connecting/disconnecting several times.

I don't have anything else connected to UNO.

I've also tried hitting Reset Button just before upload.

let me know what lese i need to try.


Several possibilities: wrong Arduino driver installed, wrong board selected in the arduino software, wrong COM port selected in the arduino software, or something in your code is taking control of pins 1 and/or 0.

That COM28 for Arduino is interesting, however. I've never seen one go so high. I *assume* the Arduino software can handle a COM port with that high of a number, but maybe not? Do you have a lot of Bluetooth dongles installed? Is that what all those BT COM ports are for?