Author Options:

Arduino UNO not working with Arduino WiFi shield Answered

I'm having a lot of issues regarding interfacing an Arduino wifi shield with the Arduino Uno. My Arduino works fine when the shield is not attached to it but when I attach the shield, I'm unable to upload the code; I get:

avrdude: stk500_getsync(): not in sync: resp=0x00

I also tried to change my board and uploaded the code on Arduino due, then it gives:
device not found on COM 8 as error

Otherwise the boards are perfectly fine, they are working usually they should. Also, I'm unable to reset the board when the shield is mounted on the board
The code i uploaded is simple blink code,however none of the code are uploading
The shield i'm using is this , the arduino's official WiFi shield

These are the things i have already tried but none is working :

-powered up the arduino from external power supply (12 V, 1A)

-removed the shield and programmed it (code loads on board ) but then mounting shield on board, the led on pin 13 cease to blink

-without using the shield , arduino works as usual (like that Rx, Tx pins work and pin 13's LED and power led blinks /lit up) but with the shield stacked on board , nothing seems to work


Do you have anything attached to Arduino pins 0 and/or 1 through the wifi shield? Those pins are shared with the UNO's USB programmer and can foil USB programming.

Also, if you're using a pre-3.0 UNO board (i.e., if the back of the board isn't white), you need to do the steps outlined here: http://arduino.cc/en/Guide/ArduinoWiFiShield#toc2

neah! nothing is attached to pins (any pin i meant ) , also i have latest Arduino uno R3 and the arduino due as well
Can u please suggest some other ways to tackle this up?

Unfortunately I've never used the wifi shield so I'm just throwing out some typical Arduino things I've seen that might be the problem.

Does the UNO have power when the shield is plugged in? I.e., is the power LED lit? It's possible, I guess, that the shield could be drawing more current than the PC USB connection can provide, browning out the UNO. If that's the case try powering the UNO with a 9v battery or 9v wall adapter.

And just to check -- you know the usb connection on the shield itself is NOT for programming the UNO, right?

actually the power LED lits up on uno board when the shield is plugged in , however the pin 13 i.e. the inbuilt led doesn't lit up . I have tried both ways to power up the board like adaptor and the USB , but it ain't working !!

I had another thought -- sometimes the solder points on the underside of an Arduino shield short out against the Arduino's USB jack, causing all kinds of mayhem. Try backing the shield off the Arduino a little -- not enough to pull the header pins out, but enough to keep the shield from touching the USB connector. Alternately, put a piece of electrical tape over the metal part of the USB connector to insulate it.