Author Options:

Arduino Uploading Problem? Answered


I have an Arduino Duemilinove with Atmega 328 and Arduino 1.0 programming language. I am using a Mac. Whenever I try to upload a program, It tells me avrdude: stk500_recv(): programmer is not responding. I have downloaded all the drivers and normally the port that the Arduino is on starts with  /dev/tty.usbserial, but that does not show up. I have tried on a PC also and it doesn't upload either.


Its not impossible the bootloader is corrupted on the Arduino. Are you sure the device is ennumerating in Windows and Linux ?

In Windows, use Device Manager, in Linux, I think you say cat /dev/usb

I have checked device manager and it does not show up.

It should show up in Serial ports ?

Last chance: Try a different cable.

Already did. I have tried with four different cables.

The FTDI chip is the "USB-ness" of the board. Its not that expensive a chip, and it could be replaced.

So, the com port (or dev/tty.usbserial) isn't showing up when the unit is plugged in?

Confirm the arduino environment is looking for a dumil with 328 and the port is actually showing up in the list - reboot/reinstall?

worst case your chip has some fuses set wrong and I have no idea how to fix that.

Also, when I try to upload, the RX and TX LED's don't light. So that tells me it is not getting anything. And i rebooted the computer and used 1.0 and 0022 vesions of IDE