Author Options:

Arduino (uno r3) not in sync, help? Answered

So I'm pretty new to arduino. Got myself an Uno rev3, and all was well for a couple of weeks. Now however, whenever I try to upload a sketch I get an error message telling me this:

avrdude: stk500_getsync(): not in sync: resp=0x00

Googling this has not solved anything.

I don't think there's anything messed up with the IDE, as I get this in both arduino 1.0.1 and 1.0.2, as well as Visual micro.
I tried everything I could think of. Resetting the board did nothing, neither did re-installing drivers or rebooting.

The serial bounce test showed no errors, and the Rx LED blinks when I try to upload. 

(If you are unaware, the bounce test means connecting Rx to Tx and opening a serial monitor. Everything you send should then be bounced back.)

I'm currently thinking bootloader issues, since resetting the board does not make the pin 13 LED blink. 

So, does anyone know what to do here?
UPDATE: I am an idiot. This whole time, I had the atmega328 plugged in backwards. It works now.


Sounds like you've screwed the bootloader. Its not uncommon. The fix requires an "SPI programmer", which plugs onto the little 6 way header on the board. Google for it, and look on Instructables.

So I guess my best bet would be to build a parallel programmer. Simple enough.



2 years ago

in my case reseting the board blinks the led on pin 13 what should i do please explain i am a total newbie


2 years ago

how to plug in and out the atmega ? you have to solder and unsolder it i have the same error please help me


5 years ago

I am definitely not an expert but i have had this error before.
Typically it is caused from one or more of these:
Unplug the USB then plug back in
Choose the correct board
Choose the correct Port

Check the port in the device manager, easy way to get to the device manager is right click on my computer-click manage-click device manager on the left side- look for ports. Unplug the Arduino's USB and watch the ports ( COM & LPT ) to see if there is a change. Plug the USB back in and watch the ports to see if there is a change.
Good Luck

That worked for me! Thanks @WWC

Great i am glad it helped!

Thanks, but I've already tried all of those. None worked.


5 years ago

Sometimes I get this problem when the arduino is executing a really tight loop (eg. frequency counting interrupt). Try holding down the reset button until the IDE gets to the "uploading" phase.

Tried that. Unsuccessfully, I'm afraid.

Steveastro has the correct answer: You can use another arduino as an icsp: I made a video about it:

There are lots of others on youtube also -