Author Options:

Asus laptop wont connect to certain wifi network anymore? Answered

Hi !! .. Okay, so I got myself a new asus laptop about 2 weeks ago. I brought it to work and connected it to my works wifi , as I always do with my phone as well , and everything worked perfectly. I was able to use the wifi for about 3 or 4 days when suddenly the next day it just wouldn't connect anymore. So I tried forgetting the network and reconnecting, but it says "verifying and connecting" and then "cant connect to this network" .. The password hasn't changed, I can still connect to the works wifi with my phone and other devices, even when I forget the network and reconnect. And my laptop can also connect to other networks and hotspots, like my phone, my moms phone, the cafe's network, etc. So the laptops wifi does work, just not with the works network anymore.. If anyone has any suggestions or thoughts please ?? I would really appreciate it.And im not very tech clever, so please explain nicely so I know what your talking about :) ! Thank you.



2 years ago

let me start by saying good news this was very helpful and i got it fixed with some extra help and steps -

first step is restart the laptop and make sure wireless switch or the wireless router or the internet source is on .

go to the power management of your wireless adapter and unchecked the box

and go the driver and update the latest driver than restart the laptop .

if all this did not work uninstall and delete the wireless driver from device manager and visit asus website to get the support or latest driver at https://goo.gl/w3tb15 and after this is fixed update the driver and windows again . thank you


2 years ago

you just need to follow the steps and you can get it fixed. just need to update the wireless driver and reset the wireless settings . and check the firewall or any other network filter blocking the internet connection and for more help visit asus http://goo.gl/vB0wbJ and call asus +1-855-208-2429 and see it that solves that problem . i got it fixed


3 years ago

Here are some small tips which mostly help to resolve this problem.Before go
anywhere try once this steps. All the steps can't write here you see here



4 years ago

Different frequencies ?
If you Wifi module supports both 2.4 and 5GHz and one of them failed...
network admins also love to block your MAC address if you tried to
access areas you should not or used the companies internet for private

I simply guess you did not bother to do the most logical thing first?
Like to ask the companies network admin if there is a problem he can tell you about?
No offence but sounds like the classical lockout from unauthorised network access.


Answer 4 years ago

Nope, I actually did. And we are allowed to use the companies internet for private use. I also don't try to access areas I shouldn't.


Answer 4 years ago

Well, you state the Laptop works fine in
other networks, you also state other devices connect to the company
network with no problems.
This either leave a setup problem on your Laptop or a blocked MAC address for your Laptop in the companies network.
I simply don't think the network use a different frequency band that failed in your Laptops WiFi system.

Since you are either unable or unwilling to provide detailed infos to solve the problem I will ask my crystal ball instead....
Here is what I saw in my crystal ball:
You use Windows8 and an Atheros WiFi card / chipset (Maybe integrated into a Qualcom solution).
Your default network settings are set to 802.n only.
The Laptop uses the standard Windows drivers for the network card.
network admin was either not capable of providing a fix (which I doubt)
or not in the mood to help as the laptop would be mainly used privatly

If my crystal ball was not completely wrong you will need
to find proper drivers for your network card that are from the chipset
manufacturer and not Windows, maybe the Win7 driver works well too.
driver available means the company network has to change their protocol
to 802b or g but not n or combined - I doubt they will make that change
for you.
Your problem is a classic Win8 problem ;)

Just I case I am wrong:
For further assistance the full set of all details is needed as otherwise we can run around in cricles for weeks here ;)


4 years ago

Most common fix is to go into the device manager and uninstall the wireless adapter. Restart the computer and let it find the adapter and install the drivers. Then connect to the network. This refreshes the drivers and often fixes problems.