747Views15Replies

Author Options:

Bold text <p><strong> bold text </strong></p> not displaying in chrome and mozilla? Answered

For some reason all "bolded" sub-headings in my articles are not displaying in bold highlight. The html code looks okay?

I have tried two different browsers with same result. Changing the source code to <p><b>bold text</b></p> doesn't work either.

Does anyone else have this problem?

Tags:bugs

Discussions

0
None
MillennialDIYer

10 months ago

This still hasn't been fixed. It's aggravating for the instructable's editor to not show bold text, even if the published instructable does. Oddly enough, italicized text does show properly. Is this really that hard to fix, considering that it was working fine prior to the site "upgrade"? (It still pains me to call it that...)

0
None
audreyobscura

11 months ago

May I inquire which OS you are using?

0
None
lingibaudreyobscura

Reply 11 months ago

Windows 10 Home
Version 1709
OS Build 16299.192

I don't think the problem is with the operating system as I can overide the effect using inline CSS

0
None
audreyobscuralingib

Reply 11 months ago

Uff, that's not what I meant to ask, I typed OS but meant browser...D'oh!

Thanks for helping us isolate this issue!

0
None
lingibaudreyobscura

Reply 11 months ago

Windows 10 Home
Version 1709
OS Build 16299.192

Inline code fixes the problem which points to a setting in the CSS file.

0
None
seandogue

11 months ago

if the b tag doesn't work, try your text


I never really used strong.

I've had no issues using either direct insertion (my "try" suggestion) or the b tag in either Chrome or FF

edited many months later. for those of you who have found that my text shpowed up with bold font, I used a p tag and added

style='font-weight:bold;" to the opening p tag

0
None
seandogueseandogue

Reply 11 months ago

erm I was trying to say (put the appropriate brackets around it)

(p style="font-weight:bold;")your text(/p)

0
None
lingibseandogue

Reply 11 months ago

Thank you :)

your text

works a treat.!!!

The "bold" button in the instructables editor surrounds all highlighted text with . Guess I'll have to resort to inline code until this issue is fixed.
0
None
seandoguelingib

Reply 11 months ago

you can always add a css statement at the beginning of your doc, and then reference it with custom classes or apply via id, eg (I'm using parentheses to avoid forcing a behavior in the brower)

(style type="text/css")
input[type="checkbox {scale:1;max-width:20px;max-height:20px;}
.show_disclaimer {color:white;border:1px solid transparent;}
.show_disclaimer:hover {color:#cf0;border:1px solid #cf0;}
button.foo { color:red;background:black;font-weight:bold;font-style:italic;}
(/style)

or something like that.

one then references them like this (again parenthesis for presenting ti to you instead of forcing behavior

(div class"show_disclaimer") some stuff (/div)

etc

0
None
lingibseandogue

Reply 11 months ago

Windows 10 Home
Version 1709
OS Build 16299.192

Inline code fixes the problem which points to a setting in their CSS file.

0
None
lingiblingib

Reply 11 months ago

Sorry ... this was an ooops :(

A good case for having a delete button in the comments

0
None
lingibseandogue

Reply 11 months ago

Brilliant ...

I edited one article last night using an inline style as suggested and it worked well ... but pretty painful looking though the html.

Fortunately you only have to CTRL-V the code into each {p} tag and delete the {strong} tags. This approach looks so much easier.

Thanks for for coming to my rescue :)

0
None
MillennialDIYer

11 months ago

Same here. Glad I'm not the only one.

0
None
Yonatan24

11 months ago

Yup, I noticed that it doesn't work too. Haven't tried any browsers other than Chrome.

0
None
lingib

11 months ago

If I paste the instructables source code into a local test page the contents display correctly.

The correct code is there when I use the web developer's toolbox in mozilla which points to the CSS file overiding the highlighting ;(