Author Options:

Collaboration member cannot edit Instructable error Answered

I have several member working on a Collaboration and now none of them have access to the edit screen, this has only been a problem this week. All members have Mac books and safari of firefox or chrome makes no differences



Using the old or new editor, click the dropdown button and select 'collaborate', then enter in the names of members you want to collaborate with on this project. Only you as the project originator can add people to help you collaborate.

Your collaborators can access your shared project by logging into their account and going to their You page, then clicking on the Instructables tab and then collaborations.

Please make sure you (and your collaborators) don't have any script-blocking add-ons running (like AdBlock, GreaseMonkey, or LastPass) as it can inhibit how the site loads and may prevent functions from working.

Thanks Mike, Ive done all this a couple of months ago, it only just stopped working in the last week

Try clearing your cache and refreshing the page. It sometimes helps clear up weird things like this.

That is exactly what you should see on your side as the creator of the Instructable. For every collaborator, they'll need to disable all browser add-ons, to clear their cache completely, then log in and refresh the page.

Your collaborators can access your shared project by logging into their account and going to their You page, then clicking on the Instructables tab and then collaborations.

Did that help?

Hi Mike we cleared the cache, and cookies form the members computers tried firefox, safari, chrome, seamonkey still the same problem.
I dont think it a problem from this end

The new editor is still having some bugs worked out of it. I just heard from our development guys and collaborations is an area that will be getting a fix in an upcoming release. They suggested that the combination of a project with the new editor and immediately trying to collaborate may be the issue. Try starting a new Instructable using the old editor, then save and refresh the page, then try adding collaborators.

I can get it to work on my machine, but it may be due to admin. powers. If that doesn't work please know we've got this issue reported and will be fixed in an upcoming release with the new editor soon.
Let me know how it turns out. Good luck!

hi Mike Today I deleted the other collaboration members and added them as a collaboration again, same result they still cannot edit.

We're experiencing a lot of problems with the new editor rolling out. If using the old editor doesn't work all I can suggest right now is to hold tight while we try and fix all these bugs in an update soon to be released. I'm sorry about the delay.

Thanks Mike I wont see the class till tomorrow i will try again then.

An update--I deleted the Instructable that was giving me a hard time and started a new one. Got three steps in and am having the same errors in Chrome and Firefox. Will have to wait for this to be resolved before I can post any more. Let me know what you find. Thanks!

Also, just to clarify, I can't edit in the New editor either. Instead of an error message, I get the "saving" and "loading" pop-ups when I'm trying to add the step. I think at this point I'll delete this Instructable and start from scratch.

This happens in just the old editor. The new editor is fine!
For the old editor, I tried the cookies/cache with page refresh and this didn't solve it on Chrome. Downloaded FireFox and got a similar error message. Thanks, all!

Hi--I am having a similar pop-up, though the message is slightly different:

"There's been a problem updating your Instructable
SyntaxError: Unexpected end of input"

Any suggestions or thoughts as to why this is popping up? It shows up when I go to add a new slide to my existing Instruct able draft.

Thank you!

I have also had that message, try resizing your photo and renaming it, that seems to work for me, most of the time.

Thanks for getting back to me!

Unfortunately, I'm not trying to add a photo. This comes up when I'm trying to add a new Step. Any ideas?

This is a known bug we're working on fixing in an update we'll be releasing soon.

Does this happen in the new or old editor? What happens when you switch to the other editor?

It seems the new editor is a bit buggy, as mike said try logging out clearing the cache, and cookies and logging back in again and use the old editor.If your not sure how to do it just goggle "clearing cache, and cookies" for your web browser. Also you could try updating your web browser or using firefox if you dont already, as it seem to work the best on the instructales site.