Author Options:

Desktop computer having issues with connecting to home WiFi network, but has no problem with other WiFi networks, help? Answered

Good afternoon. Recently--four days ago-- I installed a new modem/gateway combo unit in my home and decided to keep the same SSID as well as pin in order to decrease the hassle of going through each of my devices and reconnecting them to a new network with a different password. All was going well and I had not detected any issues. The next day, I booted up my PC in the bedroom and I tried to load up Steam and play some games. It soon became clear to me that the internet wasn't working as it should. When I looked at the icon tray to see if I was still connected, it showed I was. I launched Chrome to look up a solution to my problem and it failed to load anything. I got my tablet out and it was doing fine with anything I wanted to do.

I eventually broke out an older laptop and used the Windows 7 built in ICS tool to use the ethernet cable and connect to the internet. It worked. So I grabed the old router and plugged it into the laptop's ethernet and created a new WiFi network and sure enough the desktop picked it up and it connected just fine to the internet. I switched back to the new (old name) network and it still refused to allow me access to the internet.

I am running Windows 8 fully patched with a TP-Link WN881nd WiFi card. System restore is not an option unless it is 100% needed.

I have looked at hundreds of forums and threads and none of them have been able to help. 


When you setup a new router you usually need to reconnect each device to it. Even with the same SSID and pass, it's doubtfull that they will swap like that. I tried what you described once and had nothing but headaches >.<

Try deleting the original SSID and the new one, then re enter the info for your new one.

If not, Try slightly altering your SSID's name with say a dash or something.

I did slightly alter the SSID's name and I still couldn't get any internet connection. I also did not have any trouble connecting any other devices to the new network as they just "seamlessly" transfered. I just recently went into the registry of the PC and deleted the old profile entry and tried to start fresh, but it did nothing to help the problem. Thanks for the suggestion.

Have you tried contacting the manufacturer? If your having troubles chances are others have also; The company's IT Dept probably has a fix. Least you can complain if they don't help you fix it :P

also reading your response to Vyger, "When I skip all those steps and connect to the new router via WiFi, I cannot load any websites though it clearly states I am connected to the internet." If your computer says it's connected to the internet but you can't open a web page (or says connection limited with a yellow triangle) means your IP and so-forth have been accepted, but the router is having troubles talking to it. Can you log into your router? With my newest one it will show me if there are any problems. it should note any bad connections on that page.

I have logged into the router's firmware and I can see my computer on the list of connected devices. The manufacturer was not in the least helpfull by anymeans. I looked into the event viewer and found a clue (I think) that would help.

Event 1001, Dhcp-Client: Your computer was not assigned an address from the network.......The following error occurred: 0x79

Event 1014, DNS Client Events: Name resolution for the name xxxxx timed out after none of the configured DNS servers responded.

These two errors are repeated multiple times.

EH, there we go ! now we have something to work with :D

start by opening up your wireless properties, go to your wireless connection and click on properties, select Internet protocol version 4 and hit properties.

Under the general tab, be sure "Obtain IP" and "Obtain DNS" are set to obtain automatically, then restart your comp.

**Be sure you set up your router to automaticly assign these settings as well** (allthough it already sounds like you have)

Let me know if that doesn't work and we can go from there :)


Good morning now, I gave what you said a shot and it was still a no go. Same errors and same problems.

Change the DNS from auto to assigned and put in the following numbers

Primary ---

Secondary ---

This will go directly to the high speed DNS server and by pass any other routing.

I would also put these numbers into your router that way it takes care of everything on the network.

You can also set your IP # manually as long as it is in the same range as the router.

The gateway is the router. The gateway # will be something like The last digit 1 designates that it is the gateway. You can set your IP to the same sequence but change the last digit to a number between 100 and 200. For example Actually there are more available but that is generally a safe range. This gives you a static IP that the router will not mess with and will keep from being assigned to anything else on the network.

I suspect that the problem has something to do with Steam. It might be trying to designate you computer as a gaming server with an IP number outside the proper range. Setting it manually should defeat that but might make it so you can't play games. You may have to set up some special setting in the router to allow those connections to pass through. For that you would have to get the directions from Steam.

aww you beat me to it ! lol

Just set them up manualy like Vyger said. Hopefully that will work !

I am really starting to get beyond the point of reasonable action. I first completely reset the modem+router combo unit back to factory settings. After that didn't work, I installed a brand new copy of Windows 8.1 onto a blank hard drive and tried to connect because the possibility of a virus was slightly there. That was a no go. So I then reset the modem/router POS again and once again, I was show no mercy by this behemoth of a nightmare. The problem that so irritates me is that earlier I tried using my old router directly of the new modem with a different SSID than when I first tried it running off the my Alienware laptop using Windows ICS, and once again it worked. I am 100% STUMPED and I am about to just cut the chord on this. I really appreciate the help you guys are giving me. One last go for it and if it fails, then I will post a video of me DESTROYING the damn thing and crying during the event.

All bitching and moaning aside, any ideas? 4 nights of all nighters and sleeping only about five hours each day are driving me nuts.


As Entertaining as that would be to watch, :D

plz don't, at least get your money back !

you can cause them just as many problems as they caused you :P

does you router have an option to select another Chanel? (still inside the 2.4 GHz range?)

** take note of the settings before you change it, you may need to change them back

Thank you x1000000000 :D this is the first time it actualy worked. I've seen you respond to other questions and felt honored when you answered mine. Thank you to all who helped me conquer this beast.

Rly that didn't work?

try punching in whts my IP on your tablet for your specific IP and DNS, then edit the last 3 didgits like Vyger up there said

After that I'm out of Ideas sadly :'(

There are a few more sinister things that could be going on. Especially because of Steam. He might have an infection with a virus that is redirecting network traffic, might be attempting to to turn the PC into a zombie. There is actually a whole list of things to try but it gets more complicated.

yeah i was leaning towards a virus too, there's just so many I can't give a definite answer

can't say I've had any probs with steam, but you never know right?


3 years ago

OK, since the other answer is getting a little long I will start a new thread.

Your formatting and reinstalling has removed the possibility of it being malware, etc.

The router is working correctly since other things can connect through it. By the way I am familiar with this brand. I put one of their routers in the county public library ( I am the IT person for them) to provide open access (a wireless hot spot) to the public. So far it has worked perfectly. Hundreds and hundreds of connections and it works fine.

So there are only a few possibilities left.

The wireless NIC in the computer is either defective or incompatible with the router. OR the Windows 8 drivers for the card are wrong or bad.

Easiest thing to do is to just replace the card. They are relatively cheap. Even a USB one would work work. I have a whole rainbow of different cards because sometimes one will just not work for a particular configuration.

As an acid test sort of thing (and to satisfy your curiosity) I would download the latest version of Knoppix and boot the computer with that. Knoppix is a complete LINEX system that runs off of a DVD. We use it for testing hardware and determining if a problem is hardware or software caused.

IF Knoppix can find and connect to the router and get online then your card is working correctly. If this is the case then that means that it is a Windows 8 driver problem.

If it cannot then it is either a defective card or incompatible with the router. This used to be a big problem. There were 2 rival chip makers and their chips would often not work together. If you tried to connect a NIC from one chip to a router with the others chip they often would not work. This problem was mostly resolved by the companies adopting standard protocols and I have seen very little trouble with it recently. However that does not mean that it has gone away. Yours might be a case of the chips being incompatible. So, get Knoppix, (its free) try it and see what happens. Its a big download by the way.

You can try the following options:

1 - Restart your router

2 - Reset your router (most unlikely)

3 - Re-connect your computer to the WiFi network.

4 - Forget WiFi network and re-connect.

5 - If you use parental controls, disable it.

If you need to get in your router settings do the following:

1 - Take a device connected to the same network.

2 - Type your router's gateway.

3 - Log in.

4 - Modify anything in the settings ;)

Thank you for your response, I gave your list a shot and I thought fof a second it would work, but then it timed out. In earlier replies, I gave out some error codes that might be able to help you help me better.


3 years ago

Go into the device manager and remove/uninstall the network card. Reboot and let windows rebuild the device and all the required settings that go with it. It will first find new hardware and then find a new network and ask to connect to it.

I have tried this as well as physically removing and reinstalling the card. It didn't improve the situation. Also should be noted that I can successfully connect to the internet with my neighbors WiFi. Just to make it a little more clear, I connected a laptop to the new wifi, shared that to a different router, connected to that router with my pc and had no problems with the internet. When I skip all those steps and connect to the new router via WiFi, I cannot load any websites though it clearly states I am onnected to the internet.

Check the DNS # . It should probably be set to auto. If it is not make sure it has a valid set of numbers. If the computer can't contact a DNS server then the web browsers will not work even though you are on the internet.


I've seen a few ppl do that


3 years ago

Hi, I am having similar problems with my laptop.

I find if I restart it a few times it normally re-connects and then it is fine.