Author Options:

Disk boot error? Answered

Last night, I wanted some files off my laptop drive, so I stuck it in an external enclosure and plugged it into my desktop (whilst on). I then turned off the desktop without unplugging my laptop drive and turned it on again today, forgetting to unplug it. I have USB booting enabled, so it tried to boot from the laptop drive and as I was out of the room when it was booting, it entered the recovery partition as the hardware is incompatible. I have done this before, so I just turned off my computer, unplugged the drive, and restarted.

Instead of booting from my primary internal drive, it got stuck on the post screen. It detected it, but wouldn't go any further. I then thought that it was still looking for the USB drive, so changed the boot order and removed usb boot, same problem. Removing my primary drive just returned the error "disk boot error, insert boot drive and press enter to continue", so I inserted the primary hard drive (I have it in a hot-swap bay, so it can easily be removed, although being my primary hard drive, not "hot"). After doing so, it kept returning a similar error.

I then figured that it was still looking for my laptop drive as a primary boot device, so I cleared CMOS with the jumper and after setting it up again, disabling every other bootable interface except the sata port my primary drive is connected to, and it still just gets stuck on post. I have left it about 10 mins and still get the same problem. It is also hard to enter BIOS or any of the other utilities, as it waits until after post, so I have to either remove all drives or insert the laptop drive in it's enclosure. How can I get my desktop to boot from the primary hard drive again?

Inserting the install disk is also hard, because I don't actually have a DVD drive yet, so I installed Windows 7 extended trial through a memory stick from my laptop with a disk drive. I have since deleted it off my memory stick, and my laptop is now in pieces hooked up to my monitor/keyboard/mouse instead of my desktop. It is on it's back and the hard drive bay is open in case I need it again.

My BIOS is award with additional features on a Gigabyte GA-H55M-USB3 board. Both drives are Hitachi sata-II drives, one being 3.5" and one being 2.5".



Best Answer 7 years ago

First thing to figure out, is it a hardware problem or a software problem. I would try using a different hard drive, like an old smaller drive that you know still works,something like a 40 gig IDE drive, and try installing a copy of XP on it. If that installs and boots then you have narrowed it down to one or the other.
You should not really have to flash the BIOS but keep that as another possibility if it refuses to boot correctly and use the selected drive.
Rather than letting it work on automatic for boot choices, if the hard drive appears, and it should, then try specifying to boot only from it and nothing else.

Windows 7 does not boot the same way as previous OS's. If you use a disk cloning utility to make a copy of the drive and then try to boot off it it will give you a disk error. You have to boot using the DVD and then have it repair the drive.
So you have lots of things to try, just work through them logically and isolate the problem by swapping out things like the drive. Try and get to a state where things work, then work backwards to find where its going wrong.
Another possibility is that it might be set to boot from a raid instead of a single drive. The raid settings can sometimes be confusing, but again that should not have changed on its own. Whenever you make BIOS changes, do them a few at a time and reboot in between so if something goes wrong you can backtrack and roll back to where you last had it working. It might seem like its time consuming but its a lot easier than making a dozen changes, finding something doesn't work and then having to try and undo everything to figure out what went wrong.

I don't actually have any blank drives, but I would imagine it would work. Its just that my primary drive is seen as unbootable even though it obviously is. It will boot from any other device as normal, except when my main drive is in it gets stuck. The primary drive is the one I have been using on my desktop and it worked fine until I booted it with my laptop boot drive in an enclosure. I have made the mistake before, but removed it and restarted it. This time, I left the room, and it automatically entered some repair utility because the hardware obviously isn't the same. I'm guessing this may have changed something to cause it to not boot from my main drive.

When windows starts up it checks all the drives identified by the BIOS and looks for the check disk switch. If that has been set then the OS offers to run the check kisk utility. There is a screen that say's if you don't hit a key it will execute the check disk and gives a countdown. It does this even for USB drives. So apparently from what I am understanding the OS on the USB drive which it booted from ran a checkdisk on the main drive. Depending on the file system it has probably altered the settings. It may not be considered to be a primary drive with booting capability. When the BIOS scans the drives it determines if a drive is bootable depending on what the OS has labeled it. Its just like some CD's are bootable but most are not. They have to be made bootable. You can fix this in a number of ways, depending on what you have available to you.
The easiest way is if you have a utility available, like Acronis Disk utilities. If you boot from it it will analyze the drive and allow you to set it once again as a primary boot drive. Its just point and click simple. If you don't have that then you can boot from the Windows CD and go into the recovery counsel. Windows 7 should notice he problem with the drive and repair it for you.
Another way, one which I prefer, is to put the drive in another system, A USB adapter is great here, and use the computer management , disk and storage management services and through that change the designation of the drive to a bootable drive with a primary partition. I would run a disk check also just to be sure and to turn off the disk check switch.
Once the drive has been labeled as a primary bootable drive the BIOS will accept it as a boot drive.

Ahh yes, that was the problem. I have it sorted now, I put the disk in another desktop, and using the windows partition manager, I simply changed the "active" partition. I seem to have another 100mb partition I don't remember creating which was set to active. I just swapped this back to the rest of the drive and it works fine again (I'm using it now). I decided to leave the mystery partition in place though, in case it contains anything important. Thanks for the help!

I tried using my usb enclosure, and it looks like it doesn't provide enough power. It doesn't have an external power supply, it just runs on USB power. My drive is detected, but won't spin up (and that isn't the problem, I can hear is spin up and can even access it on my desktop). All my other enclosures/adapters are IDE. About the Acronis Disk utility, is it free (or cheap)? And can it be run on a memory stick? (no dvd drive). It also needs to be able to detect new drives being plugged in,a s so far,t he only way to bypass the bios post screen is to disconnect the drive and connect it after it boots on other media,

Thanks, I'm pretty certain that is the problem here. As I said to the other guy, I made a bootable usb with the windows install disk (no dvd drive yet), but it only works if I first disconnect the main drive, and so far, it has only picked it up again 1/4 times. I will try the usb enclosure on my laptop though, it si for 2.5" disks, but I can probably remove the actual enclosure and the electronics should work with the larger drive.

Let's see if I understand this:
You connected a USB drive to your desktop machine, which had it higher in the boot order than the drive it should be booting from.
The desktop attempted to boot via USB but failed so you hard-killed it by cutting the power.

You cleared CMOS (why? surely back to defaults does nothing which you couldn't do yourself like changing the boot order?)
You disabled (physically?) all the bootable interfaces that weren't a problem.

>if it don't POST properly, what happens if you remove all the things connected to the board that aren't essential to POST?
>Try that first, consider that your OS (primary) disk may be damaged.


No, I have USB boot before my primary hard disk as I don't have a dvd drive, so install all my software via usb from my laptop with a disk drive. I left the drive in accidently and it tried to boot from it, and as I was out of the room, it appears to have entered a recovery utility and changed my primary hard drive to become unbootable.

I didn't cut the power on it, I would never do so whilst a hard disk is in use. I simply restarted it from the setup utility and removed it once powered down. I cleared CMOS as I figured it may either be corrupted or store some hidden information like the bootable disk.

I disabled all bootable interfaces through bios, mainly because I have been meaning to do so anyway to speed up startup as it takes a few seconds checking each sata port, but also to make sure it isn't trying to boot from any other drive.

I think the problem is definitely the drive, but not physically as I take good care of it and it is a high quality hitachi drive, only a few months old. My old drive, which was an "excel stor", ripped from a 4 year old external hard drive which I knew was on it's way out and I just wanted to test my new desktop, had its ventilation hole blocked by a sticker, and would cause system lag, unexpected shutdowns, reach temperatures of about 50 degrees, and make horrible clicking sounds before it died. This drive is perfectly healthy, it's just the disk repair utility automatically initiated by no input on my laptop drive in an enclosure seems to have overwritten my main drive's ability to be bootable. I have just realised another solution actually, I have another desktop I can stick it in and hopefully make it bootable again.

Interesting... it is possible that your MBR is corrupt... you would need to be able to access a system re-install disc to fix it. One thing you can do if you don't have anything like that is to just use Ubuntu. It's a free system, but it works really good.

That's the only thing I can suggest without seeing the computer.

Ok, I'll dig out my install disk and make a bootable usb. I ahve also got ubuntu and fedora on a memory stick, not much help really as I can't fix the problem. I might as well just continue using my laptop.

I doubt its a corruption, one of the main reasons I bought this board was actually because it has two bios chips and a hardware reset jumper to overwrite the main bios in the event of a corruption.

It only seems to want to boot on USB, even when disabled. If I select the main drive before usb, it waits for a bootable usb. It seems that it doesn't think ym main drive is bootable, but I don't know where it would store this information. I already cleared bios, the ram is volatile, and I have no other storage devices connected.

You could also flash the BIOS... look on the manufacture website to find out how to do that. Sorry I forgot to mention that earlier. If it is a problem in the BIOS, that would (in theory) fix it.

Thats another thing I tried. My bios is also equipped with a flash from hard disk utility. I flashed it with an image I made about a month ago, same problem. I have just made another bootable usb stck, I'll try that now.

It is also possible that your hard drive has been corrupted... you might have to get a new one.

I doubt that, it is only a few months old as it is, and it is a hitachi deskstar, one of the best in my opinion. My first drive was a 3 year old "excel stor" which died, then I ordered a hitachi but got a seagate so sent it back, then got an actual hitachi drive. SMART utility says the disk is fine, I honestly thing it's just been changed from being the primary boot drive. I'll try Vyger's suggestion.

I tried the system install disk via USB, it still gets stuck on post when it detects my primary drive, even when boot priority is given to the usb. I removed the drive, booted the recovery software, then inserted my primary drive, my windows installation is detected and it simply said "there is a problem with your boot option", and clicking "change and restart" didn't do anything.