Author Options:

Dual-Channel RAM? Answered

I have a Gigabyte GA-H55M-USB3 Motherboard and an i5-760 CPU. I have been using 4x1GB DDR3-10600 modules, and then recently bought 2x4GB DDR3-10600 modules hoping to get 10GB, however, I can't seem to get it to work. All the modules are in working order and work individually. I currently just have a single 4GB module in. If I insert more, I either get a constant bios speaker tone indicating RAM error, or it will post successfully, but Windows will bluescreen. I have looked in the booklet and it is unclear as to how I should install the modules, but I thought I had to install them in matched pairs corresponding to the coloured slots on the motherboard. I have tried the 4GB modules in the white slots and the 1GB modules in the blue slots, but it won't post. Putting the two 4GB modules in a white and blue slot will post fine, but BSOD on startup. Any idea how I can get this configuration to work with my board? My CPU and board both support dual-channel DDR3 memory, so I can't see the problem here.



Best Answer 6 years ago

You need to check for a BIOS update. Often they make updates to accommodate newer hardware. While your on the manufacturers web site look into the memory specks and any new instructions they may have put up. If you don't find the answer there then try posting the question. Often they have FAQ and tech support. The designers will know how to address your problem, especially for a relatively new board.

I have just updated the BIOS, one of the listed updates was additional RAM support, however it still doesn't work. There is a list of tested and verified RAM on the board manufacturer's website, but mine isn't listed, then again, neither were my old modules. They are all the same speed and interface, just the old modules (1GB) are Hynix, and the new ones are Ramos. It still doesn't make sense though, as a single module works on it's own, but in conjunction with the other 4GB module or any of the 1GB modules, it won't boot. Anything else seems to just BSOD on startup.

Well, the next step in diagnostics would be to try the components in a different motherboard. If you have access to a friends, (or anyone for that matter) that would let you swap out the ram to test it then that is what to do next. If the different chip types are not compatible then it won't work on another board either. We had a board that we used to call the whore because we stuck so many different components in it to try out until one day it finally met its match and burned out. Swapping is a way of diagnostic testing, just be aware that there is always a chance of something going wrong and stuff can burn out. Use anti static procedures and be careful. And don't ever tell anyone that its totally safe, always let them know that there is a small risk.

As far as I could find on that motherboard, (It was hard for me to find... interestingly enough...) you have a 32 bit system. You can only address 4 gb on a 32 bit system. (I got around that limitation once, but it was awhile ago, and I don't remember how I did it.)

I have a 64-bit system. My CPU is an i5-760, and I am running Win7 x64. The limitation is only in place for windows however, It shouldn't cause my whole system to fail by having too much RAM. I have built 32-bit desktops and given them more than 4GB RAM before, and just turbocached the excess RAM. I think I have found out the problem now, It's probably the modules (either voltage or chips. The manufacturer is "RAmos".

In that case it does sound like the modules.

As a jumping off point I would go into bios and reset your cmos(or just pull out the battery for a minute), do a little research on your 4g modules and determine if the voltage settings for the blue channels in your BIOS are high enough to satisfy the higher power demands from a 4g dram.It sounds funny but install your graphics card in the other pci-e slot( one of them is PCI-E 16x and the other is at 1X, I cant tell one from the other.) Out of curiosity what OS are you running?,is it 32 or 64 bit?,the reason I ask of course is 32 bit will only support 4Gb max ram.Just a few ideas on what might be the root of your problem.
Good Luck


I will try checking the voltages, but I don't see what the graphics card has to do with it. It already works fine, an the other PCI-e slot is and x16 running at x4, I have a wireless card in there at the moment. I am running Win 7 x64, but even if it was x86, the RAM models still show up, it just limits the useable to 4GB. When I install both 4GB modules, it is detected fine by BIOS, but windows BSODs on startup, and when used with any of my 1GB modules, BIOS isn't happy. So far, it will only work in the old configuration or with one single new 4GB module.

Your right, it does sound funny and on the surface appears pointless,but having said that all I can say is I had a positive result while struggling with a similar problem.
good luck