80Views11Replies

Author Options:

E-Book Problems Answered

OK...SO i just got a PRO membership, and i am trying to download some E-Books but it just keeps sending me to an overview page that shows the different formats i can get the E-Book...why cant i dowload them? PLEASE HELP!!!?

Tags:ebooks

Discussions

Can you please reply here and show me a screenshot of what you're seeing?

Thank you!

I go to download the e-book and the first screen print is where i click first, then i run into the second screen print...the third and fourth SP's is the second, its just scrolled down.

Screenprint 1.1.pngScreenprint1.pngScreenprint2.pngScreenprint3.png

Awesome! I think I know the problem. In your second image the buttons are missing.  It looks like the top of the gold buttons are there, but for some reason, the bottom 7/8's of the buttons have decided to disappear on you.  Look at the image I've attached, the gold buttons on your screen should be in the exact same order.  Please try clicking them and letting me know if you have any troubles.


ebook.png

hahaha...ok...so now i can lol. thanks! is there anyway to make the buttons show up better?

Explorer 9. I have tried with Firefox (latest edition), and Chrome. they are all doing the same thing.

Weird. What version of Windows are you using? (you might try clearing you cache...but if you opened the page in Firefox and Chrome for the first time...it shouldn't be doing it in either one of those.

hmmm...theres a bunch of wierd crap going on with all three browsers...i restarted my computer, and now Firefox & Chrome work, but Explorer9 still is doing the same crap...

I'm running Windows 7 Ultimate. I will try clearing my cache, but i dont think its gonna help...worth a try though. ill update you when im done.

OK...SO...i cleared out my Cache and its still doing the same thing as illustrated in the second picture i posted earlier.

What version of windows are you running (please be as exact as possible). You can left click the start menu, right click on my computer and go to properties (I'm pretty sure), and get the details from there.