Author Options:

Eagle keeps crashing in Ubuntu, what to do? Answered

Ok, I'm running ubuntu 9.10 on my netbook/laptop, and whenever i go to try and open a file(thats been imported from my desktop, a vista), it gives me an error message that says

Invalid data in autorouter block of file
(filename & location here)

Continue with default autorouter settings?

Y => pulls up file
I then go to edit, (move tool), and I click on a part and all of eagle crashes.
I can add parts and it wont crash.
It does this even on newly created files.

I bet that this is an issue with the version, as there is a newer version out, but I dont understand these things, I am trying to though.



8 years ago

I'm running Ubuntu 9.10 and Eagle kept crashing while doing various things.  I tried the fixes found on the net and it still crashed.  It turned out all I needed to do is change the dirctories in the contro panel options.  For instance My libraries are now under "eagle/lbr"  The rest are same format.  Then it will ask if you want to create these directories.  Yes.  Move your projects and stuff there.   You can also download more library files and add them to the "eagle/lbr" folder.  Before I did not have permissions for the eagle files.  Worked for me.  Good luck



8 years ago

Yeah, its a bug.  There are many reports about it in launchpad but I didn't see any fixes yet.

You may want to try running Update Manager and make sure you have the latest updates and then go to this page at Debian. It lists some users' workarounds.


There may be something there that will work for you.


8 years ago

Sounds like a specific bug - try upgrading to the newest version...