Author Options:

Fixing broken power supply? Answered

Have been using my FolgerTech Prusa i3 printer for a few weeks now, and was doing some cable management when, "Pop!" goes the power supply.

I had the mains power unplugged from the power supply, and didn't connect or disconnect any other wires. I was working on hiding some endstop cables (That i will probably just go ahead and shorten later) and when i was satisfied with the job, i went ahead and plugged the printer back in. Pop! Immediately unplugged the printer to prevent further harm. Sounded as if a .22 went off in my room. No burning or acidic smell, just a pop. From the sound of it, i assumed it had to be the power supply. So i examined everything, the ramps boards, the arduino, etc. Nothing. Everything looks fine. I remove the power supply from the printer, and plug it back in. LED light stays off, no more sounds. Using my multimeter, i checked the output voltage, and sure enough, it's dead.

So i go ahead and crack the power supply open, and begin examining the components.
Absolutely nothing.
All the caps look fine, no charred marks, no scorches or burns. No component looks any different than its functional counterpart. Beyond the cheap chinese soldering job, the board looks fine.
So i take the board off of the metal plate to examine the backside. Solder splatter everywhere, but no shorts or anything (It worked for about 3 weeks.). I do, however, notice that there is a nice dry joint on one of the large capacitors. Thinking that might be the problem, i go ahead and fix the joint by reflowing the solder. Put it back in its case, plug it in, nothing.

Anyone have any idea what may have happened?
I am a student who currently doesn't have 30$ to fork out for another power supply, but do have an arsenal of spare electronic components. (Will eventually buy another power supply, but currently don't have money to set aside for it.)

What should i look for? What blew up? Why does it not work anymore?
If any more info is needed, let me know!


I see the capacitor joint you mentioned I also see a bubble on the side of the 39 ohm resistor beside the terminal bar (Pic 2) Nice pics by the way. wherever the falt is it is not obvious so the only thing I can suggest start at AC in checking with a meter and trace until you do not get power. Do you need suggested test points?

So I followed the trace, and it was all good until I got the the Bridge Rectifier. I did a test on the rectifier, and according to my multimeter, it checks out. However, after the AC goes into it, on the output side, I get ~320v DC... And when I try measure it in AC, I get 0v. Is this a problem? There are caps on that side of the circuit, so could that be it? After the Bridge Rectifier, I don't know which traces to follow.. (Begins branching out, going to the IC, a whole bunch of diodes and resistors, one of the small transformers, etc.)

If you have 220 mains 320 should be about right at the rectifier.

For a short cut in the yellow box line voltage AC and DC out the red boxes beside the yellow box.

If you don’t get AC in the yellow box the trouble is between the rectifier and the mains.

If you don’t get DC in the red boxes the trouble is in the rectifier.

Check the voltage switch, make sure it is working. If I am reading your picks right there should be a voltage between the brown arrows and no or vary little voltage between the yellow arrows.

Next check the light blue box at the light blue box, pink wire positive, black wire negative, next post not sure bottom post positive feedback to drive the mosfets, if you don’t get feedback voltages the mosfets won’t work.

Next check the dark blue box if you don’t get voltages there it is the transformer between the light blue box and the dark blue box.

Next check the green box you should get voltages on 5 of the six pins second from the bottom is not important doesn’t connect to anything.

trouble shoot1.jpg

i know it is to late to tell you that is very awesome enplane cause i have the same circle but diff rant error i have at the end of circle 5.0 DC V it should be 12 DC V

i check the light blue and i find voltage almost 150 v

but i don`t know what exactly i should do in the dark blue box i can`t have the voltage in this box or may be i can`t know the Positive or vegetative plz help as soon as you read my problem

First off, thanks for the in detail reply!

Uh, I don't have 220v mains... 120v Is what I run on o_o

That’s why I found it confusing.

I get 120v AC in the yellow box, so the fuse and the small transformer looking thing are functional.

In the Red Boxes that are on the rectifier, I get 333.3VDC

Between the brown arrows, I get 120v AC. (And 9-10VDC... ?) There is the large brown polyster cap on the other side of the board on one of the brown arrows, the other is the 120v in.

Nothing/ .008v between yellow arrows (This is the switch.)

I don't get anything from Pink and ground/black... So I assume my mosfet(s) are fried?

Went ahead and checked out the lime green area... Some pin combos outputed ~1.3-1.5VDC... Don't think that is anything though.

So I guess I'll look up a method of testing Mosfets... Strange I don't see any visible damage on them (Though this means nothing.) Am still trying to figure out how it made such a loud noise.

The high voltages on the DC side of the rectifier may be your meter misinterpreting current for voltage with digital meters it can give you weird readings. Your meter is under loaded. See my Instructable Circuit Testing for a more thorough explanation.


It could be your mosfets or it could be your feedback to drive your mosfets.

Between the light blue box and the dark blue box is a transformer with a feedback on the bottom pin in the light blue box. That is the feedback for your mosfets and it may not be working.

The only way to know if it is the mosfets or the feedback, take a wire or a set of jumpers and connect the bottom terminal in the blue box and connect it to the terminal just above the light blue box.

If the mosfets are Ok you should get a voltage at the pink and black.

If you do get a voltage at the pink and black the fault is in the feedback and the rest is too hard to do over the net.

I unsoldered the mosfets (Looking at the spreadsheets, they are actually plain old NPN Transistors... Their model numbers are D13009K... Good luck finding any spreadsheets in english.) and did some transistor tests on them. I have been lead to believe one/both of them are dead, as both give different readings, and according to the "tests" I put them through, they seem to be defective.

Tried looking for legit source to order them from (mouser, digikey, etc.) and couldn't come across anything. I did come across this: http://forums.reprap.org/read.php?1,238385,238543

But that's about it. Any recommendations on what alternative I should order? Possibly something more beefed up/overkill? Seeing as they aren't extremely expensive, wouldn't hurt to order a few and try, right?

I got one in both English and Manderan from here:


It was marked 3DD13009K.

This is a good supplier:


Scroll down click on transistors.

Next click on transistor type.

Next in available filters click on the parameters you are looking for.

Beside "Available Filters" you will see "625 Matches" or something like that.

Beside "625 Matches" you will see "625 remaining"

If remaining is 0 change the parameters until you get 1 or more.

The first transformer that gets electricity has 5 inputs, 3 outputs. No matter which combo of output pins i tried getting a voltage off of, i always got 0v. On the input side, i have "~320-340v DC" going in (Still can't figure that out...) and nothing coming out. There is, however, an array of diodes and resistors right before the transformer, so that may also be interfering.

If i am looking at this board correctly, it appears the diodes are also forming some sort of AC to DC rectifier of somesorts. Why is this needed if there is already one on it?

Its actually suppose to be a 390 ohm resistor (Orange White Brown Gold, unless if I did my conversion wrong) But I end up getting 220 ohm with my multimeter....

Not a bad idea. Will do that this weekend. Would leaving one lead on one of the 120v inputs and the other moving down the traces work, then repeat with the other 120v line?

It looked black in the pic so that would be 390 ohm.

Remember to switch to the secondary when you reach the step down transformer.

Cheap and nasty power supply with (by the looks of it) no real protection at all.
I assume your mosfets have blown, or triacs/power darligtons - what ever they used in this thing.
Can't tell by the pics, but the two black thingies next to transformer and toroid.

If i am looking at the right piece, its a Bridge Rectifier according to spec sheets. (KBU808)

How would I figure out if this is dead?

How would I figure out if the mosfets are dead?

The thing is, the extremely loud popping sound would have made me think something had to blow open, crack, or at least blister (Similar to frying an IC). But from my hours worth of observation, I haven't found anything of the sort.

Can a component really make the sound of a .22 blast without externally being damaged??

A bridge rectifier is just 4 diodes, so it can be tested the same way.
For the mosfet you can check with a multimeter.
Plenty of info on the net if you bother to ask my friend Google, for example Youtube.
If a mosfet blows it can be anything from a silent death to a violent explosion ripping the thing into pieces.
But if the IC that is regulating all is damaged too you might have a problem as these chenises dudes usually fail to provide any info on them or use programmed microchips.

I took a look at the Rectifier... According to the diode test function on my multimeter, the Rectifier Checks out. However, when I plug the power supply in, if I check the output of the rectifier in DC, I get ~320v... And in AC I get nothing. What's this suppose to mean??

I'd be looking at the bridge rectifier first up. It's the black square unit with the chamfered edge. They can make a nice pop when they go. If that's OK look at the voltage regulators (attached to the very poor heat sink) They can make a decent bang when they blow. The heat sink does look rather distorted in your pic. That solder could simply be left when it was built, I can't imagine any component leaving that behind after self destructing. I see the bridge rectifier looks as if it should have a heatsink attached according to the PCB overlay. Perhaps that's for the 45 amp model. Stu

The heat sinks on the mosfets were removed for the image. Normally, there is a block of aluminum between them and the casing, which is used as the heat distributor.

The Bridge Rectifier didn't have a heatsink.

Thing is, power supply wasn't run for a while, so it wasn't overheating issues. I successfully ran the printer for a week straight with stock heat sinks/lack of heat sinks.

Solder is definitely from when it was built.

Will look into those components hopefully tomorrow, thanks!


2 years ago

I'd have replaced that cap first, also. On a few of the other solder joints, the wires don't look well wetted...that might be a place to look.

I'd check that varistor (black thing labeled RTL), it's designed to fail and sacrifice itself like the fuse (which I'm sure you already checked).

Edit, Googled how to test Varistors, will have to unsolder it to get accurate test. Will report in a few ways. Same goes for caps

I fixed the solder joint on the Cap... The thing is, it worked for a few weeks, and then stopped. None of the internal components were moved between those two points, so I wouldn't think that is the issue. However, if I get it working (Or just to see if it is the issue) I will probably run over each joint to make sure its wetted correctly.

According to my multimeter, RTL is a closed circuit, so I doubt its that. The fuse was the first thing I checked, also closed and functional.

Those switch mode power supply can be tricky to fix, have you thought of using and old desktop power supply? You can pick a whole desktop for free if you ask around, try the IT people at your school.

i have a whole bunch of spare atx power supplies. Issue is, none of them are 30 amps... Which could cause a few problems...

Why would it cause problems?
In fact I would prefer it:
One ATX for the printer electronics, one just for the heatbed.
That's why there are two power connections on the RAMPS board.
IMHO it is much better to have the massive power consumption from the bed seperated from the rest.

Mk... Was also thinking of that. However, my heatbed draws around 20 amps according to the spec sheet/reprap wiki, and the hotend+steppers well over 10a. So unless if I go and purchase a few newer ATX power supplies, if I am correct, I am pretty much out of luck here.

Dumb question: Did you check the fuse (or 'FUSH' as it is labelled on the PCB)?

From the pictures (which are better than on some of the Instructables I've seen lately, btw.) it's difficult to tell if it is blown or not.

Anyway, if you can measure the caps. At least resolder them, those solder joints are not good.

And thanks about the pictures. It's all in good lighting :)

These were taken with my smartphone, held by my hand. Evidence a DSLR isn't needed for decent pictures.

Multimeter states fuse is good. I tried resoldering the caps, though should have used more flux... (The solder they used is very low quality...) will try again.