Author Options:

How do I comment on someones instructable? Answered

How do I comment on someone's instructable? Everytime I type something in the comment box and hit post a thing pops up and says "please type the two words as seen on image". But there is no image or words??? It won't let me post any comments on anybody's pages or projects. It's very frustrating.


Please see this forum topic for all issues relating to Captcha not working.

This thread is now locked.


4 years ago

I want to  comment on this page : https://www.instructables.com/id/Arduino-on-all-sorts-of-Atmels/step3/Program-MCUs-what-dont-have-bootloaders/

but it show me this :  please type two word as seen on image

but there is no image and no captcha

I checked my cookies and it was ok

i'm using win7 , XP and firefox  , chrome

(wtf , I even can't upload my desktop image in this post )

Testing this.

Still I have problem in posting comments. I am using Firefox 25 on Windows 8. I havent installed adBlock.

If we have a free membership, are we unable to post in the Community section? I can make a comment on someone's instructable but not in the community board. Thanks! Oh, it simply asks me to sign in despite my being signed in already. Also, once I got as far as making the comment (it didn't bang me out at that point), but when I hit post it asked me to sign in again. I'm using Firefox on a regular desktop computer.

Did you block cookies (on purpose or by accident)? In Firefox, you should be able to go to Preferences -> Privacy, then look at the list of sites which have attempted to use cookies. If you modify that list to allow "www.instructables.com" or/and "instructables.com" to use cookies, then it will remember that you're logged in.

If you have your defaults set up to reject cookies, you should not change that :-) You definitely don't want all the third-party advertisers getting in your business.

Well, I only have Tools/Options/Privacy... which btw, it didn't have a way to get into 'cookies.' I could delete all my cookies, but it didn't have an option for an exception. I did put Instructables in my exceptions for pop-up windows. At any rate, since I tried last night, I've turned off my computer and restarted it... and for whatever reason, it is working today. Thanks for taking the time to respond, kelseymh. (Now I need to find out where I am managing the cookies... I really couldn't find it under privacy on my version of Firefox).

Ah, I found it. I needed to select 'Firefox will:' then toggle down to 'Use custom settings.' At that point a whole new set of options appear. At this point, I am allowing all cookies. I should update that. Thanks!

Oops! I'm using Firefox on my Mac; I didn't expect the configurations to be that different. Sorry about that!

In any event, I strongly encourage you to limit cookies. The way I have my Firefox set up, it prompts me each time a site asks for a cookie (and tells me the site name and the cookie contents). Once I say 'no' (or 'Deny') it remembers that for all other cookies from that site.

(Staff, see also recent comments here: https://www.instructables.com/community/Captchas/ )

Still can't reply. Getting the two word message.

We rolled out a release last week that should have fixed this. Please make sure you have browser add-ons (like Ad-Block), then clear your browser cache, and log back into the site and try again. Did that work?

I'm still not able to post replies on some posts. For example on this page: https://www.instructables.com/id/KNEX-Modified-Arm-Lift/ I get the error about trying to fill in the reCaptcha. But I don't have any problem replying to this post. I've tried this using Chrome and Safari on Mac.

I can see a comment you left on the Instructable you reference with a time stamp of Dec 18, 2012. 5:05 PM.

If you're having trouble leaving comments, please make sure you do not have any script-blocking add ons (like Ad Block plus) running on your browser. Then clear your browser's cache and sign in again.


Have you made a new ID, because according to your profile, that's the only comment you have ever made here...?

So you're able to see the two words? What happens when you type them in as shown?

mikeasaurus's advice worked for me. I was having the same problem in Chrome and Firefox. What I did was:

1) Leave a comment at the top where the Captcha is located.
2) After leaving that comment (without refreshing the page), I clicked "Reply" on the comment I wanted to reply to, and a Captcha appeared beneath the "Reply" box.
3) I re-entered my comment in the reply box, filled out the Captcha, and clicked "Post."
4) After my reply was posted, I went back and deleted the comment I'd left in step 1.

Hope this helps someone!

Note: I'm using Chrome (latest version--26.0.1410.64 m) and Firefox 18.0.1. When I tried this solution, I was using Chrome... but I'm assuming it works the same in FF. Also, I have Adblock Plus installed on both browsers, but I disabled it for this (not sure if that matters, but felt I should mention it).

All that said--and even though I managed to get it to work--this is still an issue that needs resolving. It should be easy to reply to posts! :)

Thank you for letting us know. A screen shot would help, along with your browser and OS. Please make sure you have no script blocking on your browser as this affects how the site loads.

hehehe just wanted to say your "screenshot" made me lol. :)

We rolled out a small update last night that should have fixed that. Is there still a problem with the recaptcha? (that's the thing that's asking you for the two words)

Thanks, I can post now. Doesn't doesn't require me to enter the captcha. not sure if it was supposed to?

That protocol is dropped after authenticating the user as human

I have the same issue and I have tried with Firefox, Chrome and Internet Explorer.

mikeasaurus says: May 16, 2013. 6:42 PMReply
Try just leaving a comment next to the Captcha (instead of replying to a comment), this will solve the Captcha and remove it from appearing again.
After posting your first comment on a project, refresh the page and then try leaving a reply.

I don't see the captcha words either. argh.

Um, OK. I just found that there's a comment box at the top of all the other comments and one at the bottom. The one at the top has the captcha but the one at the bottom doesn't. Why the hell are there two comment boxes?

mikeasaurus says: May 16, 2013. 6:42 PMReply
Try just leaving a comment next to the Captcha (instead of replying to a comment), this will solve the Captcha and remove it from appearing again.
After posting your first comment on a project, refresh the page and then try leaving a reply.

Could you post a screenshot of the two boxes?

So there is a comment box in the middle of the page between the actual article and the actual comments. This box had the captcha stuff there.

If I then scroll all the way to the bottom of the page, there's a link that says Add Comment. If I click that link, a new comment box opens that does NOT have the captcha stuff.


Thanks for posting all this.

You should only have to complete the Captcha once to authenticate you are human and not an evil spam-bot. What happens if you complete the Captcha words in the top comment, refresh the page and then try leaving a reply comment at the bottom?

Yes, that does now work. However, when I tried to post my first comment yesterday, I couldn't figure out why it wouldn't let me post at all.

I do use Adblock but I disabled it for this website, cleared my cache, etc to make sure it wasn't causing the problem

Can you please tell me what browser and OS you are using? And, do you have any browser add-ons (like AdBlock or Greasemonkey) that might be preventing the page from loading correctly?

Thanks for posting that. I think it will help the development team.

Try just leaving a comment next to the Captcha (instead of replying to a comment), this will solve the Captcha and remove it from appearing again.
After posting your first comment on a project, refresh the page and then try leaving a reply.


5 years ago

im having the same problem as these people had, i cleared my cashe and history and restarted my browser but it still didnt help. i still get the message asking to type the words . i can type post new messages and send it but i cant reply to others peoples comments. like how Kelsymh replied to mwilson50s comment.

Same problem, the Captcha is not loading.

I have the same problem on Chrome and Firefox


5 years ago

the same to me

So the "captcha" is missing?

I'll pass on a bug report.

(Can you add a note about what software you are using, and take a screen-shot of the message?)

Yes there was no 'captcha' just a box that said "please type the 2 words...". I tried it in IE and Firefox with the same results. I'll try and figure out how to take a screenshot for . The captcha showed up to create this forum topic but not for posting comments on people profiles?

The 'recaptchaContainer' div is using an id. There is always one of these on the page, and when you click reply, another one is created, which does not get filled. This is just wrong.

Having the same issues in WIn7 with both latest Firefox and Chrome. The captcha container div is simply empty.

testing...is this thing on?