Author Options:

I HAVE NEVER been able to start a "New Paragraph" on the notes that are placed onto My Photo's...ARRRG ! Answered

Hi Everyone !

I have not found this bug in this section or anywhere so dont know if its just me now....

The Problem:

I have published 5 instructables and in EVERYONE that i have made, i have always made step-by-step photo-instructables as thats how i would prefer to learn something, best of both worlds, reading a little whilst looking at pictures !!!

Now, i make mostly ALL my notes and explanations directly onto my pictures by drawing a Box around the section i am describing or detailing the 'how-to' on, then i start typing away into the text box. BUT!!! when i want to start a new paragraph within the text box that i'm writing in, i have USED ALL METHODS DESCRIBED on THIS wiki formatting page for adding OR starting a NEW PARAGRAPH even tried doing the "FORCE" new paragraph code and NOTHING WORKS..........

Ive just finished my 5th instructable and ive got so infuriated that my blood-FLASH-BOILS WHILST STILL IN THE VEINS because i have to revisit every single photo that i have EVER published here on instructables.com so i can ADD paragraphs to the HUNDREDS of photo-instructions i have PAINSTAKINGLY written for everyone to follow and separate the extremely LONG one-paragraph "BLOCKS" of text so that (i) - I CAN READ IT EASILY to correct any flaws but more importantly (ii) ITS AN EASIER "Read" for anyone and everyone who visits the instructable for the help, how-to or advice i have taken, sometimes months, to compile...

 SO i am NOT publishing another instructable UNTIL i have found a solution to this because theres nothing worse than having to read a darn-script without any paragraph-breaks..... Like i have separated all these paragraphs here in these details of my moaning of what bug is bugging the hell outta me (no pun intended, lol !)

My browser is Opera, it WAS Firefox RELIGIOUSLY for YEARS but the WHOLE of last YEAR it kept SELF-TERMINATING and closing down by itself when even google.com or google.co.uk was visited so i'll never use it again, chrome is too simple for me and i used to use opera in its early years and kept an eye on it over the years, not switching browsers again as i like the functionality of it... here are my specs for Opera:

About Opera
Version information   11.61
Build                              1250
Platform                        Win32
System                          Windows 7
XHTML+Voice               Plug-in not loaded
Browser identification:

Opera/9.80 (Windows NT 6.1; U; Edition United Kingdom Local; en) Presto/2.10.229 Version/11.61

My PC 1:
MOBO: Intel® Workstation Board S5520SC
RAM: 48 GB DDR3 1333Mhz (NO Typo here, Yes, 48 GB)
CPU: 2 x ZEON X5560
Graphics 2 x 1GB Asus 9800GT
4 x OCZ Vertex SSD (RAID-0)
Win 7 Ultimate

My PC 2:
Mobo: Zotac GeForce 9300
RAM: 8GB DDR3 1333Mhz
CPU: Intel Q6600
Graphics@ Built-in MOBO
2 x OCZ Vertex SSD
Win 7 Pro

If you check out any of my instructables, from offtherails2010, EVERY SINGLE text-box on EVERY SINGLE photo has errors within them where you can plainly see where an automatic ""LINE-BREAK"" or ""NEW PARAGRAPH"" should have been started by half finished code like this: (without the quotes):

"<br/>"  or "<br/><br/>"

and ive tried everything to try to FORCE it to recognize that there is A NEW PARAGRAPH in the text but i have tried again and again and again THIS ENTIRE YEAR, goolged by brains out and now im just so fed up with it that i wont publish another instructable until i get this fixed because the more i publish, the more work i will HAVE-TO do going back re-visiting the entire collection of hundreds of pictures ive uploaded  that i have added a bit of a speech-to, to separate the paragraphs in EACH PHOTO.

The pictures shown as examples here, the 1st picture i have circled in RED where a NEW PARAGRAPH should had-started and the second picture i just Highlighted the error broken code and then circled it in RED.

For Example, i only pressed enter twice to start THIS NEW PARAGRAPH.


But on my pictures it annoyingly DOESN'T start new paragraphs and i have tried manually typing in the code as described on the trac.edgewalll wiki and then clicking the 'save' link on the photo's but still nothing...

PLEASE please please can someone help me find what i may have overlooked... Probably something simple and no, i wont feel embarrassed if it was something plainly obvious as it will teach me to be more observant in the area i am lacking in !!!!

And thank you in advance for the help & advice


I guess that's why there are step by step instructables instead of the photo with multiple photos instructables so that you can have the text always available and you use the image notes to refer to the properly formatted main text. Image notes have always been wonky and can disappear or get their positions moved depending on the bug-du-jour. You should really do a full step-by-step with page breaks.

Yup, your absolutely right !

From now on i'll be writing up the instructions in the Main "TEXT" sections of when i make more instructables because what i have also noticed was that INTERNET EXPLORER DOES NOT EVEN SHOW ANY OF MY TEXT that has been written on my photos !!!!!!!!

So what on earth were people thinking when the saw my instructables WITHOUT ANY INSTRUCTIONS ?????????????????

As that what i thought the whole "POINT" of making a PHOTO-STEP-BY-STEP instructable was all about --- write the instructions ON the photo's (which "to be fair" i think IS a better way IF one is to create a photo-step-by-step tutorial, then thats what it should be as it says on the tin, so-to-speak !!!!)

Although i may be a Jedi-Master in my own way in the Fine-Art of "Bodging", lol,
But like i mentioned below, i had not been studying instructables.com as closely as you Well-Seasoned Guru's of this website and knew not of the many variations of ailments until i looked for whats just a Minor flaw of my annoyance compared to some of the more serious glitches like not being able to Give/Receive Feedback Credit to those who deserve it and so on...

But alas, i will go back into all my past exploits here and write up everything into the 'Main' text sections, of all the instructions ive given to do whatever ive instructed & constructed !!!

Then i will continue to create more !!!! But like i said, its only the new paragraph thing thats failing with me, but the IE problem of not even SHOWING any of the texts scrawled on the pics has me bit miffed so a full write-up is the best way forwards for me her-on-in !

Anyhoo many thanks for the input, as i still have my 'L' plates on at instructables - i still have a lot to learn !!!!

Also added my IE version Pic to the above 2 pics for possible reference, as ive never ever held IE in any high regard at all, it has never been used nor updated since me having win 7 pro (since it was releaseed in the uk.....) so i never have updated it, just in case the latest version HAS fixed that problem ?!!?

Photo instructables are more for showing off stuff you've already made, or things that require very little instruction beyond the image itself.

They're most suitable (IMO) for showing off artwork you have made (including photography), or for new members to show off things they made before they found the site and hadn't taken any step-by-step photos.

Hi Kiteman!

Yaa, its all a good learning experience, plus i'd only just recently got hole of a decent 'ish digital camera, so the last 10 have been without such a tech and ive been taking snaps of almost everything ive made (kid with a new toy, lol) !!

Still, jus gonna take a break from all this madness for a few days as spent alotta time on my last 'ible and now some people are saying they cant rate it !!!

So am gonna wash my hands with these glitches for a week or so then start banging me head against it again !!!

Ha, when I switched to digital (around 2003ish), I was taking 300+ shots on a day out.

Forget about the ratings glitch - ratings have never been used much by members for years - focus on publishing good stuff and getting views, good comments and features.

Thanks for finding this. I can confirm it in Firefox 10.0.2 on Windows XP and will make sure the dev team are aware of it.

Hi Jayefuu, Many many thanks !!!!

This hasn't discouraged me at all from making any future instructables because i have followed this website for YEARS but have only just started to give back to the community recently and will continue to do so !

Although i hadn't been following this website too religiously as i am nowadays so i thought that my glitch was the only one and was the norm!

Anyhoo, no real harm done, to maintain a MASSIVE website like this there are bound to be a few slips here and there so again, a MAJOR thanks for bringing it to the eyes of the right people!!!