200Views12Replies

Author Options:

I get the message "replace the emergency stop switch" in my treadmill. Answered

Hi. The treadmill is a Life Fitness T7. I would really appreciate any help on how to solve this problem.

Thank you very much in advance.

Discussions

0
None
Desgrac

5 months ago

Hi. Thank you for your replies. Yes, there is a magnetic rounded key that is connected to the console and this key is attached to the user by a cord. The treadmill manual says that if the key is not attached to the treadmill the "replace the emergency stop switch" message will appear. The problem is that the message is appearing even with the key connected to the console.

I have attached two pictures.

In the first one, you will see a yellow area at the bottom. There you can see a half circle magnet. That is where the magnetic key attaches.

I do not know the reason the console is not "detecting" that the key is already connected.

Now, looking at the picture #2, I do not know if "replace the emergency stop switch" could mean to replace the corresponding card (the one labeled 4C, for example) or getting a new console (that would be expensive).

Thank you for your replies. I really appreciate them.

consola1.jpgconsola2.jpg
0
None
Jack A LopezDesgrac

Reply 5 months ago

It is called a reed switch.

https://en.wikipedia.org/wiki/Reed_switch

This is the component the console uses to sense the magnetic field of the magnetic key, or at least that is what it looks like to me. It is that little green glass thing, on the underside of the console, right beneath where the magnetic key goes.

Actually, it is little bit hard to tell what I am looking at, since the picture you upped is kind of lacking in resolution.

But you know, if you open up the console on your treadmill, you will be able to see it for yourself, and compare it to the pictures in the Wikipedia article for "Reed switch", linked above.

By the way, as you can see from the Wiki article, the reed switch is, electrically, a pretty simple thing, basically just two wires.

So, if the contacts of this reed switch, are stuck open for some reason, you could wire another switch, or just a short length of wire, in parallel with the existing reed switch.

Or, just as a quick test, you could temporarily short the reed switch, like with a paper clip or short length of wire, while the console is powered on, and see if this clears the error message.

0
None
DesgracJack A Lopez

Reply 5 months ago

Thank you Jack! Man I was excited to try what you told me. As you can see in the new picture I have attached, there are two Reed switches connected in series. I tried wiring two small clip wires, one for each switch: negative outcome. Then, I used a longer wire going from the first leg of switch 1 to the second leg of switch 2: negative outcome (the "replace the emergency stop switch" was still on). So, now I do not know if the problem is the whole console (the one shown in the previous pictures- called User Pod console). If that is the case, I found this in Ebay:

https://www.ebay.com/itm/Life-Fitness-T5-5-T7-0-Tr...

I could make an effort to spend $200 instead of buying a new one considering that Life Fitness sells the new ones in $450 (a quantity I cannot afford at this time). Now, I have read other posts about the same problem, so it seems it is kind of a common problem. So I would probably just fix the treadmill and sell it as I need the space anyway.

Up until this point, what do you think? Besides wiring the switches, what other options do I have?

Thank you very much! I am learning a lot.

sensor.jpg
0
None
Jack A LopezDesgrac

Reply 5 months ago

Hey. Thanks for the better picture.

I rotated it, cropped it a little, and drew some numbers {1,2, and 3} on the nodes attached to the reed switches.

Also I drew, with pencil and paper, a diagram of how I imagine the wiring to be.

The wiring I am imagining on the main board is really kind of a wild-ass guess, since I cannot actually see that part.

Also I cannot see exactly what is going on with that white ribbon connector (labeled "...B1Z A3" ?). It looks like it has 4 conductors in it, but I am guessing only 2 of them are being used.

Anyway, I think the nodes I labeled 1 and 3 would be a convenient place to solder some little stubs, or loops, made of copper wire, so that you would have something for your clip leads to grasp.

I am guessing: shorting node 1 to 3, e.g. by connecting these with a clip lead, or soldering a wire between them, I am guessing that would fool this console's little microprocessor into thinking the magic magnetic key is in place.

I know you said you already tried this, but I wonder how solidly you had it connected, considering that this wire has to stay connected, and you have to turn it over to see what the display is saying, since the display is on the other side.

Also, regarding the white ribbon connector, I think that can be unplugged, and plugged back in again.

So, if you want, you can disconnect the little daughter board with the reed switches, and test it separately by connecting it to your multimeter ( in resistance measuring mode), and bringing magnets close to it.

Also, with your multimeter, you could attach the probes to nodes 1 and 3, and watch the voltage there. I am guessing it will be some small DC voltage, like 3 to 5 VDC, when the reed switches are open, and 0 volts when the switches are closed.

I mean, that is kind of what we would expect, right? The voltage across a closed switch, across a piece of wire, across a short, being very close to, or exactly, zero volts.

I suppose there is the possibility there could be a break in the ribbon cable, or in the connectors on either end of it. That also would look like an open circuit. However that possibility seems unlikely to me, because usually those things are pretty sturdy.

Regarding money, I would be willing to spend hours of time, before spending hundreds of dollars.

I dunno. I would not give up just yet.

Although I am trying to think what I would do if defeat seemed imminent. Maybe contact that eBay seller you linked to, and see if he, or she, is interested in the parts from your treadmill.

Of course for people like this, hardcore capitalists, there might only be interest at like 1/10,or 1/100, the prices they're re-selling it at.

It would be preferable to fix it yourself, if you can.

Or if you can't fix it, maybe give it away, or use it for parts. The motor could be a handy paperweight, or doorstop. ;-P

There are legends that say the native people of my country (the Former United States) used every part of the Buffalo, and who knows? There might be some truth to those old stories.

treadmill-reed-switch-edit2.jpgtreadmill-reed-switch-wiring-hypothetical.jpg
0
None
DesgracJack A Lopez

Reply 5 months ago

Hey Jack! I solved it! I followed the cables from the user pod console that connect to the bigger console. I noticed one connector was not plugged and it was precisely the one from that cable!

Wow! I really, really appreciate your help! I learned a lot and had the confidence to keep looking for a solution.

Thanks again!

Arturo.

0
None
Jack A LopezDesgrac

Reply 5 months ago

Ah! Success! Well, I am glad to hear I could help in some small way. Also glad to hear your treadmill has been rescued from the dark shadow of the Recycle Bin.

0
None
Jack A LopezJack A Lopez

Reply 5 months ago

Also on the topic of reed switches:

If you happen to have a DollarTree(r) store in your town, they might have this little gizmo,

https://www.dollartree.com/Battery-Powered-Window-...

they call "Window and Door Alarm", which consists of, a ceramic magnet, a reed switch, and an annoyingly loud, electronic alarm, powered by some coin cell batteries.

The reason for me mentioning this, is in the case that you want a replacement reed switch, or maybe if you just want these parts (the reed switch, the magnet, a circuit to sense if a switch is closed) for to experiment with, and learn how reed switches work.

0
None
Yonatan24

5 months ago

What a tiny button for a stop switch. That should be illegal!

0
None
Jack A Lopez

5 months ago

Have you tried doing what it asked you to do? Have you tried replacing the emergency stop switch?

I dunno. It sounds like good advice to me.

0
None
Jack A LopezJack A Lopez

Reply 5 months ago

By the way, this, "replace the emergency stop switch," message might be alluding to some kind of physical key, or dongle, that must be inserted into the controller console thingy, for to activate the treadmill.

Also I think the dongle is supposed to be attached to the user, by way of a piece of rope or cord.

That way, if the user falls of the treadmill, he or she will pull the dongle out of its slot, and signal to the treadmill to stop running.

I am not sure why it is important to stop the motor in this circumstance. Maybe the absence of motor noise provides the user with a moment of silence, so that he or she might better contemplate this circumstance of why, or how, he or she just fell off a running treadmill.

I found some manuals, from lftechsupport.com, have the word "T7" in the title. There are two I have noticed so far. One for "T7i". One for "T7.0".

https://www.lftechsupport.com/c/document_library/g...

https://www.lftechsupport.com/c/document_library/g...

Both have language suggesting the magic stop dongle is a magnet of some kind.

I mean, look at those documents yourself, and then do a Ctrl-F to search for occurrences of the word, "magnet", in the text of the document.