1379Views23Replies

Author Options:

I just bought 7 555ic timers, all of them are faulty? Answered

i bought 7    555ic timer. i tried to blink an led but the output always stays high. when i swapped the 555 by a 556 it then worked.


first i thought that my circuit was wrong. i've verified it countless times all seemed to be good but the pin 3 output was always high. when i used the 556 timer with same components it worked. is the 555 timer at fault or i am missing something?

Discussions

0
None
padmanabhapsimha

7 years ago

the frequency of your output may be too high. try using higher value resistors and capacitors between pin 6-7,7-8 (put a 100 k ohm variable and check out which value is the one you want. use a 0.47uF capacitor between pins 1 and 2.

0
None
lemonie

7 years ago


I think there is just 1 faulty thing, and it's not in the 555s. Please show us the rest of it.

L

0
None
ARJOONlemonie

Answer 7 years ago

note that the transistor 2n22222 has been removed and the led has been conected in series with a resistor to the pin3 of the timer

2.bmp1.bmp
0
None
AndyGadgetARJOON

Answer 7 years ago


I've not looked at this in detail, but the thing which strikes me is that there's no resistor in the base lead of the transistor.  That will either blow the 2N2222 or limit the 555 output to 0.7V and heat up the IC and tranny.

0
None
lemonieAndyGadget

Answer 7 years ago


I diagram helps doesn't it, I think we'll get there on this one.

L

0
None
AndyGadgetlemonie

Answer 7 years ago

 
Moreso if I'd read his comment first - The 2222 has been removed.
Arjoon, do you have a working 555 anywhere?  A simple substitution will tell you immediately what's at fault.

0
None
ARJOONAndyGadget

Answer 7 years ago

as i said when i used a half 556 it worked.

Pin designation, 555 first then 556 A then 556 B if applicable:
Format is Name: 555 pin # - 556A,B
Gnd: 1 - 7
Trigger: 2 - 6,8
Output: 3 - 5,9
Reset: 4 - 4,10
Control: 5 - 3,11
Threshold: 6 - 2,12
Discharge: 7 - 1,13
+V: 8 - 14

0
None
verenceARJOON

Answer 7 years ago

If it worked with a appropriately rewired 556, so either the 555s are bad or you are using the devices at an limit where the 556 works but the (fine) 555s don't.

I see two possibilities:
a) try to find another 555 that works and use this
b) leave the 556 in place and enjoy a working (although not elegant) circuit

0
None
ARJOONAndyGadget

Answer 7 years ago

the transistor has been removed. the resistor was soldered to the back of the pcb because i didn't want to use more of the costly pcb. just have a look at the pcb and the pin 3 of the timer and the base of the transistor are not connected to any component so the a resistor was soldered on the pcb side

0
None
ARJOONlemonie

Answer 7 years ago

some lines on the pcb is not shown. i just soldered wire.

0
None
verence

7 years ago


How could you swap the 555 with a 556? The 555 has a 8 housing, the 556 is like two 555s in a 14 pin housing with a different pin out. If you rewired the circuit, I'd guess you corrected any fault while doing so.

Can you show the schematic of your circuit and what is the exact labelling of you 555s?

0
None
rickharrisARJOON

Answer 7 years ago

Interesting I had never noticed you could use half a 556 directly in the 555 8n pin socket - Still it's a circuit problem unless you got the ICs by the Kg, in which case they may be anything.

0
None
verencerickharris

Answer 7 years ago

> I had never noticed you could use half a 556 directly in the 555 8n pin socket

That's because you can't. The pins of the first half are on one side (1 to 6), the pins of the second half on the other side (8..13).

See here: http://www.kpsec.freeuk.com/555timer.htm

0
None
rickharrisverence

Answer 7 years ago

Nope, even looking at your page you CAN pins 11,122,13,14 = 5, 6, 7, 8 !!!!!

0
None
verencerickharris

Answer 7 years ago

Look again. Say, you put the 14pin IC into the 8pin socket with IC pin 1 in socket pin 1. So pins 5..10 of the IC will be in the air. The IC gets no proper ground (pin 7). Pins 1 to 4 are of one 555 in the 556 (that's what the 'A' means). Pins 11..13 are of the other 555 of the 556 (that's what the 'B' means). So neither half of the 556 is properly connected. To use half of the 556, you would have to connect pins 1..7 and 14 OR 8 to 14.

0
None
rickharrisverence

Answer 7 years ago

Yes I see what you mean. Could it be that the 556 will allow a ground through another pin?

The author seems to think it worked.

BUT on the evidence - your right and I was totally wrong 555=556 no! unless socket changed.

0
None
verencerickharris

Answer 7 years ago

> Could it be that the 556 will allow a ground through another pin?

Not sure for the 555, but on some occasions an IC might work with a faulty or missing GND connection (don't ask me why I know that ;-) ... ). Internal diodes (intentional for ESD protection or parasitic) will allow the current to flow out of a grounded pin - might even be an input pin connected to a low output of another chip. This other chip might be damaged by the high current into the output and the not grounded chip will suddenly stop working once the output goes high. Fun to find the problem...

But as it seems from more current comments of the OP, he didn't plug in the 556 directly, but used a different (and probably correct) pinout. So this whole discussion was kind of pointless.

0
None
seandogue

7 years ago

try attaching a 1K-10K (somewhere in that vicinity) resistor between the 555 output and ground, before the base of the transistor, to load the output..

0
None
Quercus austrina

7 years ago

Really, we can't get a good grasp on exactly what the problem is if you don't show exactly what you did. Forget the other schematics, draw yours as it is in the real world, take a clear picture or 2, give us the actual situation of when it worked and when it failed. Then we can (hopefully) get to the bottom of the problem.

As for the 555/556 debate, no direct correlation to physical layout, but if you wired as per the datasheet, using only one set of pins(A or B, not both) for the 556 and translated to the 555 correctly, it should work.

Pin designation, 555 first then 556 A then 556 B if applicable:
Format is  Name: 555 pin # - 556A,B
Gnd: 1 - 7
Trigger: 2 - 6,8
Output: 3 - 5,9
Reset: 4 - 4,10
Control: 5 - 3,11
Threshold: 6 - 2,12
Discharge: 7 - 1,13
+V: 8 - 14

So show us exactly what you did so we can help.

Qa

0
None
AndyGadget

7 years ago


So are you actually using them in the same socket, or in two different circuits? (They can't possibly work in the same socket as you'll be using half of timer A and half of timer B of the 556.)
What you really need is a KGU - a Known Good Unit to test against in the 555 circuit. You must have another 555 somewhere in one of your HV circuits. If it works, it's the chips. If not, check and re-check your wiring until you find the fault.
It's very unlikely that all chips from a batch are faulty if they're from a reputable dealer. If it was a job lot from an eBay shop in China, well . . . anything's possible.

0
None
orksecurity

7 years ago

It is extremely uncommon for integrated circuits to be faulty. ALWAYS suspect your circuit first.

0
None
rickharris

7 years ago

Not impossible BUT Incredibly highly unlikely that all are faulty. Something else is wrong..

I concur over swap 556 for 555 can't be done directly.