Author Options:

Ipad Comment Problem Answered

For some reason I can't type any comments on instructables from my ipad. Whenever I type nothing happens and it is really annoying! This is the only website were I have that problem and it has only been happening for a week.  Is this my fault or is it just a bug in the website?


When I'm on the iPad I usually use a bluetooth keyboard. What I've found in both Safari and Chrome (when working on an 'ible, not commenting) is that even when focus is in the text box and the arrow keys or backspace key both work, text entry is not recognized, and no amount of tapping into the field helps.

However, if I tap a different text field, such as the "Title," then tap into the text field, I can resume my typing. It also works if I save, then refresh, then tap in.

So it feels like a weird IOS problem with focus. Extra strange that some keys on the BT keyboard would register, making it look like the focus was correct, only to disallow plain old numbers and letters.

This may coincide with manual saves and auto-saves, as well as clipboard operations.

As I mentioned, I haven't noticed this in comments, only while making an instructable. And I haven't noticed the issue with the IOS on-screen keyboard, because I use a BT one. But it sure sounds like we may be dealing with a similar frustration.

Just chiming in,



This occasionally happens to me, I'm on an IPad almost all the time when I'm on instructables. For me, just tapping the comment box a second time will solve it, but my guess is that you've tried that already.

I have tried tapping it twice and nothing happens and for me it doesn't happen occasionally it happens every time. :(

I can leave comments on an iPad and on my smartphone on both the regular and mobile version of the site. Can you give us more details?
(I did notice there was a slight delay after hitting 'post' to when the comment appeared)

Well what happens is that when I start touching the keyboard to right a comment it doesn't type anything. I haven't had this problem on an iphone only on the ipad 2.

Which part doesn't work? Are you logged in? What happens when you click "Add comment"? Or does it just not post the comment when you click "Post Comment"?