Author Options:

Linux App Install Issues Answered

I've spent most of the afternoon trying to get Supertux 2 (a.k.a. 0.3.1) running on my computer. Put simply, I didn't really get anywhere. The obvious first option for me is Synaptic, but it only had the original 0.1.3 release. So... I've got to try to install something with a command line. Not something I've sucessfully done before.

If it helps any, I'm running Knoppix 6 on a cheapo Acer netbook.

So... first I got the .tar.bz2 file. easy enough. Uncompressed it. Everything I can find says I'm supposed to only have to use four command-line instructions:

cd /home/knoppix/supertux-0.3.1
make install

but wait... after trying this it became apparent that makewasn't on my system (what kind of system is that?). So, with the help of Synaptic, I got make on there, tried it again, and it still didn't work. After looking at the Supertux docs it turned out it wanted cmake. Well, no problem, right? I've got Synaptic, right? Wrong. The server was down or something and Synaptic couldn't help me. So, I look in the docs again, and it says something called jam is supposed to work in basically the same way. So I get that with Synaptic (successfully), but on the third line ("jam") it it tells me

./Jamconfig: No such file or directory
Couldn't find config. Please run 'configure' first.

What? What's ./Jamconfig? Didn't I just run configure?

I'm clueless. Any idea what's going on here?


I don't know that Jam will work. I've never used it, but the documentation says it uses jam files instead of make files. It appears from the official site that you would have to compile the code and make the jam file youself...no fun.

It also seems that jam is missing its configuration file - it's different from running ./configure for your game, that's totally separate - dunno why. (Tried running "configure?")

I'd try using apt-get (as root...duh). 

$ sudo apt-get install supertux2

Of course you will have to make sure that deb http://archive.ubuntu.com/ubuntu/ karmic universe is added to the other repos, either in Software Sources or by manually editing the sources.list.

If that doesn't work, see http://supertux.lethargik.org/wiki/Download/Stable

(Oh, and try installing cmake again...just for yuks. :) )

Sorry that took so long, the internet's been having an epic fail 'round here.

Supertux does come with jamfiles, so it presumably would work if whatever went wrong with jam didn't go wrong (not that I'd know).

apt-get seems to have the same problem as Synaptic.

A little more detail on how to add repos? I know ubuntu's has the new version, but I wouldn't know what to do about it.

I looked all over their site, but nothing was too helpful... besides, you linked to the 0.1.3 (stable) page, I'm trying to get the unstable version (0.3.1). Yeah, stupid, I know, but it is a much better game.

And, yes, I did try installing cmake three times each with Synaptic and apt-get.

Ah, sorry for the bad links/information in my earlier post then.

You add repositories by going to System>Adminstration>Software sources (that's the nice, easy, gui way). Then go to Other sources and add it. You'll need to google to find out which one to add -  try "supertux repository". :D

Just out of curiosity, what's the problem with apt-get again? That seems strange...

Sys>Admin>Software Sources? I'm running Knoppix, not Ubuntu. The closest thing I can find is Settings>Repositories in Synaptic. I still don't know what to put in there though, and googling "supertux repository" didn't help much (wouldn't know what else to google).

apt-get gives me an error message (I forget exactly what it is) amounting to not being able to get the files from the server.

Doh! Sorry, I keep forgetting you're running knoppix...Yes! That's it exactly. I'm having a hard time finding the correct repository also, though...

Edit: as I was writing this up I found what I think you need instead. Go here and download the .deb and run it (I *think* .debs install fine in Knoppix, since it's derived from Debian, right?). See how that works.

It recognizes it as a debian package, but for all other purposes treats it like a .tar.bz2 archive with nothing more interesting in it than what I've already got.


Really? It won't install? Ummm...I dunno then...