Author Options:

My Power Mac G4 MDD won't turn on! Answered

I have a Power Mac G4 MDD that won't turn on.  When you push the power button It lights up, but when you realese the power button the light just fades out. Sometimes even when I get it running it turns itself off after a random amount of time.  Every time I unplug the machine it does it's routine. I am experienced with electronics so feel free to post a comment below!  Thanks!



Best Answer 6 years ago

This is a common problem with Macs. The internal clock has its own battery backup. If that battery runs down (typically after 3-5 years), the system won't power up. Open the case and you can replace the battery, or you can take it to a shop and pay them to do it.

Kelseymh I have an old G4 i haven't turned it on in a while so when I tried the other day i was surprised when it didn't power up at all do you think this could be my problem because I was thinking it was the power supply Im going to try the battery to day do I just put it in or is there a step or two

Just replace the battery, close up the shell and turn it on. If you've set it up to get the time from NTP, everything should be just fine. Good luck!

This fourm is ancient history. Its fixed now and dual booting 10.5 Leopard, and Ubuntu 12.04. It was a power supply issue.

This seems to be the answer to my question!
(And you thought you were to "simple-minded!"

I don't think this is the problem... The battery lights up a battery just fine.

I realise this thread is ancient but I found a fix. The ide cable that connects the optical drive to the mother board had failed. Apparently there is enough vibration in the machine that over the years, it had worn a spot on the cable out and caused a short.

By removing that cable I was able to get the machine to start again.


What was your solution? Mine just started exhibiting this symptom. Was running yesterday. Not today.

Not that I'm aware of. Resetting the PMU is the closest thing (different from the CUDA reset). For a full PMU reset (when your computer won't power on, or has stopped responding, i.e., won't power down); you need to turn it off, disconnect ALL the cables from the computer (including the peripherals and power). Then press the CUDA/PMU button only ONCE. Wait a full 10 seconds, then reconnect all the cables you disconnected and supposedly, you should be able to power it up. If you tried this already, then you may have to get it looked at by an Apple Tech.

I read a bunch of forums on Apple.com and figured out that it is probably the batterie. I am going to order one on eBay for 4.79 US dollars. Free shipping!

So it worked! For a while.
I got it running for two days but today it powered off unexpectively. The fans stopped spinning, everything turned off

If you haven't already, check the most obvious things first (that many people forget to check), like the power supply at the back of the machine, the power bar (reset?), the plug at the power bar, the power bar plug to the outlet and the circuit breaker for that outlet. Sometimes its just that simple.

You could also try to reseat the PCI and Graphics Cards.

If that doesn't work, then I would suggest that you remove the battery, unplug everything (including the power cord, peripherals, monitor, mouse, keyboard etc) and leave it that way overnight. Then plug everything back in the next day and see if it will power up.

Either something came loose, needed or needs resetting or something has fried.

Ok, I know that this is kind of an "OUTDATED" post, but i figured something out. Sometimes it will turn on... And sometimes it wont. So I finally decided to take it in to someone that I know that repairs computers at a good price. He thinks it is the power supply. But we will soon find out!

iApple guy

Ahhhh! I'm late! Well I got it back on about July 20-25 with a good power supply. Oh, and by the way I use my mdd as my main computer. I do not have ANY INTEL MACS! If I had one it would be my main computer.

I have had this 'non power up' issue,

it's a G4 MDD 1.25 Dual FW400 running 10.4.11

It's been running with a flat p-ram battery for a year, clock is picked up via internet so no problems on that front.

anyway I have just replaced that and it made no difference.

What seems to work is leaving the mains switched on!

If I turn off the Mac and turn off the mains, when I come back the mac won't start for about 1/2 hour. Originally I was swapping for an alternate kettle lead but found that just leaving it worked?
Could it be the earthing or a static charge that stops the mac from powering up?


I've got an MDD I managed to get used/well-flogged & the 1st item that was always a concern was this very problem- at first I could solve the problem by unplugging & plugging back in which was resetting the Power Supply Unit's [PMU] main reset... After a while, most MDDs blow the unit [capacitor failure from cheap-source manufacturing; go figure, right?] and mine was no exception...

That said- this evening we had a power failure [lightening in the area] and once everything came back up, I thought I had a blown PSU- even though it was a new/refab with SUPERIOR parts [guy on eBay does them- I recommend him HIGHLY] not even 6 month old!

Well- it turns out that some of the MDDs are reeeeally finicky when it comes to power-down or power failure style shutdowns- mine is the 877[?]mhz model and when I noticed 'canuckgirl's' recommendation concerning a "Full PMU Reset" [unplug EVERYTHING- THEN restart] wouldn't you know it- I was able to fire this bad/old boy right up..!

Sadly- if your [iAppleGuy] MDD has not had a PSU change/upgrade, you may be suffering from what's been considered an "inevitable" problem with this model/platform which is a catastrophic PSU capacitor failure...

I hope you're able to get it back up and running- this model has been my favorite so far [and for so long] though a G5 [with a modified/corrected liquid cooling system!] certainly wouldn't be turned down if/when I come across it!

Just a side note to keep in mind, read ALL comments before posting one! You must have put effort into that comment, but if you look down below I'm sure you will notice something. Read the comment that was posted July 11 2012 at 1:26 PM:

Ok, I know that this is kind of an "OUTDATED" post, but i figured something out. Sometimes it will turn on... And sometimes it wont. So I finally decided to take it in to someone that I know that repairs computers at a good price. He thinks it is the power supply. But we will soon find out!

iApple guy

So in the end I did replace the power supply... And it works.
So just make sure to read ALL comments first!

Ya, that's what I thought...

Perhaps you could try kelseymh again, or wait and see if someone else has any ideas. I agree with you, that it doesn't seem like a battery issue (since you have lights), but I'm not sure if that applies to a draining battery as well (it might). So you could try replacing that (they aren't terribly expensive - under $5 online). Beyond that, all the symptoms suggest a PMU issue to me, and I can't honestly think of anything else. (sorry). :-(

I thought about it for a while and thought "is there a way to force boot this computer?"

So after all that the draining battery turned out to be the problem anyway?

Oh okay. I wasn't sure either, that's why I suggested it as an option (since they're fairly cheap). I'm just interested in knowing what the problem was/is. So if you do find out for sure, let me know. ;-)

Well, what you describe sounds more like a PMU issue (at least those are very common symptoms).

To reset the parameter RAM to default values, start with it shut down. Then hold the Command, Option, P and R keys simultaneously and restart the computer. If the computer manages to start up, you can release the keys when you hear the startup sound the second time. That will reset it.

So you got roughly +28V connecting pin 11 to black and pin 22 to red? Did you bother doing the next part of the test? (I was sure the power supply was the issue)...

What about my additional comment/question above regarding the CUDA/Logic?

Yes I have gone on with all of the test. Before I posted this question I had it running but when I powered it on logged in etc. it would turn off after a random amount of time. When it does this it does not properly turn off, it just powers down.
I just reset the CUDA after doing all of the tests. Sometimes my problem is the RAM. Is there a specific way that I need to seat the RAM?

If you have volt meter, you should check it (at least to rule it out).

I read the WARNING. Exposes you to high voltages... NO IT DOES NOT!

I am resetting the CUDA switch right now I did not know that you had to take the battery out for 10 minutes while resetting.

Yes. I noticed that also. ;-)

Let me know if that works or not.

Thanks for your post! But... I have already tried that.

Blargh. It sounds like you've done as many of the available diagnostics and "reset" actions as possible. Canucksgirl is pretty well versed, so it'd be foolish of me to suggest any simple-minded alternatives. Good luck :-(

Ah... Don't be modest.
(I'm all tapped out of ideas)...

Whoa, wait a minute. Resetting the CUDA chip only requires you to press the reset button (located near the battery). For resetting the Logic Board, you need to remove the battery and leave it out for a minimum of 10 minutes... Can you clarify what you did?