Author Options:

Need for speed Hot pursuit 2 Says that i have a debugger loaded? How can i fix this? Answered

But i don't have any "Debugger" loaded! In fact.its a fresh install of Windows XP Professional. I have tried upgrading DivX,nothing. I tried the thing with msconfig,zilch. I have even tried disabling any services that would interfere with it,Nada Any help? Edit:It says that i have loaded a debugger to try again after the debugger is unloaded,and it does not start the game.



Best Answer 9 years ago


a small tiny driver misbehaving ? i dont know. i also dont use software that fears that i'll debug it and tries to hide away its copyrighted insides

No,Its Xp Pro in Virtual PC ,there are no bad drivers. ITs a fresh install i just installed XP a few days ago

virtual pc is what the game sees as debugger

aeihhh...NO Look,IN virtual PC ,the virtual Machine,It says that error,and within the virtual OS Virtual Pc is not even installed!

the os inside sees virtual pc as a debugger (well i guess basically it is a debugger) while windows does not really mind the game knows that it is run on a virtual computer and does not like it

no in fact the os inside virtual pc cant to anything to my Real Pc even if i loaded the WORLDS BEST VIRUS into virtual pc all it can effect is the virtual harddrive

your real pc is not related to the issue the game knows that you run it in virtual pc and does not like it cause virtual pc is like a debugger for the stuff that runs inside it

No,no game can detect that the os is running in an emulator nor any program!

do you think the emulater is perfect ? it is not ! every software can do some tests to see if its inside an emulator. it can feel that it is running in a plasticky world windows does not really mind being emulated (and probably does not bother to do any of the tests) your game minds and is unhappy with it

i will start with,do you know what an emulator is? Virtual pc is from microsoft by the way...also the only way for any program,such as Virtual machine additions is by sending something through the network and while it is being sent out Virtual pc sees that and returns something...that thing that is sent is maybe a randomly generated serial of something that is encrypted with a key that virtual pc knows Also,since it is from microsoft,it does not have anything to read the memory or processor requests sent or recived. Nor can any emulator can do that ,an emulator is made for the sake of running an on within an os,it was never developed as a hacking tool. and i find myself here answering more questions that what i should be answered too... Also...my problem is common but my scenario is different,most of the time it is that it finds a program that it suspects of being a debugger.

as i allready said - the game can test to see if its in emulator emulator is one of the most usefull reverse engineering tools (and what the game is hiding from is exactly this)

sorry mate,I upgraded to service pack 3 and it starts....it only gives my a graphics error no biggie

quite possible. the game relies on defects in windows and virtual pc for the tests that detect virtual pc / debuggers. maybe sp3 fixed one of the defects the game relied on out of interest - try running the game in xp sp1 / sp2 on a real computer and see if it happens

Really you dont know what your talking about...Vm additions is what it thinks is a debugger

vm additions ? let be. so after all it is part of the vm ha !

No virtual machine additions is a program that you can install on the emulated os

and how easy its now to see that we are emulated ?

if the game sees one of the vm additions installed then its a big clear hint that it is emulated

oh my gosh NOOO Look that game was made before Virtual Pc was created itself!!! Also An emulator was NEVER developed as a hacking tool!

it does not need to know the addon if it suspects some of the activities of this addon thats enough an emulator IS hacking tool. what it matters how it was developed ?

Oh my gosh you don't no what your talking about...Google search virtual pc and emulator in wikipedia before you prove yourself stupid And the addon is still installed and the game starts ok ALSO do you know what it means when it finds the debugger? ITS MISTAKEN IDENTITY

Is it causing you a problem? L

Of course,It is the problem.
It would not be a problem if i did not ask for help,No?

OK, I'll rephrase that to "what is the problem?" What is it doing that needs fixing? L

It does not let me play the game,Because when i try to start it is says "A debugger has been detected,unload the debugger and try again"